aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-xineliboutput
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-07-26 13:16:06 +0000
committerWen Heping <wen@FreeBSD.org>2018-07-26 13:16:06 +0000
commitca4bd2943b2cd3329ef7b040f3e617fb76ca228f (patch)
treef54ce7cad3dbf255cbf26e0d3431bcd9b8beb632 /multimedia/vdr-plugin-xineliboutput
parentd19739216bb9dea209704d841c7aaf003f5b3564 (diff)
downloadports-ca4bd2943b2cd3329ef7b040f3e617fb76ca228f.tar.gz
ports-ca4bd2943b2cd3329ef7b040f3e617fb76ca228f.zip
- Fix build with clang6
PR: 229573 Submitted by: shoesoft@gmx.net
Notes
Notes: svn path=/head/; revision=475369
Diffstat (limited to 'multimedia/vdr-plugin-xineliboutput')
-rw-r--r--multimedia/vdr-plugin-xineliboutput/Makefile2
-rw-r--r--multimedia/vdr-plugin-xineliboutput/distinfo1
-rw-r--r--multimedia/vdr-plugin-xineliboutput/files/patch-frontend.c11
-rw-r--r--multimedia/vdr-plugin-xineliboutput/files/patch-osd.c11
-rw-r--r--multimedia/vdr-plugin-xineliboutput/files/patch-tools_sdp.h11
-rw-r--r--multimedia/vdr-plugin-xineliboutput/files/patch-tools_udp__pes__scheduler.c11
-rw-r--r--multimedia/vdr-plugin-xineliboutput/files/patch-xineliboutput.c11
7 files changed, 57 insertions, 1 deletions
diff --git a/multimedia/vdr-plugin-xineliboutput/Makefile b/multimedia/vdr-plugin-xineliboutput/Makefile
index a62cdf1b4690..77555dc351f2 100644
--- a/multimedia/vdr-plugin-xineliboutput/Makefile
+++ b/multimedia/vdr-plugin-xineliboutput/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vdr-plugin-xineliboutput
PORTVERSION= 1.0.90s20120511
-PORTREVISION= 21
+PORTREVISION= 22
CATEGORIES= multimedia
MASTER_SITES= SF/xineliboutput/files/xineliboutput/vdr-xineliboutput-${PORTVERSION}/:release \
LOCAL/nox:snapshot
diff --git a/multimedia/vdr-plugin-xineliboutput/distinfo b/multimedia/vdr-plugin-xineliboutput/distinfo
index eabc37a26db4..6273cfed8d9c 100644
--- a/multimedia/vdr-plugin-xineliboutput/distinfo
+++ b/multimedia/vdr-plugin-xineliboutput/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1532570045
SHA256 (vdr/vdr-plugin-xineliboutput-1.0.90s20120511.tar.bz2) = 87d6903cb66e29452c2e0c380dcbe7eed2c5414281a8ebf9be7f7e12b2dd611f
SIZE (vdr/vdr-plugin-xineliboutput-1.0.90s20120511.tar.bz2) = 372415
diff --git a/multimedia/vdr-plugin-xineliboutput/files/patch-frontend.c b/multimedia/vdr-plugin-xineliboutput/files/patch-frontend.c
new file mode 100644
index 000000000000..c788791a98dc
--- /dev/null
+++ b/multimedia/vdr-plugin-xineliboutput/files/patch-frontend.c
@@ -0,0 +1,11 @@
+--- a/frontend.c.orig 2012-05-11 07:37:27 UTC
++++ b/frontend.c
+@@ -91,7 +91,7 @@ void cXinelibThread::KeypressHandler(con
+ if (!remote->Put(key, repeat, release)) {
+ if (!strcmp(keymap, "KBD")) {
+ uint64_t value = 0;
+- sscanf(key, "%"PRIX64, &value);
++ sscanf(key, "%" PRIX64, &value);
+ if (value) {
+ remote->cRemote::Put(KBDKEY(value));
+ return;
diff --git a/multimedia/vdr-plugin-xineliboutput/files/patch-osd.c b/multimedia/vdr-plugin-xineliboutput/files/patch-osd.c
new file mode 100644
index 000000000000..074e367f5b97
--- /dev/null
+++ b/multimedia/vdr-plugin-xineliboutput/files/patch-osd.c
@@ -0,0 +1,11 @@
+--- a/osd.c.orig 2012-05-11 07:37:27 UTC
++++ b/osd.c
+@@ -567,7 +567,7 @@ void cXinelibOsd::Flush(void)
+ int NumColors;
+ const tColor *Colors = Bitmap->Colors(NumColors);
+ if (Colors) {
+- osd_rect_t DirtyArea = {x1:x1, y1:y1, x2:x2, y2:y2};
++ osd_rect_t DirtyArea = {x1:(uint16_t)x1, y1:(uint16_t)y1, x2:(uint16_t)x2, y2:(uint16_t)y2};
+ CmdLut8(i,
+ Left() + Bitmap->X0() + XOffset, Top() + Bitmap->Y0() + YOffset,
+ Bitmap->Width(), Bitmap->Height(),
diff --git a/multimedia/vdr-plugin-xineliboutput/files/patch-tools_sdp.h b/multimedia/vdr-plugin-xineliboutput/files/patch-tools_sdp.h
new file mode 100644
index 000000000000..34ae671d09d6
--- /dev/null
+++ b/multimedia/vdr-plugin-xineliboutput/files/patch-tools_sdp.h
@@ -0,0 +1,11 @@
+--- a/tools/sdp.h.orig 2012-05-11 07:37:27 UTC
++++ b/tools/sdp.h
+@@ -54,7 +54,7 @@ static const char *vdr_sdp_description(c
+ s_data = cString::sprintf(
+ /*** session ***/
+ /* version */ "v=0"
+- /* origin */ "\r\n" "o=%s %u %"PRIu64" IN IP4 %s"
++ /* origin */ "\r\n" "o=%s %u %" PRIu64 " IN IP4 %s"
+ /* name */ "\r\n" "s=%s@%s (multicast %s:%d)"
+ /* opt:info */ /*"\r\n" "i=vdr-xineliboutput primary device output"*/
+ /* time */ "\r\n" "t=0 0"
diff --git a/multimedia/vdr-plugin-xineliboutput/files/patch-tools_udp__pes__scheduler.c b/multimedia/vdr-plugin-xineliboutput/files/patch-tools_udp__pes__scheduler.c
new file mode 100644
index 000000000000..3a65825fa062
--- /dev/null
+++ b/multimedia/vdr-plugin-xineliboutput/files/patch-tools_udp__pes__scheduler.c
@@ -0,0 +1,11 @@
+--- a/tools/udp_pes_scheduler.c.orig 2012-05-11 07:37:27 UTC
++++ b/tools/udp_pes_scheduler.c
+@@ -674,7 +674,7 @@ void cUdpScheduler::Schedule(const uchar
+
+ if (DATA_IS_TS(Data)) {
+ if (ts_get_pcr_n(Data, Length/TS_SIZE, &pts)) {
+- LOGSCR("UDP PCR: %"PRId64, pts);
++ LOGSCR("UDP PCR: %" PRId64, pts);
+ ScrSource = eScrFromPcr;
+ elapsed = CalcElapsedVtime(pts, eScrFromPcr);
+ }
diff --git a/multimedia/vdr-plugin-xineliboutput/files/patch-xineliboutput.c b/multimedia/vdr-plugin-xineliboutput/files/patch-xineliboutput.c
new file mode 100644
index 000000000000..31261ecf2560
--- /dev/null
+++ b/multimedia/vdr-plugin-xineliboutput/files/patch-xineliboutput.c
@@ -0,0 +1,11 @@
+--- a/xineliboutput.c.orig 2012-05-11 07:37:27 UTC
++++ b/xineliboutput.c
+@@ -104,7 +104,7 @@ const char cmdLineHelp[] =
+ " fbfe (framebuffer)\n"
+ " none (only remote frontends)\n"
+ " -r PORT --remote=PORT Listen PORT for remote clients\n"
+-" (default "LISTEN_PORT_S")\n"
++" (default " LISTEN_PORT_S ")\n"
+ " none or 0 disables remote mode\n"
+ " Also local interface address can be specified:\n"
+ " --remote=<ip>:<port> (default is all interfaces)\n"