aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2023-03-08 20:24:47 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2023-03-10 14:02:20 +0000
commit345272090c1216afd333c23a5b06494cb1961333 (patch)
tree3dd557bb3604c339e47394af21202906f802ce9c /multimedia/vlc
parent5a89b90f39d146d2e74df12e96aee8d029281fa8 (diff)
downloadports-345272090c1216afd333c23a5b06494cb1961333.tar.gz
ports-345272090c1216afd333c23a5b06494cb1961333.zip
multimedia/vlc: Turn off ASLR
Starting with 13.2, elf processes will have ASLR turned on by default. However, the vlc binary core dumps with ASLR on, so turn it off until a proper fix can be found. This fix is based on a discussion between emaste and Peter <pmc@citylink.dinoex.sub.org>. See also: https://lists.freebsd.org/archives/freebsd-stable/2023-March/001181.html PR: 270038 Reviewed by: emaste, mjg, riggs Approved by: multimedia (tcberner, maintainer) Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D38994
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 36997c57686f..121909074eab 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -1,6 +1,6 @@
PORTNAME= vlc
DISTVERSION= 3.0.18
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 4
CATEGORIES= multimedia audio net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
@@ -26,10 +26,12 @@ BUILD_DEPENDS= gsed:textproc/gsed \
yasm:devel/yasm
RUN_DEPENDS= ffmpeg>=3.4.1,1:multimedia/ffmpeg
-USES= compiler:c++17-lang cpe desktop-file-utils gettext-tools gmake gnome \
- iconv:wchar_t libtool localbase pathfix pkgconfig tar:xz
+USES= compiler:c++17-lang cpe desktop-file-utils elfctl gettext-tools \
+ gmake gnome iconv:wchar_t libtool localbase pathfix pkgconfig \
+ tar:xz
CPE_VENDOR= videolan
+ELF_FEATURES= +noaslr:bin/.libs/vlc # See PR 270038
# VLC git (post 2.2.4) requires C++11 support and passes the appropriate flag
# to the compiler. Until the port is updated, we explicitly pass -std=c++11 to