aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vlc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-04-29 18:52:20 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-04-29 18:52:20 +0000
commit6512c114940f49b71eebe3e98b17c5bb1527de4d (patch)
tree357689ebd0115be81629a069d67c5e2b923a1d64 /multimedia/vlc
parent7fd5dedca84fb937e62865d1521495031691f5b9 (diff)
downloadports-6512c114940f49b71eebe3e98b17c5bb1527de4d.tar.gz
ports-6512c114940f49b71eebe3e98b17c5bb1527de4d.zip
multimedia/vlc: update to 3.0.10
PR: 246016 Reported by: VVD <vvd@unislabs.com> MFH: 2020Q2 Security: CVE-2019-19721 CVE-2020-6071 CVE-2020-6072 CVE-2020-6073 CVE-2020-6077 CVE-2020-6078 CVE-2020-6079
Notes
Notes: svn path=/head/; revision=533383
Diffstat (limited to 'multimedia/vlc')
-rw-r--r--multimedia/vlc/Makefile3
-rw-r--r--multimedia/vlc/distinfo6
-rw-r--r--multimedia/vlc/files/patch-libplacebo-1.18101
-rw-r--r--multimedia/vlc/files/patch-modules_codec_aom.c10
-rw-r--r--multimedia/vlc/files/patch-share_Makefile.in6
5 files changed, 7 insertions, 119 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 89725e5b788e..b0df34c3daa1 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= vlc
-DISTVERSION= 3.0.8
-PORTREVISION= 22
+DISTVERSION= 3.0.10
PORTEPOCH= 4
CATEGORIES= multimedia audio net www
MASTER_SITES= http://download.videolan.org/pub/videolan/${PORTNAME}/${DISTVERSION:S/a$//}/ \
diff --git a/multimedia/vlc/distinfo b/multimedia/vlc/distinfo
index 03005d42adc5..d7b6d5dc12d2 100644
--- a/multimedia/vlc/distinfo
+++ b/multimedia/vlc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566290066
-SHA256 (vlc-3.0.8.tar.xz) = e0149ef4a20a19b9ecd87309c2d27787ee3f47dfd47c6639644bc1f6fd95bdf6
-SIZE (vlc-3.0.8.tar.xz) = 26041520
+TIMESTAMP = 1588135602
+SHA256 (vlc-3.0.10.tar.xz) = a966abfc7f3b2ff3adaa130306ecaf5d6ad3b6dc73385fc9ab0c1204029d4c31
+SIZE (vlc-3.0.10.tar.xz) = 26096828
diff --git a/multimedia/vlc/files/patch-libplacebo-1.18 b/multimedia/vlc/files/patch-libplacebo-1.18
deleted file mode 100644
index 50379dcb2272..000000000000
--- a/multimedia/vlc/files/patch-libplacebo-1.18
+++ /dev/null
@@ -1,101 +0,0 @@
-https://code.videolan.org/videolan/vlc/commit/b579384a2396
-https://code.videolan.org/videolan/vlc/commit/29773f496f33
-https://code.videolan.org/videolan/vlc/commit/24dc03640d3c
-
---- modules/video_output/opengl/fragment_shaders.c.orig 2018-12-16 20:40:54 UTC
-+++ modules/video_output/opengl/fragment_shaders.c
-@@ -616,7 +616,13 @@ opengl_fragment_shader_init_impl(opengl_tex_converter_
- color_params.intent = var_InheritInteger(tc->gl, "rendering-intent");
- color_params.tone_mapping_algo = var_InheritInteger(tc->gl, "tone-mapping");
- color_params.tone_mapping_param = var_InheritFloat(tc->gl, "tone-mapping-param");
-+# if PL_API_VER >= 10
-+ color_params.desaturation_strength = var_InheritFloat(tc->gl, "desat-strength");
-+ color_params.desaturation_exponent = var_InheritFloat(tc->gl, "desat-exponent");
-+ color_params.desaturation_base = var_InheritFloat(tc->gl, "desat-base");
-+# else
- color_params.tone_mapping_desaturate = var_InheritFloat(tc->gl, "tone-mapping-desat");
-+# endif
- color_params.gamut_warning = var_InheritBool(tc->gl, "tone-mapping-warn");
-
- struct pl_color_space dst_space = pl_color_space_unknown;
---- modules/video_output/opengl/vout_helper.c.orig 2018-10-10 14:20:20 UTC
-+++ modules/video_output/opengl/vout_helper.c
-@@ -628,7 +628,9 @@ opengl_init_program(vout_display_opengl_t *vgl, struct
- .log_level = PL_LOG_INFO,
- });
- if (tc->pl_ctx) {
--# if PL_API_VER >= 6
-+# if PL_API_VER >= 20
-+ tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL);
-+# elif PL_API_VER >= 6
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0);
- # else
- tc->pl_sh = pl_shader_alloc(tc->pl_ctx, NULL, 0, 0);
---- modules/video_output/opengl/vout_helper.h.orig 2018-02-19 15:53:40 UTC
-+++ modules/video_output/opengl/vout_helper.h
-@@ -151,6 +151,30 @@ static const char * const tone_text[] = {
- #define TONEMAP_WARN_TEXT "Highlight clipped pixels"
- #define TONEMAP_WARN_LONGTEXT "Debugging tool to indicate which pixels were clipped as part of the tone mapping process."
-
-+#define DESAT_STRENGTH_TEXT "Desaturation strength"
-+#define DESAT_STRENGTH_LONGTEXT "How strongly to desaturate bright spectral colors towards white. 0.0 disables this behavior, 1.0 enables full desaturation (hollywood-style)"
-+
-+#define DESAT_EXPONENT_TEXT "Desaturation exponent"
-+#define DESAT_EXPONENT_LONGTEXT "Controls the steepness of the desaturation curve. If you set this to 0.0, the curve will be flat, i.e. desaturation always enabled (hollywood-style)."
-+
-+#define DESAT_BASE_TEXT "Desaturation base"
-+#define DESAT_BASE_LONGTEXT "Controls the starting offset of the desaturation curve. Brightness values below this base will always be colorimetrically tone mapped (never desaturated)."
-+
-+#define MAX_BOOST_TEXT "Maximum brightness boost"
-+#define MAX_BOOST_LONGTEXT "Maximum allowed brightness boost to compensate for dark scenes. A value of 1.0 means no brightness boost is allowed."
-+
-+#define PEAK_PERIOD_TEXT "HDR peak detection period"
-+#define PEAK_PERIOD_LONGTEXT "This option enables peak detection with the specified smoothing period. A value of 0.0 disables peak detection. Higher values result in a larger smoothing period which means the detected values will be stable over a longer number of frames, at the cost of responding more slowly to changes in scene brightness"
-+
-+#define SCENE_THRESHOLD_LOW_TEXT "Scene change lower threshold"
-+#define SCENE_THRESHOLD_LOW_LONGTEXT "When using HDR peak detection, this sets the lower boundary of a brightness change indicating a scene change. Brightness changes between frames that exceed this threshold will begin to be mixed into the detected peak more strongly, bypassing the peak smoothing. Setting this to a negative number disables this logic."
-+
-+#define SCENE_THRESHOLD_HIGH_TEXT "Scene change upper threshold"
-+#define SCENE_THRESHOLD_HIGH_LONGTEXT "This sets the upper boundary of a brightness change indicating a scene change. Brightness changes that exceed this value will instantly replace the detected peak, bypassing all smoothing. Setting this to a negative number disables this logic."
-+
-+#define DELAYED_PEAK_TEXT "Allow delaying peak detection by up to one frame"
-+#define DELAYED_PEAK_LONGTEXT "In some cases, peak detection may be more convenient to compute if the results are delayed by a frame. When this option is disabled, libplacebo will use an indirect buffer simply to force peak detection results to be up-to-date. Enabling it allows skipping this indirection in order to improve performance at the cost of some potentially noticeable brightness flickering immediately after a scene change."
-+
- #define DITHER_TEXT "Dithering algorithm"
- #define DITHER_LONGTEXT "The algorithm to use when dithering to a lower bit depth (degrades performance on some platforms)."
-
-@@ -171,6 +195,22 @@ static const char * const dither_text[] = {
- #define DEPTH_TEXT "Dither depth override (0 = framebuffer depth)"
- #define DEPTH_LONGTEXT "Overrides the detected framebuffer depth. Useful to dither to lower bit depths than otherwise required."
-
-+
-+#if PL_API_VER >= 10
-+#define add_desat_params() \
-+ add_float("desat-strength", pl_color_map_default_params.desaturation_strength, \
-+ DESAT_STRENGTH_TEXT, DESAT_STRENGTH_LONGTEXT, false) \
-+ add_float("desat-exponent", pl_color_map_default_params.desaturation_exponent, \
-+ DESAT_EXPONENT_TEXT, DESAT_EXPONENT_LONGTEXT, false) \
-+ add_float("desat-base", pl_color_map_default_params.desaturation_base, \
-+ DESAT_BASE_TEXT, DESAT_BASE_LONGTEXT, false) \
-+ add_obsolete_string("tone-mapping-desat")
-+#else
-+#define add_desat_params() \
-+ add_float("tone-mapping-desat", pl_color_map_default_params.tone_mapping_desaturate, \
-+ TONEMAP_DESAT_TEXT, TONEMAP_DESAT_LONGTEXT, false)
-+#endif
-+
- #define add_glopts_placebo() \
- set_section("Colorspace conversion", NULL) \
- add_integer("rendering-intent", pl_color_map_default_params.intent, \
-@@ -184,10 +223,9 @@ static const char * const dither_text[] = {
- add_integer("tone-mapping", PL_TONE_MAPPING_HABLE, \
- TONEMAPPING_TEXT, TONEMAPPING_LONGTEXT, false) \
- change_integer_list(tone_values, tone_text) \
-+ add_desat_params() \
- add_float("tone-mapping-param", pl_color_map_default_params.tone_mapping_param, \
- TONEMAP_PARAM_TEXT, TONEMAP_PARAM_LONGTEXT, true) \
-- add_float("tone-mapping-desat", pl_color_map_default_params.tone_mapping_desaturate, \
-- TONEMAP_DESAT_TEXT, TONEMAP_DESAT_LONGTEXT, false) \
- add_bool("tone-mapping-warn", false, TONEMAP_WARN_TEXT, TONEMAP_WARN_LONGTEXT, false) \
- set_section("Dithering", NULL) \
- add_integer("dither-algo", -1, DITHER_TEXT, DITHER_LONGTEXT, false) \
diff --git a/multimedia/vlc/files/patch-modules_codec_aom.c b/multimedia/vlc/files/patch-modules_codec_aom.c
deleted file mode 100644
index 5d131a6751b9..000000000000
--- a/multimedia/vlc/files/patch-modules_codec_aom.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- modules/codec/aom.c.orig 2018-12-19 00:05:20 UTC
-+++ modules/codec/aom.c
-@@ -98,7 +98,6 @@ uint8_t i_needs_hack;
- { VLC_CODEC_I444, AOM_IMG_FMT_I444, 8, 0 },
-
- { VLC_CODEC_YV12, AOM_IMG_FMT_YV12, 8, 0 },
--{ VLC_CODEC_YUVA, AOM_IMG_FMT_444A, 8, 0 },
-
- { VLC_CODEC_GBR_PLANAR, AOM_IMG_FMT_I444, 8, 1 },
- { VLC_CODEC_GBR_PLANAR_10L, AOM_IMG_FMT_I44416, 10, 1 },
diff --git a/multimedia/vlc/files/patch-share_Makefile.in b/multimedia/vlc/files/patch-share_Makefile.in
index b0297f5f6085..79222127a897 100644
--- a/multimedia/vlc/files/patch-share_Makefile.in
+++ b/multimedia/vlc/files/patch-share_Makefile.in
@@ -1,9 +1,9 @@
--- share/Makefile.in.orig 2017-04-06 14:40:37 UTC
+++ share/Makefile.in
-@@ -1700,7 +1700,7 @@ skins2/default.vlt: $(skins2_default_vlt
- $(AM_V_at)rm -f -- skins2/default.vlt.tmp
- $(AM_V_GEN)GZIP=--no-name \
+@@ -1845,7 +1845,7 @@ skins2/default.vlt: $(skins2_default_vlt
+ GZIP=--no-name \
tar cvvzf skins2/default.vlt.tmp \
+ --format=ustar $$tarsort \
- --owner=root --group=root --directory="$(srcdir)/skins2" \
+ --directory="$(srcdir)/skins2" \
default/