aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vvenc
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-01-25 09:20:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-25 09:20:22 +0000
commitb55ffec9a5d54241956a351b396938e5dfb31eba (patch)
tree3dd8800ae82ed57806458787cd13af0f0eefab89 /multimedia/vvenc
parent1e6f41078eae790b4bf937e6a78c2f4c74bdda24 (diff)
downloadports-b55ffec9a5d54241956a351b396938e5dfb31eba.tar.gz
ports-b55ffec9a5d54241956a351b396938e5dfb31eba.zip
multimedia/vvenc: New port: Versatile Video Coding (VVC) encoder
Diffstat (limited to 'multimedia/vvenc')
-rw-r--r--multimedia/vvenc/Makefile29
-rw-r--r--multimedia/vvenc/distinfo3
-rw-r--r--multimedia/vvenc/pkg-descr12
-rw-r--r--multimedia/vvenc/pkg-plist12
4 files changed, 56 insertions, 0 deletions
diff --git a/multimedia/vvenc/Makefile b/multimedia/vvenc/Makefile
new file mode 100644
index 000000000000..68c75d6bd9d7
--- /dev/null
+++ b/multimedia/vvenc/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= vvenc
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7.0
+CATEGORIES= multimedia
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Versatile Video Coding (VVC) encoder
+WWW= https://www.hhi.fraunhofer.de/en/departments/vca/technologies-and-solutions/h266-vvc.html
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= cmake:testing
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+GH_ACCOUNT= fraunhoferhhi
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+CMAKE_OFF+= VVENC_ENABLE_X86_SIMD
+.endif
+
+.if ${ARCH} == powerpc64 || ${ARCH} == riscv64
+CMAKE_OFF+= VVENC_ENABLE_LINK_TIME_OPT
+.endif
+
+.include <bsd.port.mk>
diff --git a/multimedia/vvenc/distinfo b/multimedia/vvenc/distinfo
new file mode 100644
index 000000000000..2cf134ef6f5b
--- /dev/null
+++ b/multimedia/vvenc/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1670954092
+SHA256 (fraunhoferhhi-vvenc-v1.7.0_GH0.tar.gz) = cb73d0ebe1d86f2365f47db4f0982d1239748786c18580e2995361559eb5453c
+SIZE (fraunhoferhhi-vvenc-v1.7.0_GH0.tar.gz) = 2086639
diff --git a/multimedia/vvenc/pkg-descr b/multimedia/vvenc/pkg-descr
new file mode 100644
index 000000000000..5e5e39c43fae
--- /dev/null
+++ b/multimedia/vvenc/pkg-descr
@@ -0,0 +1,12 @@
+The Fraunhofer Versatile Video Encoder (VVenC) is a fast and efficient
+H.266/VVC encoder implementation with the following main features:
+- Easy to use encoder implementation with five predefined
+ quality/speed presets;
+- Perceptual optimization to improve subjective video quality, based
+ on the XPSNR visual model;
+- Extensive frame-level and task-based parallelization with very good
+ scaling;
+- Frame-level single-pass and two-pass rate control supporting
+ variable bit-rate (VBR) encoding;
+- Expert mode encoder interface available, allowing fine-grained
+ control of the encoding process.
diff --git a/multimedia/vvenc/pkg-plist b/multimedia/vvenc/pkg-plist
new file mode 100644
index 000000000000..170db5f86f10
--- /dev/null
+++ b/multimedia/vvenc/pkg-plist
@@ -0,0 +1,12 @@
+bin/vvencFFapp
+bin/vvencapp
+include/vvenc/version.h
+include/vvenc/vvenc.h
+include/vvenc/vvencCfg.h
+include/vvenc/vvencDecl.h
+lib/cmake/vvenc/vvencConfig.cmake
+lib/cmake/vvenc/vvencConfigVersion.cmake
+lib/cmake/vvenc/vvencTargets-shared-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/vvenc/vvencTargets-shared.cmake
+lib/libvvenc.so
+libdata/pkgconfig/libvvenc.pc