aboutsummaryrefslogtreecommitdiff
path: root/multimedia/webcamd
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2021-02-08 09:42:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2021-02-08 09:42:54 +0000
commit8198bb27695bb33962ad69d2f06ba38ae35ea23a (patch)
tree58b9d7115de29b114019010d0a080ab4a2bd0b2d /multimedia/webcamd
parentf98fa4ce5795b0a3b57227cc5f43341521fc891c (diff)
downloadports-8198bb27695bb33962ad69d2f06ba38ae35ea23a.tar.gz
ports-8198bb27695bb33962ad69d2f06ba38ae35ea23a.zip
Drop dependency on HAL
Webcamd does not need hal itself, it only pushes information into it. Given hal is not used anymore anywhere in freebsd, it is time to drop the support for it. Approved by: hselasky (maintainer)
Notes
Notes: svn path=/head/; revision=564686
Diffstat (limited to 'multimedia/webcamd')
-rw-r--r--multimedia/webcamd/Makefile12
-rw-r--r--multimedia/webcamd/files/webcamd.in8
2 files changed, 4 insertions, 16 deletions
diff --git a/multimedia/webcamd/Makefile b/multimedia/webcamd/Makefile
index 0d159306d557..ea80eebc9da0 100644
--- a/multimedia/webcamd/Makefile
+++ b/multimedia/webcamd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webcamd
DISTVERSION= 5.10.6.1
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= hselasky@FreeBSD.org
@@ -23,8 +24,8 @@ GH_PROJECT= ${PORTNAME}
GH_TAGNAME= v${DISTVERSION}
GH_TUPLE= torvalds:linux:v5.10-rc6:linux
-OPTIONS_DEFINE= DEBUG HAL VT_CLIENT VT_SERVER DVB INPUT KEYBOARD MOUSE RADIO WEBCAM
-OPTIONS_DEFAULT=DVB HAL INPUT RADIO WEBCAM
+OPTIONS_DEFINE= DEBUG VT_CLIENT VT_SERVER DVB INPUT KEYBOARD MOUSE RADIO WEBCAM
+OPTIONS_DEFAULT=DVB INPUT RADIO WEBCAM
#
# 32-bit compatibility support is mostly useful for
@@ -36,13 +37,6 @@ OPTIONS_DEFAULT_amd64= COMPAT32
COMPAT32_DESC= Enable 32-bit compatibility support
COMPAT32_MAKE_ARGS= HAVE_COMPAT32="YES"
-HAL_DESC= Build with HAL and DBUS support
-HAL_LIB_DEPENDS+= libhal.so:sysutils/hal
-HAL_LIB_DEPENDS+= libdbus-1.so:devel/dbus
-HAL_MAKE_ARGS= HAVE_HAL="YES"
-HAL_SUB_LIST= LIBHAL="${LOCALBASE}/lib/libhal.so:${LOCALBASE}/lib/libdbus-1.so:"
-HAL_SUB_LIST_OFF= LIBHAL=""
-
DEBUG_MAKE_ARGS= HAVE_DEBUG="YES"
VT_CLIENT_DESC= Build with vTuner client support
diff --git a/multimedia/webcamd/files/webcamd.in b/multimedia/webcamd/files/webcamd.in
index b29a1697dd73..0b3610ed8843 100644
--- a/multimedia/webcamd/files/webcamd.in
+++ b/multimedia/webcamd/files/webcamd.in
@@ -98,19 +98,13 @@ load_rc_config $name
devd_device=${2}
devd_interface=${3-0}
-command=webcamd
+command=%%PREFIX%%/sbin/webcamd
command_args="-B -U ${webcamd_user} -G ${webcamd_group}"
start_cmd="${name}_start"
stop_cmd="${name}_stop"
status_cmd="${name}_status"
-webcamd()
-{
- # When running early we need to pre-load some libraries
- env LD_PRELOAD=%%LIBHAL%% %%PREFIX%%/sbin/webcamd $*
-}
-
webcamd_pids()
{
pids=$(pgrep -d ' ' $name)