aboutsummaryrefslogtreecommitdiff
path: root/multimedia/webcamoid
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /multimedia/webcamoid
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'multimedia/webcamoid')
-rw-r--r--multimedia/webcamoid/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/webcamoid/Makefile b/multimedia/webcamoid/Makefile
index 157b8898a5d2..d5b17a0e7030 100644
--- a/multimedia/webcamoid/Makefile
+++ b/multimedia/webcamoid/Makefile
@@ -17,12 +17,12 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libpulse.so:audio/pulseaudio \
libv4l2.so:multimedia/libv4l
-USES= pkgconfig qmake
+USES= pkgconfig qmake qt:5
USE_GITHUB= yes
USE_GNOME= glib20
USE_GSTREAMER1= yes
USE_GL= gl
-USE_QT5= concurrent core gui multimedia network opengl qml quick svg widgets buildtools_build quickcontrols_run
+USE_QT= concurrent core gui multimedia network opengl qml quick svg widgets buildtools_build quickcontrols_run
MAKE_ENV= NOOSS=1 # NOOSS is because the OSS module attempts to use kevent on OSS devices, which is broken in the base
QMAKE_ARGS= INSTALLQMLDIR=${QT_QMLDIR} \