aboutsummaryrefslogtreecommitdiff
path: root/multimedia/winff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-05-25 16:31:21 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2018-05-25 16:31:21 +0000
commitae635a951dd3d7170fad43cfc661de04960c82cd (patch)
tree7c23ab9b803bf454a97a095273ff2657ce4bd550 /multimedia/winff
parent18e742ef3b4ebc577e401c01a2cb4d2a41880d07 (diff)
downloadports-ae635a951dd3d7170fad43cfc661de04960c82cd.tar.gz
ports-ae635a951dd3d7170fad43cfc661de04960c82cd.zip
- Moved ports to Uses/lazarus.mk
- Add FLAVORS Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D14661
Notes
Notes: svn path=/head/; revision=470851
Diffstat (limited to 'multimedia/winff')
-rw-r--r--multimedia/winff/Makefile51
-rw-r--r--multimedia/winff/files/patch-winff_unit1.pas19
2 files changed, 28 insertions, 42 deletions
diff --git a/multimedia/winff/Makefile b/multimedia/winff/Makefile
index f991a3847181..11bdc5fd48f3 100644
--- a/multimedia/winff/Makefile
+++ b/multimedia/winff/Makefile
@@ -3,8 +3,9 @@
PORTNAME= WinFF
PORTVERSION= 1.5.5
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= multimedia
+PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
MASTER_SITES= http://winff.org/docs/source/
DISTNAME= ${_PORTNAME}-${PORTVERSION}-source
@@ -13,20 +14,15 @@ COMMENT= Convert your videos quickly, easily, and all at once
LICENSE= GPLv3
-BROKEN= fails to build
-
-BUILD_DEPENDS= lazbuild:editors/lazarus
LIB_DEPENDS= libavutil.so:multimedia/ffmpeg
NO_WRKSUBDIR= yes
-USES= fpc
USE_XORG= x11
-USE_FPC= cairo fcl-base fcl-image fcl-json fcl-xml pasjpeg regexpr x11
-USE_GNOME= cairo
+USES= fpc lazarus:flavors
+USE_FPC= chm fcl-base fcl-image fcl-json fcl-xml pasjpeg regexpr x11
_PORTNAME= ${PORTNAME:tl}
DATADIR= ${PREFIX}/share/${_PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/${_PORTNAME}
-INSTALLS_ICONS= yes
DESKTOP_ENTRIES= "${PORTNAME}" \
"${COMMENT}" \
@@ -35,34 +31,19 @@ DESKTOP_ENTRIES= "${PORTNAME}" \
"AudioVideo;" \
true
-LAZBUILD_CMD= ${LOCALBASE}/bin/lazbuild -d
-LAZARUS_VER= 1.8.0
-LAZARUS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}
-LCL_UNITS_DIR= ${LOCALBASE}/share/lazarus-${LAZARUS_VER}/lcl/units/${BUILDNAME}
-
-BUILD_WRKSRC= ${WRKDIR}/${PKGNAME}/${_PORTNAME}
-
-OPTIONS_SINGLE= LCL
-OPTIONS_SINGLE_LCL= GTK2 QT4
-
-GTK2_DESC= Use gtk20 interface
-QT4_DESC= Use qt4 interface
+LAZARUS_NO_FLAVORS= qt5
+LAZARUS_PROJECT_FILES= winff.lpr
+LAZBUILD_ARGS= -d
-OPTIONS_DEFAULT= GTK2
+gtk2_CONFLICTS_INSTALL= ${PORTNAME}-qt4
+qt4_CONFLICTS_INSTALL= ${PORTNAME}-gtk2
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGTK2}
-USE_FPC+= gtk2
-USE_GNOME+= gtk20
-LCL_PLATFORM= gtk2
-BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-gtk2
-.endif
+BUILD_WRKSRC= ${WRKDIR}/${PKGNAME}/${_PORTNAME}
-.if ${PORT_OPTIONS:MQT4}
-LIB_DEPENDS+= libQt4Pas.so:x11-toolkits/qt4pas
-LCL_PLATFORM= qt
-BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:editors/lazarus-lcl-qt
+.if ${FLAVOR:Ugtk2:Mgtk2}
+USE_FPC+= cairo
+USE_GNOME+= cairo
+INSTALLS_ICONS=yes
.endif
pre-configure:
@@ -71,10 +52,6 @@ pre-configure:
${REINPLACE_CMD} -e 's|/usr/bin/|${LOCALBASE}/bin/|g' ${BUILD_WRKSRC}/${fp}
.endfor
-do-build:
- cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${LAZBUILD_CMD} --ws=${LCL_PLATFORM} --lazarusdir=${LAZARUS_DIR} -B winff.lpr
-
do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME:tl} ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DATADIR}/languages
diff --git a/multimedia/winff/files/patch-winff_unit1.pas b/multimedia/winff/files/patch-winff_unit1.pas
index e4a3c9ba5c6e..e272ae6f9916 100644
--- a/multimedia/winff/files/patch-winff_unit1.pas
+++ b/multimedia/winff/files/patch-winff_unit1.pas
@@ -1,6 +1,15 @@
---- winff/unit1.pas.orig 2013-08-16 03:55:46 UTC
-+++ winff/unit1.pas
-@@ -1228,13 +1228,13 @@ end;
+--- winff/unit1.pas 2016-09-21 16:40:54.000000000 -0500
++++ winff/unit1.pas 2018-03-07 17:35:42.310241000 -0500
+@@ -27,7 +27,7 @@
+ {$IFDEF WINDOWS} windows, shellapi, dos,{$endif}
+ {$IFDEF unix} baseunix, unix, {$endif}
+ laz_xmlcfg, dom, xmlread, xmlwrite, StdCtrls, Buttons, ActnList, Menus, unit2, unit3,
+- unit4, unit5, gettext, translations, process
++ unit4, unit5, gettext, translations, process, LazFileUtils, LazUTF8
+ {$IFDEF TRANSLATESTRING}, DefaultTranslator{$ENDIF}, ExtCtrls, ComCtrls, Spin, UTF8Process,
+ PoTranslator, types, FileUtil, regexpr;
+
+@@ -1241,13 +1241,13 @@
// launch browser
procedure TfrmMain.launchbrowser(URL:string);
@@ -16,7 +25,7 @@
s:='';
if fileexists('/usr/bin/konqueror') then s:='/usr/bin/konqueror';
if fileexists('/usr/bin/mozilla-firefox') then s:='/usr/bin/mozilla-firefox';
-@@ -1369,13 +1369,13 @@ end;
+@@ -1382,13 +1382,13 @@
// launch pdf
procedure TfrmMain.LaunchPdf(pdffile:string);
@@ -32,7 +41,7 @@
s:='';
if fileexists('/usr/bin/evince') then s:='/usr/bin/evince';
if fileexists('/usr/bin/kpdf') then s:='/usr/bin/kpdf';
-@@ -1953,7 +1953,7 @@ var s : string;
+@@ -1982,7 +1982,7 @@
language: string;
begin
language:=leftstr(lang,2);