aboutsummaryrefslogtreecommitdiff
path: root/multimedia/wlrobs
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-11-21 00:54:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-11-21 00:54:43 +0000
commit40b12e1fe043150b6cca210ba9c4cfca979f4ccb (patch)
tree68e29bc3242433141c29a9321b91cd399889e30f /multimedia/wlrobs
parent1e1ec076f8479671a6fc438da0f6b43239ee8fdd (diff)
downloadports-40b12e1fe043150b6cca210ba9c4cfca979f4ccb.tar.gz
ports-40b12e1fe043150b6cca210ba9c4cfca979f4ccb.zip
multimedia/wlrobs: add new port
wlrobs is an obs-studio plugin that allows you to screen capture on wlroots-based Wayland compositors. https://hg.sr.ht/~scoopta/wlrobs
Notes
Notes: svn path=/head/; revision=518070
Diffstat (limited to 'multimedia/wlrobs')
-rw-r--r--multimedia/wlrobs/Makefile36
-rw-r--r--multimedia/wlrobs/distinfo3
-rw-r--r--multimedia/wlrobs/pkg-descr4
3 files changed, 43 insertions, 0 deletions
diff --git a/multimedia/wlrobs/Makefile b/multimedia/wlrobs/Makefile
new file mode 100644
index 000000000000..d8b03dac7d16
--- /dev/null
+++ b/multimedia/wlrobs/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= wlrobs
+PORTVERSION= s20191120
+DISTVERSIONSUFFIX= -8b4656a90bc7
+CATEGORIES= multimedia
+MASTER_SITES= https://hg.sr.ht/~scoopta/${PORTNAME}/archive/${DISTVERSIONSUFFIX:S/^-//}${EXTRACT_SUFX}?dummy=/
+MASTER_SITES+= LOCAL/jbeich # https://todo.sr.ht/~sircmpwn/hg.sr.ht/33
+DISTNAME= ${PORTNAME}${DISTVERSIONSUFFIX}
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Wayland screen capture plugin for obs-studio
+
+BUILD_DEPENDS= ${LOCALBASE}/include/obs/obs-module.h:multimedia/obs-studio
+LIB_DEPENDS= libwayland-client.so:graphics/wayland
+
+USES= compiler:c11 gmake localbase:ldflags
+WRKSRC_SUBDIR= Release
+MAKEFILE= makefile
+DATADIR= ${PREFIX}/lib/obs-plugins
+PORTDATA= ${PORTNAME}.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/ -O3//' \
+ -e '/-shared/!s/gcc/$$(CC) $$(CFLAGS)/' \
+ -e '/-shared/s/gcc/$$(CC) $$(LDFLAGS)/' \
+ ${WRKSRC}/makefile \
+ ${WRKSRC}/proto/subdir.mk \
+ ${WRKSRC}/src/subdir.mk
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_LIB} ${WRKSRC}/lib${PORTNAME}.so \
+ ${STAGEDIR}${DATADIR}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/multimedia/wlrobs/distinfo b/multimedia/wlrobs/distinfo
new file mode 100644
index 000000000000..ab98ab523a23
--- /dev/null
+++ b/multimedia/wlrobs/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574287498
+SHA256 (wlrobs-8b4656a90bc7.tar.gz) = eb8ffbfc80c2b6e6888e401d0a222e694fc8fc4a6ac3948cca0bae2acc136dc1
+SIZE (wlrobs-8b4656a90bc7.tar.gz) = 22963
diff --git a/multimedia/wlrobs/pkg-descr b/multimedia/wlrobs/pkg-descr
new file mode 100644
index 000000000000..8216d7264009
--- /dev/null
+++ b/multimedia/wlrobs/pkg-descr
@@ -0,0 +1,4 @@
+wlrobs is an obs-studio plugin that allows you to screen capture on
+wlroots-based Wayland compositors.
+
+WWW: https://hg.sr.ht/~scoopta/wlrobs