aboutsummaryrefslogtreecommitdiff
path: root/multimedia/wlrobs
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-12 17:30:09 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-12 17:30:09 +0000
commitefb5717e026dbaf8c273f4b85887fe0bdd3623e2 (patch)
tree6ee1a317bb845e23725506812da7080859f60e71 /multimedia/wlrobs
parent0b5864f66c9ebdb1fe499427d12253b51ae298d1 (diff)
downloadports-efb5717e026dbaf8c273f4b85887fe0bdd3623e2.tar.gz
ports-efb5717e026dbaf8c273f4b85887fe0bdd3623e2.zip
multimedia/wlrobs: fix build on powerpc64 elfv2
Clang can't build this port, build with GCC: /usr/lib/clang/11.0.0/include/mmintrin.h:50:12: error: invalid conversion between vector type '__m64' (vector of 1 'long long' value) and integer type 'int' of different size return (__m64)__builtin_ia32_vec_init_v2si(__i, 0);
Notes
Notes: svn path=/head/; revision=557842
Diffstat (limited to 'multimedia/wlrobs')
-rw-r--r--multimedia/wlrobs/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/multimedia/wlrobs/Makefile b/multimedia/wlrobs/Makefile
index 326684c5e6d4..94c9000baed6 100644
--- a/multimedia/wlrobs/Makefile
+++ b/multimedia/wlrobs/Makefile
@@ -16,12 +16,19 @@ LICENSE_FILE= ${WRKSRC}/COPYING.md
LIB_DEPENDS= libwayland-client.so:graphics/wayland \
libobs.so:multimedia/obs-studio
-USES= compiler:c11 gl meson pkgconfig
+USES= gl meson pkgconfig
USE_GL= egl
DATADIR= ${PREFIX}/lib/obs-plugins
PORTDATA= lib${PORTNAME}.so
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc64
+USES+= compiler:gcc-c++11-lib
# XXX Move to "pkg-config --cflags libobs"
-CFLAGS_powerpc64= -DNO_WARN_X86_INTRINSICS -maltivec -mvsx
+CFLAGS+= -DNO_WARN_X86_INTRINSICS -maltivec -mvsx
+.else
+USES+= compiler:c11
+.endif
.include <bsd.port.mk>