aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x264
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-12-21 19:00:27 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-12-21 19:00:27 +0000
commit3642ceafef74f24f1d2d42efe67f9e64dd00d6e6 (patch)
treeb67cf732dfd32685ed44d482b0f346835133bcd8 /multimedia/x264
parent192d15559b4049fec5a7be2baf33c7a629c6a6eb (diff)
downloadports-3642ceafef74f24f1d2d42efe67f9e64dd00d6e6.tar.gz
ports-3642ceafef74f24f1d2d42efe67f9e64dd00d6e6.zip
multimedia/x264: update to 0.159.2991
Notes
Notes: svn path=/head/; revision=520577
Diffstat (limited to 'multimedia/x264')
-rw-r--r--multimedia/x264/Makefile30
-rw-r--r--multimedia/x264/distinfo6
-rw-r--r--multimedia/x264/files/patch-configure32
3 files changed, 33 insertions, 35 deletions
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index de15a263e09a..5cfc53576c5e 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -7,24 +7,20 @@
#
# X264_BUILD is the "core" number, and can be found in x264.h.
#
-# X264_COMMIT is the commit number, and can be found here:
-# https://code.videolan.org/videolan/x264/commits/stable
-#
# X264_REV requires a checkout the git revision for the version the port
# is being updated to. Then run version.sh against it.
#
# Bumping PORTREVISION for dependent ports? This is useful:
-# cd $PORTSDIR; for x in $(find . -name "Makefile*" -print);
-# do str=$(grep -i x264.so $x); if [[ -n $str ]] { echo "$x" }; done
+# fgrep -lr --include='*/Makefile*' :multimedia/libx264 $PORTSDIR |
+# sed 's,/Makefile.*,,' | xargs $PORTSDIR/Tools/scripts/bump-revision.sh
+# or
+# rg -l :multimedia/libx264 $PORTSDIR | xargs -n1 portedit bump-revision -i
PORTNAME= x264
PORTVERSION= 0.${X264_BUILD}.${X264_REV}
-PORTREVISION?= 2 # 2 in libx264
+PORTREVISION?= 0
CATEGORIES= multimedia
-MASTER_SITES= https://downloads.videolan.org/pub/videolan/x264/snapshots/ \
- https://samples.mplayerhq.hu/yuv4mpeg2/:pgo
-DISTNAME= ${PORTNAME}-snapshot-${X264_SNAPSHOT}-2245-stable
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= https://samples.mplayerhq.hu/yuv4mpeg2/:pgo
DIST_SUBDIR= x264
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -37,15 +33,17 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS?= libx264.so:multimedia/libx264
-X264_BUILD= 157
-X264_REV= 2980
-X264_COMMIT= 34c06d1c17ad968fbdda153cb772f77ee31b3095
-X264_GITVER= ${X264_COMMIT:C/^(.......).*$/\1/g}
-X264_SNAPSHOT= 20190719
+X264_BUILD= 159
+X264_REV= 2991
+X264_GITVER= ${GL_COMMIT:C/^(.{7}).*/\1/}
USES?= pkgconfig
-USES+= compiler:c11 gmake localbase shebangfix tar:bzip2
+USES+= compiler:c11 gmake localbase shebangfix
+USE_GITLAB= yes
USE_LDCONFIG= yes
+GL_SITE= https://code.videolan.org
+GL_ACCOUNT= videolan
+GL_COMMIT= 1771b556ee45207f8711744ccbd5d42a3949b14c
HAS_CONFIGURE= yes
SHEBANG_FILES= configure
PLIST_FILES?= bin/x264
diff --git a/multimedia/x264/distinfo b/multimedia/x264/distinfo
index 7fcb71a8a60e..c283493c804e 100644
--- a/multimedia/x264/distinfo
+++ b/multimedia/x264/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1563569105
-SHA256 (x264/x264-snapshot-20190719-2245-stable.tar.bz2) = aff7ecdb846cdeefd7ed066fabac4a2bae936eab184f9f2c6eec037a5fbca1e7
-SIZE (x264/x264-snapshot-20190719-2245-stable.tar.bz2) = 770463
+TIMESTAMP = 1574812200
SHA256 (x264/example.y4m.bz2) = a5bec9d37362bd9d7773fbd0644643f9ec096d654d20823004e88d5df32bbff7
SIZE (x264/example.y4m.bz2) = 4910029
+SHA256 (x264/videolan-x264-1771b556ee45207f8711744ccbd5d42a3949b14c_GL0.tar.gz) = 84dfaafd8412bc034058da66d29606aa9ec7e1e7405e97709e63cb7e6fe808ad
+SIZE (x264/videolan-x264-1771b556ee45207f8711744ccbd5d42a3949b14c_GL0.tar.gz) = 932468
diff --git a/multimedia/x264/files/patch-configure b/multimedia/x264/files/patch-configure
index 6564f2058e1c..62f8ea92ede9 100644
--- a/multimedia/x264/files/patch-configure
+++ b/multimedia/x264/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2017-12-25 21:45:05 UTC
+--- configure.orig 2019-11-26 23:50:00 UTC
+++ configure
-@@ -692,12 +692,6 @@ case $host_cpu in
+@@ -728,12 +728,6 @@ case $host_cpu in
AS_EXT=".asm"
ASFLAGS="$ASFLAGS -DARCH_X86_64=0 -I\$(SRCPATH)/common/x86/"
if [ $compiler = GNU ]; then
@@ -13,7 +13,7 @@
CFLAGS="-m32 $CFLAGS"
LDFLAGS="-m32 $LDFLAGS"
fi
-@@ -712,7 +706,7 @@ case $host_cpu in
+@@ -748,7 +742,7 @@ case $host_cpu in
ASFLAGS="$ASFLAGS -f elf32"
fi
;;
@@ -22,7 +22,7 @@
ARCH="X86_64"
AS="${AS-nasm}"
AS_EXT=".asm"
-@@ -786,7 +780,7 @@ case $host_cpu in
+@@ -824,7 +818,7 @@ case $host_cpu in
AS="${AS-${CC}}"
fi
;;
@@ -30,17 +30,17 @@
+ aarch64|arm64)
ARCH="AARCH64"
stack_alignment=16
- AS="${AS-${CC}}"
-@@ -888,7 +882,7 @@ elif [ $compiler = ICC -a $ARCH = X86 ]; then
+ if [ "$SYS" = MACOSX ] ; then
+@@ -937,7 +931,7 @@ if cc_check '' '' '' '__attribute__((force_align_arg_p
fi
fi
-if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
+if [ $cli_libx264 != system -a $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \) ] ; then
if ! as_check "vmovdqa32 [eax]{k1}{z}, zmm0" ; then
- VER=`($AS --version || echo no assembler) 2>/dev/null | head -n 1`
+ VER="$( ($AS --version || echo no assembler) 2>/dev/null | head -n 1 )"
echo "Found $VER"
-@@ -901,9 +895,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \
+@@ -950,9 +944,6 @@ if [ $asm = auto -a \( $ARCH = X86 -o $ARCH = X86_64 \
fi
if [ $asm = auto -a $ARCH = ARM ] ; then
@@ -50,7 +50,7 @@
cc_check '' '' '__asm__("add r0, r1, r2");' && define HAVE_ARM_INLINE_ASM
if [ $compiler = CL ] && cpp_check '' '' 'defined(_M_ARM) && _M_ARM >= 7' ; then
define HAVE_ARMV6
-@@ -914,9 +905,8 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
+@@ -963,9 +954,8 @@ if [ $asm = auto -a $ARCH = ARM ] ; then
cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
ASFLAGS="$ASFLAGS -c"
else
@@ -62,7 +62,7 @@
fi
fi
-@@ -943,9 +933,8 @@ if [ $asm = auto -a $ARCH = MIPS ] ; then
+@@ -997,9 +987,8 @@ if [ $asm = auto -a $ARCH = MIPS ] ; then
if cc_check '' '' '__asm__("addvi.b $w0, $w1, 1");' ; then
define HAVE_MSA
else
@@ -74,7 +74,7 @@
fi
fi
-@@ -1257,10 +1246,6 @@ if cc_check '' -Wshadow ; then
+@@ -1327,10 +1316,6 @@ if cc_check '' -Wshadow ; then
CFLAGS="-Wshadow $CFLAGS"
fi
@@ -82,12 +82,12 @@
- CFLAGS="-Wno-maybe-uninitialized $CFLAGS"
-fi
-
- if [ $compiler = ICC -o $compiler = ICL ] ; then
- if cc_check 'extras/intel_dispatcher.h' '' 'x264_intel_dispatcher_override();' ; then
- define HAVE_INTEL_DISPATCHER
-@@ -1296,6 +1281,9 @@ if [ "$opencl" = "yes" ]; then
+ if [ $compiler = GNU ] && cc_check '' -fvisibility=hidden ; then
+ CFLAGS="$CFLAGS -fvisibility=hidden"
+ fi
+@@ -1370,6 +1355,9 @@ if [ "$opencl" = "yes" ]; then
opencl="yes"
- define HAVE_OPENCL
+ define HAVE_OPENCL "(BIT_DEPTH==8)"
libdl="-ldl"
+ else
+ opencl="yes"