aboutsummaryrefslogtreecommitdiff
path: root/multimedia/x265/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2020-09-21 04:47:33 +0000
committerMikhail Teterin <mi@FreeBSD.org>2020-09-21 04:47:33 +0000
commitdbaa3f3f8e63b4a3f7201a785938bbe8bcb3d469 (patch)
tree560da9f68e4ff85fae15f569b0c95b66d5a7b001 /multimedia/x265/Makefile
parent0339288f0b96f3e78b14977eb934e6a27e2e7529 (diff)
downloadports-dbaa3f3f8e63b4a3f7201a785938bbe8bcb3d469.tar.gz
ports-dbaa3f3f8e63b4a3f7201a785938bbe8bcb3d469.zip
While we were testing the new code, upstream have removed the 3.4
release from download area. Change our port to download using Bitbucket's method. Although the upstream branch Release_3.4 is very similar to what used to be available as 3.4, there are a few improvements -- in particular, one of our patches is no longer necessary, which is nice. PR: 247035 Reported by: John Kennedy, Tomoaki AOKI Sponsored by: United Marsupials
Notes
Notes: svn path=/head/; revision=549419
Diffstat (limited to 'multimedia/x265/Makefile')
-rw-r--r--multimedia/x265/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/multimedia/x265/Makefile b/multimedia/x265/Makefile
index 1ad0be68be0e..1dc91973982a 100644
--- a/multimedia/x265/Makefile
+++ b/multimedia/x265/Makefile
@@ -4,8 +4,7 @@
PORTNAME= x265
PORTVERSION= 3.4
CATEGORIES= multimedia
-MASTER_SITES= https://bitbucket.org/multicoreware/x265/downloads/
-DISTNAME= ${PORTNAME}_${PORTVERSION}
+MASTER_SITES= https://bitbucket.org/multicoreware/x265_git/get/${BB_TAG}.tar.gz?meow=/
MAINTAINER= mi@aldan.algebra.com
COMMENT= H.265/High Efficiency Video Coding (HEVC) format
@@ -15,6 +14,8 @@ LICENSE_FILE= ${WRKSRC:H}/COPYING
USES= cmake compiler:c++14-lang pathfix dos2unix
+BB_TAG= 25b2c07035ff # Top of the Release_3.4 branch at this time
+
OPTIONS_DEFINE= DEBUG OPTIMIZED_FLAGS VMAF
OPTIONS_DEFAULT= OPTIMIZED_FLAGS HI8P HI10P HI12P
OPTIONS_DEFINE_aarch64= ASM
@@ -50,9 +51,9 @@ VMAF_DESC= Per frame and aggregate VMAF score
USE_LDCONFIG= yes
CMAKE_ARGS= -DENABLE_TESTS=on -DENABLE_HDR10_PLUS:BOOL=true
LDFLAGS_i386= -Wl,-znotext
-EXTRACT_AFTER_ARGS+= --exclude compat
+EXTRACT_AFTER_ARGS+= --exclude compat --strip-components=1
PATCH_WRKSRC= ${WRKSRC:H}
-WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}/source
+WRKSRC= ${WRKDIR}/source
.include <bsd.port.options.mk>