aboutsummaryrefslogtreecommitdiff
path: root/multimedia/zart
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-10-12 07:14:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-10-12 07:14:59 +0000
commit064ece73536566260d4dce7478eaed903f3f0b53 (patch)
treef32c2304483ce57bb96b4c16523d08b9cbf1743f /multimedia/zart
parent385bcc24e34089d8458e740240659864c0f65e2d (diff)
downloadports-064ece73536566260d4dce7478eaed903f3f0b53.tar.gz
ports-064ece73536566260d4dce7478eaed903f3f0b53.zip
New port: multimedia/zart: GMIC GUI for video streams
Notes
Notes: svn path=/head/; revision=514319
Diffstat (limited to 'multimedia/zart')
-rw-r--r--multimedia/zart/Makefile39
-rw-r--r--multimedia/zart/distinfo5
-rw-r--r--multimedia/zart/pkg-descr6
3 files changed, 50 insertions, 0 deletions
diff --git a/multimedia/zart/Makefile b/multimedia/zart/Makefile
new file mode 100644
index 000000000000..fa6bccfc8e91
--- /dev/null
+++ b/multimedia/zart/Makefile
@@ -0,0 +1,39 @@
+# $FreeBSD$
+
+PORTNAME= zart
+PORTVERSION= g20190911
+CATEGORIES= multimedia
+MASTER_SITES= https://gmic.eu/files/source/:gmic
+DISTFILES= gmic_${GMIC_VERSION}.tar.gz:gmic
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= GMIC GUI for video streams
+
+LICENSE= CeCILL
+LICENSE_NAME= CeCILL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+LIB_DEPENDS= libopencv_core.so:graphics/opencv-core \
+ libopencv_video.so:graphics/opencv \
+ libfftw3.so:math/fftw3
+
+USES= pkgconfig qmake qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= c-koi
+GH_TAGNAME= e1b25e8
+USE_QT= core gui network widgets xml buildtools_build
+
+GMIC_VERSION= 2.7.4
+
+QMAKE_ARGS= "GMIC_PATH=${WRKDIR}/gmic-${GMIC_VERSION}/src"
+
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} 's|SYS_gettid|SYS_thr_self|' ${WRKDIR}/gmic-${GMIC_VERSION}/src/gmic.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/multimedia/zart/distinfo b/multimedia/zart/distinfo
new file mode 100644
index 000000000000..62be0bc4f71e
--- /dev/null
+++ b/multimedia/zart/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1570862150
+SHA256 (gmic_2.7.4.tar.gz) = cd9b40fa8df8a0bb47388071096c768a9d4908af574f0e98cc8515410d0b2c40
+SIZE (gmic_2.7.4.tar.gz) = 5848807
+SHA256 (c-koi-zart-g20190911-e1b25e8_GH0.tar.gz) = 5ad1816c94befbcf7ce9c4f11dc3f164e0a253bbf47a98f97bde01bbf66fb315
+SIZE (c-koi-zart-g20190911-e1b25e8_GH0.tar.gz) = 316471
diff --git a/multimedia/zart/pkg-descr b/multimedia/zart/pkg-descr
new file mode 100644
index 000000000000..83e9faa57055
--- /dev/null
+++ b/multimedia/zart/pkg-descr
@@ -0,0 +1,6 @@
+ZArt is a computer program whose purpose is to demonstrate the possibilities of
+the G'MIC image processing language by offering the choice of several
+manipulations on a video stream acquired from a webcam. In other words, ZArt is
+a GUI for G'MIC real-time manipulations on the output of a webcam.
+
+WWW: https://github.com/c-koi/zart