aboutsummaryrefslogtreecommitdiff
path: root/multimedia/zart
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2021-01-30 18:08:56 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2021-01-30 18:08:56 +0000
commit7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f (patch)
tree713fa1b8e4fb42290a607fc6c42e2fb1e1f72ed5 /multimedia/zart
parent33809b22ade1a5f4c057fc465145e9a1ca12d82c (diff)
downloadports-7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f.tar.gz
ports-7a09f7fbc250cc79d2b00104f8c4ee1b93a39d2f.zip
graphics/opencv: update to 4.5.1 -- and make port more easily maintainable
This is a major upgrade from 3.x to 4.x. Changelog from versions 3.4.1--4.5.1 can be found here: https://github.com/opencv/opencv/wiki/ChangeLog Note: this has explicitely not been added as a new graphics/opencv4 port, but replaces the previous graphics/opencv[3] port. Again, to improve maintainability by not giving ports the option to pick the "wrong one" - this leads however to some abandoned ports being broken. The port has been greatly simplified: * graphics/opencv-core which existed to enable ffmpeg to depend on opencv, and vice versa has been removed. ffmpeg no longer can depend on opencv. * graphics/py-opencv has been integrated into graphics/opencv, the default versions python bindings will be built unless the PYTHON option is explicitely turned off. * graphics/opencv-java has been integrated into graphics/opencv -- it is off by default, but can be enabled by toggling the JAVA option -- there are no consumers in the tree, so that option might go away in the future. * All the previous options have been removed and replaced by a (hopefully) sane set of dependencies that make the port and package most usable for the majority of consumers. - Please let me know if you think there are better defaults (i.e. anything that is missing, or something that should not be dependet on). - If you think something should be added or removed, please open a bug report. - If you think something should be added as an optional dependency, please open a bug report (with a good reason [tm]). The depending ports have been updated to work against opencv4, or marked broken. * Ports broken: - graphics/rubygem-objectdetect: OpenCV4 no longer ships opencv-1.0 API - graphics/p5-Image-ObjectDetect: OpenCV4 no longer ships opencv-1.0 API - graphics/gimp-gmic-plugin: OpenCV4 no longer ships opencv-1.0 API * Backports: - misc/visp: https://github.com/lagadic/visp/commit/dfa7e4bd47c24cd2e631477e6afb18806733ff8a - multimedia/zart: https://github.com/c-koi/zart/commit/6ca1964690afbbc78627d7c868a692401043a584, https://github.com/c-koi/zart/commit/d3a2931b1a07ec0322211f253468000363c4b6cb * Others: - misc/actiona: switch to pkgconfig 'opencv4' - multimedia/libav: drop opencv support - misc/darknet: already failed to build prior to the upgrade - math/saga: remove patching added to work against opencv3
Notes
Notes: svn path=/head/; revision=563430
Diffstat (limited to 'multimedia/zart')
-rw-r--r--multimedia/zart/Makefile7
-rw-r--r--multimedia/zart/distinfo4
-rw-r--r--multimedia/zart/files/patch-zart.pro11
3 files changed, 19 insertions, 3 deletions
diff --git a/multimedia/zart/Makefile b/multimedia/zart/Makefile
index f71bd30d5a34..8608afe2acce 100644
--- a/multimedia/zart/Makefile
+++ b/multimedia/zart/Makefile
@@ -2,10 +2,14 @@
PORTNAME= zart
PORTVERSION= g20191124
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= https://gmic.eu/files/source/:gmic
DISTFILES= gmic_${GMIC_VERSION}.tar.gz:gmic
+PATCH_SITES= https://github.com/c-koi/zart/commit/
+PATCHFILES= 6ca1964690afbbc78627d7c868a692401043a584.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= GMIC GUI for video streams
@@ -15,8 +19,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libgmic.so:graphics/gmic \
- libopencv_core.so:graphics/opencv-core \
- libopencv_video.so:graphics/opencv \
+ libopencv_core.so:graphics/opencv \
libfftw3.so:math/fftw3
USES= compiler:c++11-lang pkgconfig qmake qt:5
diff --git a/multimedia/zart/distinfo b/multimedia/zart/distinfo
index 8777cd82ca23..ca97bde3e4a9 100644
--- a/multimedia/zart/distinfo
+++ b/multimedia/zart/distinfo
@@ -1,5 +1,7 @@
-TIMESTAMP = 1577251091
+TIMESTAMP = 1612027931
SHA256 (gmic_2.8.1.tar.gz) = 1a2b4c75c428201e52e920bd07e6c04118ae294cb89fce3c1c4ef386421b2a7a
SIZE (gmic_2.8.1.tar.gz) = 5995556
SHA256 (c-koi-zart-g20191124-099554f_GH0.tar.gz) = 667bb0730cc462f31659b33b66cbc521e94a321e4eea96d79ded2f6ee31b002e
SIZE (c-koi-zart-g20191124-099554f_GH0.tar.gz) = 293482
+SHA256 (6ca1964690afbbc78627d7c868a692401043a584.patch) = 00c749fd75b460e57f6ad99c44c6c9f81c66d88468dd79cf2698cf7f6282bb6a
+SIZE (6ca1964690afbbc78627d7c868a692401043a584.patch) = 1154
diff --git a/multimedia/zart/files/patch-zart.pro b/multimedia/zart/files/patch-zart.pro
new file mode 100644
index 000000000000..db8f6d7fe19f
--- /dev/null
+++ b/multimedia/zart/files/patch-zart.pro
@@ -0,0 +1,11 @@
+--- zart.pro.orig 2021-01-30 17:27:07 UTC
++++ zart.pro
+@@ -29,7 +29,7 @@ greaterThan(QT_MAJOR_VERSION, 4): CONFIG += c++11
+ CONFIG += warn_on
+ QT_CONFIG -= no-pkg-config
+ CONFIG += link_pkgconfig
+-PKGCONFIG += opencv fftw3 zlib
++PKGCONFIG += opencv4 fftw3 zlib
+ DEFINES += cimg_use_fftw3 cimg_use_zlib
+
+ DEFINES += QT_DEPRECATED_WARNINGS