aboutsummaryrefslogtreecommitdiff
path: root/multimedia/zoneminder/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-08-21 16:41:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-08-21 17:12:16 +0000
commit1494c761437ec617137ebbdfc1ea7a3db81c47e3 (patch)
tree6f76db5e8845ecac006816b52492c214c7835a80 /multimedia/zoneminder/Makefile
parent8fc23f5e73d00e638c050eed7fe234726ac2264e (diff)
downloadports-1494c761437ec617137ebbdfc1ea7a3db81c47e3.tar.gz
ports-1494c761437ec617137ebbdfc1ea7a3db81c47e3.zip
Diffstat (limited to 'multimedia/zoneminder/Makefile')
-rw-r--r--multimedia/zoneminder/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index 53bc45a28972..df10c4b30480 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -1,6 +1,5 @@
PORTNAME= zoneminder
-PORTVERSION= 1.34.21
-PORTREVISION= 2
+DISTVERSION= 1.36.5
CATEGORIES= multimedia
MAINTAINER= bsd@abinet.ru
@@ -39,8 +38,9 @@ RUN_DEPENDS= ${ZM_DEPENDS} \
USES= cmake:insource,noninja jpeg mysql perl5 php shebangfix ssl
USE_GITHUB= yes
GH_PROJECT= zoneminder
-GH_TUPLE= zoneminder:crud:0bd63fb:crud \
- zoneminder:CakePHP-Enum-Behavior:ea90c0c:crud_plugin
+GH_TUPLE= FriendsOfCake:crud:0bd63fb:crud/web/api/app/Plugin/Crud \
+ ZoneMinder:CakePHP-Enum-Behavior:ea90c0c:crud_plugin/web/api/app/Plugin/CakePHP-Enum-Behavior \
+ ZoneMinder:RtspServer:cd7fd49:rtsp_server/dep/RtspServer
USE_RC_SUBR= zoneminder
USE_PHP= json pdo_mysql session gd sockets ctype opcache openssl hash
@@ -96,11 +96,6 @@ RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu@${PHP_FL
PKGMESSAGE= ${WRKDIR}/pkg-message
-post-extract:
- ${CP} -R ${WRKSRC_crud}/* ${WRKSRC}/web/api/app/Plugin/Crud
- ${CP} -R ${WRKSRC_crud_plugin}/* ${WRKSRC}/web/api/app/Plugin/CakePHP-Enum-Behavior
- ${REINPLACE_CMD} -e 's|/dev/shm|/tmp|g' ${WRKSRC}/scripts/ZoneMinder/lib/ZoneMinder/ConfigData.pm.in
-
post-patch:
# Avoid conflict with C++20 <version> by adding .txt suffix
@${MV} ${WRKSRC}/version ${WRKSRC}/version.txt
@@ -117,4 +112,10 @@ pre-install:
${MKDIR} ${STAGEDIR}/var/run/zm
${MKDIR} ${STAGEDIR}/var/tmp/zm
+post-install: # zmsystemctl.pl is only for systend-based systems
+ @cd ${STAGEDIR}${PREFIX} && \
+ ${RM} \
+ bin/zmsystemctl.pl \
+ man/man8/zmsystemctl.pl.8.gz
+
.include <bsd.port.post.mk>