aboutsummaryrefslogtreecommitdiff
path: root/multimedia/zoneminder/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-04 05:11:40 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-04 05:11:40 +0000
commite36fa5a35d646d803128131ea14502605318b9d0 (patch)
treeab310a1c1c739c86f21402dd2b085e9f854e81a7 /multimedia/zoneminder/Makefile
parent797ef6942f72d2091b054cc84c9469befdecbe65 (diff)
downloadports-e36fa5a35d646d803128131ea14502605318b9d0.tar.gz
ports-e36fa5a35d646d803128131ea14502605318b9d0.zip
multimedia/zoneminder: Update to 1.34.21
PR: 250234 Submitted by: Ivan <bsd@abinet.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=554053
Diffstat (limited to 'multimedia/zoneminder/Makefile')
-rw-r--r--multimedia/zoneminder/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index b6d9de68baa5..c83510a10f5a 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= zoneminder
-PORTVERSION= 1.34.9
-PORTREVISION= 1
+PORTVERSION= 1.34.21
CATEGORIES= multimedia
MAINTAINER= bsd@abinet.ru
@@ -46,14 +45,16 @@ GH_TUPLE= zoneminder:crud:0bd63fb:crud \
USE_RC_SUBR= zoneminder
USE_PHP= json pdo_mysql session gd sockets ctype opcache openssl hash
-OPTIONS_DEFINE= NLS V4L DOCS
+OPTIONS_DEFINE= NLS V4L
OPTIONS_SUB= yes
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls
V4L_BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
V4L_LIB_DEPENDS= libv4l2.so:multimedia/libv4l
+PKGMESSAGE= ${MASTERDIR}/pkg-message
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
+SUB_FILES= pkg-message
SHEBANG_FILES= scripts/zmaudit.pl.in \
scripts/zmcamtool.pl.in \
@@ -72,8 +73,6 @@ SHEBANG_FILES= scripts/zmaudit.pl.in \
scripts/zmonvif-probe.pl.in \
scripts/zmrecover.pl.in
-PORTDOCS= README.FreeBSD
-
CMAKE_ARGS+= -DZM_PERL_MM_PARMS=INSTALLDIRS=site \
-DZM_CONFIG_DIR=${PREFIX}/etc \
-DZM_CONFIG_SUBDIR=${PREFIX}/etc/zoneminder \
@@ -102,8 +101,6 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
post-extract:
${CP} -R ${WRKSRC_crud}/* ${WRKSRC}/web/api/app/Plugin/Crud
${CP} -R ${WRKSRC_crud_plugin}/* ${WRKSRC}/web/api/app/Plugin/CakePHP-Enum-Behavior
- ${CP} ${FILESDIR}/README.FreeBSD ${WRKSRC}
- ${CP} ${FILESDIR}/README.FreeBSD ${PKGMESSAGE}
${REINPLACE_CMD} -e 's|/dev/shm|/tmp|g' ${WRKSRC}/scripts/ZoneMinder/lib/ZoneMinder/ConfigData.pm.in
post-patch:
@@ -122,8 +119,4 @@ pre-install:
${MKDIR} ${STAGEDIR}/var/run/zm
${MKDIR} ${STAGEDIR}/var/tmp/zm
-post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-
.include <bsd.port.post.mk>