aboutsummaryrefslogtreecommitdiff
path: root/multimedia/zoneminder
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-06-21 08:09:47 +0000
committerJohn Marino <marino@FreeBSD.org>2016-06-21 08:09:47 +0000
commit7244904cd34273b66fc07b9c811cbfade6aa78f6 (patch)
tree5391f94f045dcaceaba579cb503d76e87eeb80fe /multimedia/zoneminder
parente3f979f6fd8f77d277e8dfc707c87fa60812f5a9 (diff)
downloadports-7244904cd34273b66fc07b9c811cbfade6aa78f6.tar.gz
ports-7244904cd34273b66fc07b9c811cbfade6aa78f6.zip
multimedia/zoneminder: Fix Malformed conditional introduced by last commit
Without an inclusion, OSVERSION and ARCH aren't defined. While here, couple OSVERSION with OPSYS. It's not strictly necessary in this case, but it maintains consistency with other ports. The previous change was apparently committed without any verification. Approved by: just-fix-it
Notes
Notes: svn path=/head/; revision=417189
Diffstat (limited to 'multimedia/zoneminder')
-rw-r--r--multimedia/zoneminder/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index 61949c8754bd..5ee33339625f 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -78,7 +78,9 @@ CMAKE_ARGS+= -DZM_PERL_MM_PARMS=INSTALLDIRS=site \
-DHAVE_SENDFILE=0 \
-DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"
-.if ${OSVERSION} < 1000000 && ${ARCH} == i386
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 && ${ARCH} == i386
CFLAGS+= -msse
.endif
@@ -107,4 +109,4 @@ post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>