aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-09-01 14:13:10 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-09-01 14:13:10 +0000
commit022132c3302455b485c276f8d51b2eb6effb3118 (patch)
tree41ba6cd4d42e126441e7155f5d8067d1ac8a62fb /multimedia
parentbf94442d17d99f6100efec5e235c98f551fdc110 (diff)
downloadports-022132c3302455b485c276f8d51b2eb6effb3118.tar.gz
ports-022132c3302455b485c276f8d51b2eb6effb3118.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile19
-rw-r--r--multimedia/mplayer/Makefile.options69
-rw-r--r--multimedia/mplayer/Makefile.shared11
-rw-r--r--multimedia/mplayer/distinfo4
-rw-r--r--multimedia/mplayer/files/extra-patch-base_system_gcc9
-rw-r--r--multimedia/mplayer/files/extra-patch-base_system_log2f12
-rw-r--r--multimedia/mplayer/files/patch-configure9
-rw-r--r--multimedia/mplayer/files/patch-ffmpeg-Makefile11
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-Makefile21
9 files changed, 97 insertions, 68 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index bfa9d758af57..f153d9e4cfd4 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,6 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 2
COMMENT= High performance media player supporting many formats
@@ -16,7 +15,7 @@ COMMENT= High performance media player supporting many formats
OPTIONS= DEBUG "Include debug symbols in mplayer's binaries" off
OPTIONS+= RTCPU "Allow runtime CPU detection" on
OPTIONS+= OCFLAGS "Use optimized compiler flags" on
-OPTIONS+= OTCHAIN "Use up-to-date toolchain (gcc 4.6)" on
+OPTIONS+= OTCHAIN "Use gcc 4.6+ toolchain on legacy systems" off
OPTIONS+= IPV6 "Include inet6 network support" on
OPTIONS+= X11 "Enable X11 support for mplayer's video output" on
OPTIONS+= X11XV "X11 video drivers: XV" on
@@ -129,7 +128,7 @@ CONFIGURE_ARGS+=--disable-dga1 --disable-dga2
.endif
.if !defined(WITHOUT_X11GL)
USE_XORG+= glproto
-LIB_DEPENDS+= GL.1:${PORTSDIR}/graphics/libGL
+LIB_DEPENDS+= GL:${PORTSDIR}/graphics/libGL
.else
CONFIGURE_ARGS+=--disable-gl
.endif
@@ -153,7 +152,7 @@ CONFIGURE_ARGS+=--disable-x11 \
.endif
.if defined(WITH_VDPAU)
-LIB_DEPENDS+= vdpau.1:${PORTSDIR}/multimedia/libvdpau
+LIB_DEPENDS+= vdpau:${PORTSDIR}/multimedia/libvdpau
.else
CONFIGURE_ARGS+= --disable-vdpau
.endif
@@ -167,19 +166,19 @@ CONFIGURE_ARGS+= --disable-rtc
.endif
.if defined(WITH_ARTS)
-LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+LIB_DEPENDS+= artsc:${PORTSDIR}/audio/arts
.else
CONFIGURE_ARGS+= --disable-arts
.endif
.if defined(WITH_LIBCACA)
-LIB_DEPENDS+=caca.0:${PORTSDIR}/graphics/libcaca
+LIB_DEPENDS+= caca:${PORTSDIR}/graphics/libcaca
.else
CONFIGURE_ARGS+= --disable-caca
.endif
.if defined(WITH_LIRC)
-LIB_DEPENDS+= lirc_client.2:${PORTSDIR}/comms/lirc
+LIB_DEPENDS+= lirc_client:${PORTSDIR}/comms/lirc
.else
CONFIGURE_ARGS+= --disable-lirc
.endif
@@ -193,13 +192,13 @@ CONFIGURE_ARGS+= --disable-sdl
.endif
.if defined(WITH_SVGALIB)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
.else
CONFIGURE_ARGS+= --disable-svga
.endif
.if defined(WITH_AALIB)
-LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
+LIB_DEPENDS+= aa:${PORTSDIR}/graphics/aalib
.else
CONFIGURE_ARGS+= --disable-aa
.endif
@@ -224,7 +223,7 @@ CONFIGURE_ARGS+=--disable-joystick
.endif
.if defined(WITH_ENCA)
-LIB_DEPENDS+= enca.5:${PORTSDIR}/converters/enca
+LIB_DEPENDS+= enca:${PORTSDIR}/converters/enca
.else
CONFIGURE_ARGS+= --disable-enca
.endif
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index d99bf218fbaf..0db7acfe46be 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -55,12 +55,26 @@ CFLAGS+= -O3 -fomit-frame-pointer -ffast-math
CONFIGURE_ARGS+=--enable-runtime-cpudetection
.endif
+.if ${OSVERSION} >= 900033
+WITH_BASE_CLANG=yes
+.endif
+
+.if defined(WITH_BASE_CLANG)
+CC= clang
+CXX= clang++
+.else
.if defined(WITH_OTCHAIN)
USE_GCC?= 4.6+
BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
.else
CONFIGURE_ARGS+=--disable-ssse3 --disable-fast-cmov
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-base_system_gcc
+.if ${ARCH} == "amd64"
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
+MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
+.endif
+.endif
.endif
.if defined(WITHOUT_IPV6)
@@ -70,37 +84,37 @@ CATEGORIES+= ipv6
.endif
.if !defined(WITHOUT_LIBUNGIF)
-LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS+= gif:${PORTSDIR}/graphics/giflib
.else
CONFIGURE_ARGS+= --disable-gif
.endif
.if defined(WITH_OPENJPEG)
-LIB_DEPENDS+= openjpeg.2:${PORTSDIR}/graphics/openjpeg
+LIB_DEPENDS+= openjpeg:${PORTSDIR}/graphics/openjpeg
.else
CONFIGURE_ARGS+= --disable-libopenjpeg
.endif
.if defined(WITH_MAD)
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/libmad
.else
CONFIGURE_ARGS+= --disable-mad
.endif
.if defined(WITH_LIBDV)
-LIB_DEPENDS+= dv.4:${PORTSDIR}/multimedia/libdv
+LIB_DEPENDS+= dv:${PORTSDIR}/multimedia/libdv
.else
CONFIGURE_ARGS+= --disable-libdv
.endif
.if defined(WITH_THEORA)
-LIB_DEPENDS+= theora.0:${PORTSDIR}/multimedia/libtheora
+LIB_DEPENDS+= theora:${PORTSDIR}/multimedia/libtheora
.else
CONFIGURE_ARGS+= --disable-theora
.endif
.if defined(WITH_VPX)
-LIB_DEPENDS+= vpx.1:${PORTSDIR}/multimedia/libvpx
+LIB_DEPENDS+= vpx:${PORTSDIR}/multimedia/libvpx
.else
CONFIGURE_ARGS+= --disable-libvpx-lavc
.endif
@@ -112,26 +126,39 @@ CONFIGURE_ARGS+= --disable-libschroedinger-lavc
.endif
.if !defined(WITHOUT_SPEEX)
-LIB_DEPENDS+= speex.1:${PORTSDIR}/audio/speex
+LIB_DEPENDS+= speex:${PORTSDIR}/audio/speex
.else
CONFIGURE_ARGS+= --disable-speex
.endif
.if defined(WITH_LIVEMEDIA)
-#RUN_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+CONFIGURE_ARGS+= --enable-live
BUILD_DEPENDS+= ${LOCALBASE}/live/liveMedia/libliveMedia.a:${PORTSDIR}/net/liveMedia
+CFLAGS+= -I${LOCALBASE}/live/liveMedia/include \
+ -I${LOCALBASE}/live/BasicUsageEnvironment/include \
+ -I${LOCALBASE}/live/UsageEnvironment/include \
+ -I${LOCALBASE}/live/groupsock/include
+LDFLAGS+= -L${LOCALBASE}/live/liveMedia \
+ -L${LOCALBASE}/live/BasicUsageEnvironment \
+ -L${LOCALBASE}/live/UsageEnvironment \
+ -L${LOCALBASE}/live/groupsock \
+ -lliveMedia \
+ -lUsageEnvironment \
+ -lBasicUsageEnvironment \
+ -lgroupsock \
+ -lstdc++
.else
CONFIGURE_ARGS+= --disable-live
.endif
.if defined(WITH_JACK)
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.else
CONFIGURE_ARGS+= --disable-jack
.endif
.if defined(WITH_NAS)
-LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+LIB_DEPENDS+= audio:${PORTSDIR}/audio/nas
.else
CONFIGURE_ARGS+= --disable-nas
.endif
@@ -143,37 +170,37 @@ CONFIGURE_ARGS+= --disable-openal
.endif
.if defined(WITH_PULSE)
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS+= pulse:${PORTSDIR}/audio/pulseaudio
.else
CONFIGURE_ARGS+= --disable-pulse
.endif
.if defined(WITH_BLURAY)
-LIB_DEPENDS+= bluray.2:${PORTSDIR}/multimedia/libbluray
+LIB_DEPENDS+= bluray:${PORTSDIR}/multimedia/libbluray
.else
CONFIGURE_ARGS+= --disable-bluray
.endif
.if defined(WITH_SMB)
-LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
+LIB_DEPENDS+= smbclient:${PORTSDIR}/net/samba-libsmbclient
.else
CONFIGURE_ARGS+= --disable-smb
.endif
.if defined(WITH_FRIBIDI)
-LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
.else
CONFIGURE_ARGS+= --disable-fribidi
.endif
.if defined(WITH_CDPARANOIA)
-LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
+LIB_DEPENDS+= cdda_paranoia:${PORTSDIR}/audio/cdparanoia
.else
CONFIGURE_ARGS+= --disable-cdparanoia
.endif
.if defined(WITH_LIBCDIO) && !defined(WITH_CDPARANOIA)
-LIB_DEPENDS+= cdio.13:${PORTSDIR}/sysutils/libcdio
+LIB_DEPENDS+= cdio:${PORTSDIR}/sysutils/libcdio
.else
CONFIGURE_ARGS+= --disable-libcdio
.endif
@@ -185,7 +212,7 @@ CONFIGURE_ARGS+= --disable-ladspa
.endif
.if defined(WITH_LIBLZO)
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
.else
CONFIGURE_ARGS+= --disable-liblzo
.endif
@@ -222,7 +249,7 @@ CONFIGURE_ARGS+= --disable-real
.endif
.if defined(WITH_AMR_NB) || defined (WITH_AMR_WB)
-LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
+LIB_DEPENDS+= opencore-amrnb:${PORTSDIR}/audio/opencore-amr
.endif
.ifdef(WITHOUT_AMR_NB)
@@ -234,7 +261,7 @@ CONFIGURE_ARGS+= --disable-libopencore_amrwb
.endif
.ifdef(WITH_GSM)
-LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+LIB_DEPENDS+= gsm:${PORTSDIR}/audio/gsm
.else
CONFIGURE_ARGS+= --disable-libgsm
.endif
@@ -251,7 +278,7 @@ CONFIGURE_ARGS+= --disable-tv-v4l1 \
.endif
.if defined(WITH_LIBRTMP)
-LIB_DEPENDS+= rtmp.0:${PORTSDIR}/multimedia/rtmpdump
+LIB_DEPENDS+= rtmp:${PORTSDIR}/multimedia/rtmpdump
CONFIGURE_ARGS+= --enable-librtmp
EXTRA_LIBS+= -lrtmp
.else
@@ -259,7 +286,7 @@ CONFIGURE_ARGS+= --disable-librtmp
.endif
.if defined(WITH_MNG)
-LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
+LIB_DEPENDS+= mng:${PORTSDIR}/graphics/libmng
.else
CONFIGURE_ARGS+= --disable-mng
.endif
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index 1da3656cc60b..0db41a13700a 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -4,12 +4,11 @@
#
# $FreeBSD$
-MPLAYER_SNAPSHOT_DATE= 2012-03-22
-MPLAYER_PORT_VERSION= 1.0.r${MPLAYER_SNAPSHOT_DATE:S/-//g}
+MPLAYER_SNAPSHOT_DATE= 2012-07-21
+MPLAYER_PORT_VERSION= 1.1.r${MPLAYER_SNAPSHOT_DATE:S/-//g}
CATEGORIES?= multimedia audio
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
- http://www.rrr.de/~riggs/mplayer/
-DISTNAME= mplayer-${MPLAYER_PORT_VERSION:S/.r/rc/g}
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= mplayer-${MPLAYER_PORT_VERSION:S/.r/./g}
WRKSRC= ${WRKDIR}/mplayer-export-${MPLAYER_SNAPSHOT_DATE}
PROJECTHOST= bsdistfiles
@@ -19,7 +18,7 @@ MAINTAINER?= thomas.e.zander@googlemail.com
LICENSE= GPLv2
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2
+ freetype:${PORTSDIR}/print/freetype2
BUILD_DEPENDS= ${LOCALBASE}/bin/yasm:${PORTSDIR}/devel/yasm
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index 5f80b1e5bccd..0dd0c1501245 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mplayer-1.0rc20120322.tar.xz) = 602a5a1c4e25ae054fdc2df49c19672b189978df12617748feb5307ff16b33cd
-SIZE (mplayer-1.0rc20120322.tar.xz) = 10033056
+SHA256 (mplayer-1.1.20120721.tar.xz) = 30b120bf8543b7cfad36272e3ae29a017282caa90f4d635fe157f29036393787
+SIZE (mplayer-1.1.20120721.tar.xz) = 10480368
diff --git a/multimedia/mplayer/files/extra-patch-base_system_gcc b/multimedia/mplayer/files/extra-patch-base_system_gcc
index 28ea4ee80e0f..5a4a88c2bd09 100644
--- a/multimedia/mplayer/files/extra-patch-base_system_gcc
+++ b/multimedia/mplayer/files/extra-patch-base_system_gcc
@@ -11,15 +11,6 @@
--- configure.orig 2011-12-31 00:40:03.990976000 +0100
+++ configure 2011-12-31 01:33:51.407685009 +0100
-@@ -1533,7 +1533,7 @@
- fi
-
- extra_cflags="-I. -Iffmpeg $extra_cflags"
--extra_ldflags="-lm $extra_ldflags"
-+extra_ldflags="-lm $extra_ldflags -L$_prefix/lib"
- _timer=timer-linux.c
- _getch=getch2.c
-
@@ -2683,10 +2683,6 @@
def_ebx_available='#define HAVE_EBX_AVAILABLE 0'
def_xmm_clobbers='#define HAVE_XMM_CLOBBERS 0'
diff --git a/multimedia/mplayer/files/extra-patch-base_system_log2f b/multimedia/mplayer/files/extra-patch-base_system_log2f
index aabcf649dc2f..caca838a02b0 100644
--- a/multimedia/mplayer/files/extra-patch-base_system_log2f
+++ b/multimedia/mplayer/files/extra-patch-base_system_log2f
@@ -1,15 +1,15 @@
---- configure.orig 2011-12-15 15:01:05.000000000 +0100
-+++ configure 2012-01-28 17:33:54.674887100 +0100
-@@ -3107,7 +3107,7 @@
+--- configure.orig 2012-07-24 20:47:24.721531229 +0200
++++ configure 2012-07-24 20:49:56.207569906 +0200
+@@ -3130,7 +3130,7 @@
echores "$_kstat"
--for func in cbrtf exp2 exp2f llrint llrintf log2 log2f lrint lrintf round roundf trunc truncf; do
-+for func in cbrtf exp2 exp2f llrint llrintf lrint lrintf round roundf trunc truncf; do
+-for func in cbrtf exp2 exp2f isnan isinf llrint llrintf log2 log2f lrint lrintf rint round roundf trunc truncf; do
++for func in cbrtf exp2 exp2f isnan isinf llrint llrintf lrint lrintf rint round roundf trunc truncf; do
echocheck $func
eval _$func=no
statement_check math.h "${func}(2.0)" -D_ISOC99_SOURCE && eval _$func=yes
-@@ -3119,7 +3119,9 @@
+@@ -3142,7 +3142,9 @@
echores no
fi
done
diff --git a/multimedia/mplayer/files/patch-configure b/multimedia/mplayer/files/patch-configure
index 4ceff63c7241..7e54bdff6337 100644
--- a/multimedia/mplayer/files/patch-configure
+++ b/multimedia/mplayer/files/patch-configure
@@ -17,6 +17,15 @@
;;
esac
+@@ -1533,7 +1533,7 @@
+ fi
+
+ extra_cflags="-I. -Iffmpeg $extra_cflags"
+-extra_ldflags="-lm $extra_ldflags"
++extra_ldflags="-lm $extra_ldflags -L$_prefix/lib"
+ _timer=timer-linux.c
+ _getch=getch2.c
+
@@ -3576,7 +3575,7 @@
if linux ; then
THREAD_CFLAGS=-D_REENTRANT
diff --git a/multimedia/mplayer/files/patch-ffmpeg-Makefile b/multimedia/mplayer/files/patch-ffmpeg-Makefile
new file mode 100644
index 000000000000..0f5b49f2c258
--- /dev/null
+++ b/multimedia/mplayer/files/patch-ffmpeg-Makefile
@@ -0,0 +1,11 @@
+--- ffmpeg/Makefile.orig 2012-06-29 19:20:03.000000000 +0200
++++ ffmpeg/Makefile 2012-07-21 18:47:01.068697043 +0200
+@@ -82,7 +82,7 @@
+ $(foreach V,$(SUBDIR_VARS),$(eval $(call RESET,$(V))))
+ SUBDIR := $(1)/
+ include $(SRC_PATH)/$(1)/Makefile
+--include $(SRC_PATH)/$(1)/$(ARCH)/Makefile
++-include $(SRC_PATH)/$(1)/$(MPLAYER_ARCH)/Makefile
+ include $(SRC_PATH)/library.mak
+ endef
+
diff --git a/multimedia/mplayer/files/patch-libavcodec-Makefile b/multimedia/mplayer/files/patch-libavcodec-Makefile
index 5d12820abc3a..0681ab4dbe13 100644
--- a/multimedia/mplayer/files/patch-libavcodec-Makefile
+++ b/multimedia/mplayer/files/patch-libavcodec-Makefile
@@ -1,18 +1,11 @@
---- ffmpeg/libavcodec/Makefile.orig 2012-03-21 19:20:05.000000000 +0100
-+++ ffmpeg/libavcodec/Makefile 2012-03-22 16:12:43.333951792 +0100
-@@ -735,12 +735,14 @@
- # well.
- OBJS-$(!CONFIG_SMALL) += inverse.o
-
-+-include $(SRC_PATH)/$(SUBDIR)$(MPLAYER_ARCH)/Makefile
-+
- SKIPHEADERS += %_tablegen.h \
- %_tables.h \
- aac_tablegen_decl.h \
+--- ffmpeg/libavcodec/Makefile.orig 2012-07-20 19:20:04.000000000 +0200
++++ ffmpeg/libavcodec/Makefile 2012-07-21 18:25:12.582670118 +0200
+@@ -788,7 +788,7 @@
+ codec_names.h \
fft-internal.h \
tableprint.h \
-- $(ARCH)/vp56_arith.h
-+ $(MPLAYER_ARCH)/vp56_arith.h
+- $(ARCH)/vp56_arith.h \
++ $(MPLAYER_ARCH)/vp56_arith.h \
+
SKIPHEADERS-$(CONFIG_DXVA2) += dxva2.h dxva2_internal.h
- SKIPHEADERS-$(CONFIG_LIBDIRAC) += libdirac.h
SKIPHEADERS-$(CONFIG_LIBSCHROEDINGER) += libschroedinger.h