aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-06-11 16:06:41 +0000
committerMark Felder <feld@FreeBSD.org>2016-06-11 16:06:41 +0000
commit1c9cd4e0281ba2db064e0efba945d8c6969cb997 (patch)
tree933125d305794e10e60de942b4297cb16c577cc8 /multimedia
parent1db519be90ec87b309a2e0700e55238fc5bef253 (diff)
downloadports-1c9cd4e0281ba2db064e0efba945d8c6969cb997.tar.gz
ports-1c9cd4e0281ba2db064e0efba945d8c6969cb997.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/plexmediaserver/Makefile19
-rw-r--r--multimedia/plexmediaserver/pkg-plist8
2 files changed, 13 insertions, 14 deletions
diff --git a/multimedia/plexmediaserver/Makefile b/multimedia/plexmediaserver/Makefile
index 3f13bb12bb9a..7c09b63b3cc9 100644
--- a/multimedia/plexmediaserver/Makefile
+++ b/multimedia/plexmediaserver/Makefile
@@ -42,22 +42,13 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:misc/compat9x
post-patch:
# binaries don't come pre-stripped
- ${FIND} ${WRKSRC}/Resources -name '*.so' -exec ${STRIP_CMD} {} \;
- ${STRIP_CMD} ${WRKSRC}/Resources/rsync ${WRKSRC}/Resources/Python/bin/python
+ ${FIND} ${WRKSRC}/Resources -name '*.so' -exec ${STRIP_CMD} {} \+
+ ${STRIP_CMD} ${WRKSRC}/lib* ${WRKSRC}/Resources/Plex*
+ ${RM} ${WRKSRC}/start.sh
do-install:
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} Resources ${STAGEDIR}/${DATADIR})
- ${INSTALL_PROGRAM} ${WRKSRC}/Plex\ DLNA\ Server ${STAGEDIR}/${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/Plex\ Media\ Scanner ${STAGEDIR}/${DATADIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/Plex\ Media\ Server ${STAGEDIR}/${DATADIR}
- ${INSTALL_LIB} ${WRKSRC}/lib* ${STAGEDIR}/${DATADIR}
- # Fix permissions to programs and db
- @${CHMOD} a+x ${STAGEDIR}/${DATADIR}/Resources/rsync
- @${CHMOD} a+x ${STAGEDIR}/${DATADIR}/Resources/Plex\ New\ Transcoder
- @${CHMOD} a+x ${STAGEDIR}/${DATADIR}/Resources/Plex\ Transcoder
- @${CHMOD} a+x ${STAGEDIR}/${DATADIR}/Resources/Python/bin/python
- @${CHMOD} u+w ${STAGEDIR}/${DATADIR}/Resources/com.plexapp.plugins.library.db
- # Python fix
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}/${DATADIR})
+ # Python fix for older releases of Plex
@${LN} -s ${DATADIR}/libpython2.7.so.1 ${STAGEDIR}/${DATADIR}/libpython2.7.so
# Workaround for space in binary name
@${LN} -s ${DATADIR}/Plex\ Media\ Server ${STAGEDIR}${DATADIR}/Plex_Media_Server
diff --git a/multimedia/plexmediaserver/pkg-plist b/multimedia/plexmediaserver/pkg-plist
index 453ed33f4f2c..ec11705366fc 100644
--- a/multimedia/plexmediaserver/pkg-plist
+++ b/multimedia/plexmediaserver/pkg-plist
@@ -1,6 +1,8 @@
+@mode 555
%%DATADIR%%/Plex DLNA Server
%%DATADIR%%/Plex Media Scanner
%%DATADIR%%/Plex Media Server
+@mode
%%DATADIR%%/Plex_Media_Server
%%DATADIR%%/Resources/Fonts/DejaVuSans-Bold.ttf
%%DATADIR%%/Resources/Fonts/DejaVuSans-Regular.ttf
@@ -60,9 +62,11 @@
%%DATADIR%%/Resources/Graphics/show.png
%%DATADIR%%/Resources/Graphics/video.png
%%DATADIR%%/Resources/LICENSE
+@mode 555
%%DATADIR%%/Resources/Plex New Transcoder
%%DATADIR%%/Resources/Plex Relay
%%DATADIR%%/Resources/Plex Transcoder
+@mode
%%DATADIR%%/Resources/Plug-ins-%%PLEX_BUILD%%/Fanart-TV.bundle/Contents/Code/__init__.py
%%DATADIR%%/Resources/Plug-ins-%%PLEX_BUILD%%/Fanart-TV.bundle/Contents/DefaultPrefs.json
%%DATADIR%%/Resources/Plug-ins-%%PLEX_BUILD%%/Fanart-TV.bundle/Contents/Info.plist
@@ -1916,7 +1920,9 @@
%%DATADIR%%/Resources/Profiles/iOS-iPod-4,1.xml
%%DATADIR%%/Resources/Profiles/iOS.xml
%%DATADIR%%/Resources/Profiles/tvOS.xml
+@mode 555
%%DATADIR%%/Resources/Python/bin/python
+@mode
%%DATADIR%%/Resources/Python/include/python2.7/pyconfig.h
%%DATADIR%%/Resources/Python/lib/python2.7/BaseHTTPServer.py
%%DATADIR%%/Resources/Python/lib/python2.7/Bastion.py
@@ -2772,7 +2778,9 @@
%%DATADIR%%/Resources/plexmusic-combiner-albums.xml
%%DATADIR%%/Resources/plexmusic-combiner-artists.xml
%%DATADIR%%/Resources/rootCA.pem
+@mode 555
%%DATADIR%%/Resources/rsync
+@mode
%%DATADIR%%/Resources/server.crt
%%DATADIR%%/Resources/server.key
%%DATADIR%%/Resources/themoviedb-combiner-movies.xml