aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-28 17:58:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-28 17:58:48 +0000
commit23bb797eeb1993082d735635a57ff0ac235fa0ef (patch)
tree8944787fa5a51de4fe1f91ec8ccd432a8515a44c /multimedia
parent10b15d1b9b90dd36836c20c310947512ad9c5d9b (diff)
downloadports-23bb797eeb1993082d735635a57ff0ac235fa0ef.tar.gz
ports-23bb797eeb1993082d735635a57ff0ac235fa0ef.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile11
-rw-r--r--multimedia/mplayer/distinfo4
-rw-r--r--multimedia/mplayer/files/patch-ad18
-rw-r--r--multimedia/mplayer/files/patch-ae8
-rw-r--r--multimedia/mplayer/pkg-message17
5 files changed, 23 insertions, 35 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index d78af8ee6369..fb8e61ece1b1 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -165,8 +165,7 @@
# to be installed.
PORTNAME= mplayer
-PORTVERSION= 0.90.0.110
-PORTREVISION= 4
+PORTVERSION= 0.92.0
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
@@ -178,10 +177,10 @@ MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
ftp://ftp.lug.udel.edu/MPlayer/releases/ \
ftp://mirrors.xmission.com/MPlayer/releases/ \
http://www.rrr.de/~riggs/mplayer/
-DISTNAME= MPlayer-0.90
+DISTNAME= MPlayer-0.92
PATCH_SITES= ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/kame/misc/&,}
-PATCHFILES= mplayer-0.9.0-v6-20030430.diff.gz
+PATCHFILES= mplayer-0.9.1-v6-20030825.diff.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= riggs@rrr.de
@@ -517,7 +516,9 @@ pre-everything::
@${ECHO_MSG} "builds MPlayer with GUI support."
.if defined(WITH_GUI)
- @${ECHO_MSG} "You can download official skin collections from"
+ @${ECHO_MSG} "If you want to use the GUI, you can either install"
+ @${ECHO_MSG} "${PORTSDIR}/multimedia/mplayer-skins"
+ @${ECHO_MSG} "or download official skin collections from"
@${ECHO_MSG} "http://www.mplayerhq.hu/homepage/dload.html"
.endif
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index 185becea9aba..79b541fe3e21 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,2 +1,2 @@
-MD5 (MPlayer-0.90.tar.bz2) = 9a9f294bbaab2071ecbc327f4e870be8
-MD5 (mplayer-0.9.0-v6-20030430.diff.gz) = 6a20e965b297389fa0b471032a06dac1
+MD5 (MPlayer-0.92.tar.bz2) = c4e003fc6c6f82c1cae96a95eb9b2d28
+MD5 (mplayer-0.9.1-v6-20030825.diff.gz) = b99f40b5e1ee9fd467246e0c627794eb
diff --git a/multimedia/mplayer/files/patch-ad b/multimedia/mplayer/files/patch-ad
index 7dd07cf4ce66..1a355db90e33 100644
--- a/multimedia/mplayer/files/patch-ad
+++ b/multimedia/mplayer/files/patch-ad
@@ -1,6 +1,6 @@
---- configure.orig Sun Feb 9 06:29:05 2003
-+++ configure Mon Feb 10 23:20:25 2003
-@@ -294,7 +294,7 @@
+--- configure.orig Sat Sep 27 16:27:23 2003
++++ configure Sat Sep 27 16:34:14 2003
+@@ -300,7 +300,7 @@
# 1st pass checking for vital options
@@ -9,7 +9,7 @@
_ranlib=ranlib
_cc=gcc
test "$CC" && _cc="$CC"
-@@ -530,19 +530,10 @@
+@@ -539,19 +539,10 @@
# Try to find the available options for the current CPU
if x86 || ppc; then
@@ -29,7 +29,7 @@
pname=`$_cpuinfo | grep 'model name' | cut -d ':' -f 2 | head -1`
pvendor=`$_cpuinfo | grep 'vendor_id' | cut -d ':' -f 2 | cut -d ' ' -f 2 | head -1`
-@@ -1394,8 +1385,8 @@
+@@ -1423,8 +1414,8 @@
;;
*)
@@ -40,7 +40,7 @@
;;
esac
-@@ -1405,7 +1396,7 @@
+@@ -1434,7 +1425,7 @@
test -z "$_bindir" && _bindir="$_prefix/bin"
test -z "$_datadir" && _datadir="$_prefix/share/mplayer"
test -z "$_mandir" && _mandir="$_prefix/man"
@@ -49,7 +49,7 @@
test -z "$_libdir" && _libdir="$_prefix/lib"
test -z "$_mlibdir" && _mlibdir="$MLIBHOME"
-@@ -1836,13 +1827,7 @@
+@@ -1866,13 +1857,7 @@
echocheck "memalign()"
@@ -63,7 +63,7 @@
if test "$_memalign" = yes ; then
_def_memalign='#define HAVE_MEMALIGN 1'
else
-@@ -1931,31 +1916,7 @@
+@@ -1961,31 +1946,7 @@
echocheck "pthread"
@@ -96,7 +96,7 @@
echores "yes (using $_ld_pthread)"
-@@ -4694,7 +4655,7 @@
+@@ -4848,7 +4809,7 @@
CFLAGS="$CFLAGS -D_REENTRANT"
elif bsd ; then
# FIXME bsd needs this so maybe other OS'es
diff --git a/multimedia/mplayer/files/patch-ae b/multimedia/mplayer/files/patch-ae
index cbaaba34a7d8..f5ac9daf4e55 100644
--- a/multimedia/mplayer/files/patch-ae
+++ b/multimedia/mplayer/files/patch-ae
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Dec 5 07:29:26 2002
-+++ Makefile Tue Dec 17 09:53:32 2002
-@@ -241,49 +241,11 @@
+--- Makefile.orig Sat Sep 27 15:26:46 2003
++++ Makefile Sat Sep 27 15:29:55 2003
+@@ -254,47 +254,11 @@
ifeq ($(SHARED_PP),yes)
$(MAKE) install -C postproc
endif
@@ -30,9 +30,7 @@
- @echo "*** for GUI, and extract to $(DATADIR)/Skin/"
-endif
- @if test ! -d $(CONFDIR) ; then mkdir -p $(CONFDIR) ; fi
-- @if test -f $(CONFDIR)/codecs.conf.old ; then mv -f $(CONFDIR)/codecs.conf.old $(CONFDIR)/codecs.conf.older ; fi
- @if test -f $(CONFDIR)/codecs.conf ; then mv -f $(CONFDIR)/codecs.conf $(CONFDIR)/codecs.conf.old ; fi
-- $(INSTALL) -c -m 644 etc/codecs.conf $(CONFDIR)/codecs.conf
-ifeq ($(DVDKIT_SHARED),yes)
-ifeq ($(DVDKIT2),yes)
- if test ! -d $(LIBDIR) ; then mkdir -p $(LIBDIR) ; fi
diff --git a/multimedia/mplayer/pkg-message b/multimedia/mplayer/pkg-message
index 83a7ba2bd666..fba99fd9b743 100644
--- a/multimedia/mplayer/pkg-message
+++ b/multimedia/mplayer/pkg-message
@@ -10,17 +10,6 @@ mplayer with truetype supprt, this won't work.
Please take a look at docs in
/usr/local/share/doc/mplayer
-You can download skins from the mplayer homepage:
-http://www.mplayerhq.hu/
-
-In order to use DVD please make sure that your
-kernel and base system is newer than 2001-09-25,
-otherwise DVD play will not work!
-
-NOTE: Some users have ran into trouble when using mplayer on a
-SSE-capable CPU but not having SSE enabled in the kernel config.
-
-This is only for SSE-capable CPUs. For 5.x systems, this should not
-be necessary but 4.x users must recompile the kernel with
-
-options CPU_ENABLE_SSE
+If you encounter strange problems, please have a look at
+http://www.rrr.de/~riggs/mplayer/faq_en.html
+before throwing stones at me :-)