aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-26 22:25:51 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-26 22:25:51 +0000
commit47fc5b69f7b01d5ddfade3841ff483a17b4c6cc4 (patch)
tree98404b043d94a236f0dd4eda434cb3ff5fff3217 /multimedia
parent0f9fa6dcce780546edc5811ab5e863760391db0c (diff)
downloadports-47fc5b69f7b01d5ddfade3841ff483a17b4c6cc4.tar.gz
ports-47fc5b69f7b01d5ddfade3841ff483a17b4c6cc4.zip
New port: multimedia/librist: Library for Reliable Internet Stream Transport (RIST) protocol
Notes
Notes: svn path=/head/; revision=569273
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/librist/Makefile25
-rw-r--r--multimedia/librist/distinfo3
-rw-r--r--multimedia/librist/pkg-descr5
-rw-r--r--multimedia/librist/pkg-plist13
5 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 0634af8f562c..2cd5a64dc491 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -196,6 +196,7 @@
SUBDIR += libquvi09
SUBDIR += librav1e
SUBDIR += librespot
+ SUBDIR += librist
SUBDIR += librtmp
SUBDIR += libtheora
SUBDIR += libtuner
diff --git a/multimedia/librist/Makefile b/multimedia/librist/Makefile
new file mode 100644
index 000000000000..06a6ea77940c
--- /dev/null
+++ b/multimedia/librist/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= librist
+DISTVERSION= 0.2.0-RC5.20210325
+CATEGORIES= multimedia
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Library for Reliable Internet Stream Transport (RIST) protocol
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libcjson.so:devel/libcjson
+
+USES= localbase meson pkgconfig
+USE_GITLAB= yes
+USE_LDCONFIG= yes
+
+GL_SITE= https://code.videolan.org
+GL_ACCOUNT= rist
+GL_COMMIT= 24ae978bcacf6a998aa3f2b605690f7d774f9c83
+
+MESON_ARGS= -Duse_mbedtls=false # mbedcrypto needs to be ported
+
+.include <bsd.port.mk>
diff --git a/multimedia/librist/distinfo b/multimedia/librist/distinfo
new file mode 100644
index 000000000000..7e2a461ad164
--- /dev/null
+++ b/multimedia/librist/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616794980
+SHA256 (rist-librist-24ae978bcacf6a998aa3f2b605690f7d774f9c83_GL0.tar.gz) = 4eeb926301dff77a239b5eacef4852ddd662fb728d39af11bf770d2f2828f654
+SIZE (rist-librist-24ae978bcacf6a998aa3f2b605690f7d774f9c83_GL0.tar.gz) = 1643022
diff --git a/multimedia/librist/pkg-descr b/multimedia/librist/pkg-descr
new file mode 100644
index 000000000000..248c68adb182
--- /dev/null
+++ b/multimedia/librist/pkg-descr
@@ -0,0 +1,5 @@
+Reliable Internet Stream Transport is an open source, open specification
+transport protocol designed for reliable transmission of video over lossy
+networks.
+
+WWW: https://code.videolan.org/rist/librist
diff --git a/multimedia/librist/pkg-plist b/multimedia/librist/pkg-plist
new file mode 100644
index 000000000000..3e8447afcbb9
--- /dev/null
+++ b/multimedia/librist/pkg-plist
@@ -0,0 +1,13 @@
+bin/rist2rist
+bin/ristreceiver
+bin/ristsender
+include/librist/common.h
+include/librist/headers.h
+include/librist/librist.h
+include/librist/logging.h
+include/librist/udpsocket.h
+include/librist/version.h
+lib/librist.so
+lib/librist.so.4
+lib/librist.so.4.0.0
+libdata/pkgconfig/librist.pc