aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2021-07-13 04:53:50 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2021-07-13 04:53:50 +0000
commit4f7fbe7e49de4285db647f3b19e6e1f9a07e6beb (patch)
tree02213473c65aa06e8dc34e63b3cf5067dd21c304 /multimedia
parentb3ac7d80ebd67f7e2905f76a4a1ce2255c76b7f6 (diff)
downloadports-4f7fbe7e49de4285db647f3b19e6e1f9a07e6beb.tar.gz
ports-4f7fbe7e49de4285db647f3b19e6e1f9a07e6beb.zip
multimedia/sabbu: add depends for more features
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/sabbu/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/multimedia/sabbu/Makefile b/multimedia/sabbu/Makefile
index ac004bce72b8..e2d9868786af 100644
--- a/multimedia/sabbu/Makefile
+++ b/multimedia/sabbu/Makefile
@@ -1,6 +1,6 @@
PORTNAME= sabbu
PORTVERSION= 0.3.0
-PORTREVISION= 20
+PORTREVISION= 21
CATEGORIES= multimedia
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Sabbu%20${PORTVERSION}
@@ -9,7 +9,10 @@ COMMENT= Program used to time subtitles
LICENSE= GPLv2
-LIB_DEPENDS= libsndfile.so:audio/libsndfile
+LIB_DEPENDS= libsndfile.so:audio/libsndfile \
+ libharfbuzz.so:print/harfbuzz \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
USES= tar:bzip2 compiler:c++11-lang gmake pkgconfig iconv sdl gnome
GNU_CONFIGURE= yes
@@ -17,7 +20,7 @@ CONFIGURE_ARGS= --without-ffmpeg
USE_SDL= sdl
USE_CXXSTD= gnu++98
-USE_GNOME= gtk20
+USE_GNOME= gtk20 cairo gdkpixbuf2
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
LDFLAGS+= -lgmodule-2.0