aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-12-01 00:04:33 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-12-01 00:04:33 +0000
commit61010562f934ef57199aed55647f93100c926936 (patch)
tree3354b9e47a6d3f9c59b367f3b4a2d3b0a929b683 /multimedia
parent102ae5106e73dc28546f0a7a7161fd6d54cd0fa6 (diff)
downloadports-61010562f934ef57199aed55647f93100c926936.tar.gz
ports-61010562f934ef57199aed55647f93100c926936.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg2theora/Makefile17
-rw-r--r--multimedia/ffmpeg2theora/distinfo4
-rw-r--r--multimedia/ffmpeg2theora/files/patch-SConstruct19
-rw-r--r--multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c14
4 files changed, 45 insertions, 9 deletions
diff --git a/multimedia/ffmpeg2theora/Makefile b/multimedia/ffmpeg2theora/Makefile
index 194218b7d145..86684489ba8a 100644
--- a/multimedia/ffmpeg2theora/Makefile
+++ b/multimedia/ffmpeg2theora/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= ffmpeg2theora
-PORTVERSION= 0.28
-PORTREVISION= 4
+PORTVERSION= 0.29
CATEGORIES= multimedia
MASTER_SITES= http://v2v.cc/~j/ffmpeg2theora/downloads/
@@ -15,15 +14,19 @@ COMMENT= Reencode many media file formats to Ogg Theora
LICENSE= GPLv3
-LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
- theora.0:${PORTSDIR}/multimedia/libtheora \
- kate.4:${PORTSDIR}/multimedia/libkate
+LIB_DEPENDS= avcodec:${PORTSDIR}/multimedia/ffmpeg \
+ kate:${PORTSDIR}/multimedia/libkate \
+ theora:${PORTSDIR}/multimedia/libtheora
USE_BZIP2= yes
+USE_ICONV= yes
USE_SCONS= yes
+SCONS_BUILDENV= CC="${CC}" CCFLAGS="${CFLAGS}" \
+ APPEND_CCFLAGS="${CPPFLAGS}" APPEND_LINKFLAGS="${LDFLAGS}"
+MAKE_JOBS_SAFE= yes
-SCONS_ENV+= APPEND_LINKFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
- APPEND_CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN1= ffmpeg2theora.1
PLIST_FILES= bin/ffmpeg2theora
diff --git a/multimedia/ffmpeg2theora/distinfo b/multimedia/ffmpeg2theora/distinfo
index 411d0de0ff50..7702a5bf6744 100644
--- a/multimedia/ffmpeg2theora/distinfo
+++ b/multimedia/ffmpeg2theora/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ffmpeg2theora-0.28.tar.bz2) = 6893c1444d730a1514275ba76ba487ca207205b916d6cb1285704225ee86fe1e
-SIZE (ffmpeg2theora-0.28.tar.bz2) = 95404
+SHA256 (ffmpeg2theora-0.29.tar.bz2) = 214110e2a5afdd8ff8e0be18152e893dbff5dabc1ae1d1124e64d9f93eae946d
+SIZE (ffmpeg2theora-0.29.tar.bz2) = 90143
diff --git a/multimedia/ffmpeg2theora/files/patch-SConstruct b/multimedia/ffmpeg2theora/files/patch-SConstruct
new file mode 100644
index 000000000000..9d37ce376f6b
--- /dev/null
+++ b/multimedia/ffmpeg2theora/files/patch-SConstruct
@@ -0,0 +1,19 @@
+--- SConstruct.orig 2012-06-26 02:15:16.000000000 +0900
++++ SConstruct 2012-07-04 01:17:19.000000000 +0900
+@@ -37,7 +37,7 @@
+ BoolVariable('libkate', 'enable libkate support', 1),
+ BoolVariable('crossmingw', 'Set to 1 for crosscompile with mingw', 0)
+ )
+-env = Environment(options = opts)
++env = Environment(options = opts, CC = Split(os.environ['CC']), CCFLAGS = Split(os.environ['CCFLAGS']))
+ Help(opts.GenerateHelpText(env))
+
+ pkg_flags="--cflags --libs"
+@@ -151,7 +151,6 @@
+ "libavcodec >= 52.30.0",
+ "libpostproc",
+ "libswscale",
+- "libswresample",
+ "libavutil",
+ ]
+ if os.path.exists("./ffmpeg"):
diff --git a/multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c b/multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c
new file mode 100644
index 000000000000..19981ce19dae
--- /dev/null
+++ b/multimedia/ffmpeg2theora/files/patch-src__ffmpeg2theora.c
@@ -0,0 +1,14 @@
+--- src/ffmpeg2theora.c.orig 2012-01-29 17:00:19.000000000 +0900
++++ src/ffmpeg2theora.c 2012-07-04 01:49:09.000000000 +0900
+@@ -2970,7 +2970,11 @@
+ fprintf(stderr,"\nUnable to decode input.\n");
+ return(1);
+ }
++#if LIBAVFORMAT_VERSION_INT < AV_VERSION_INT(53,17,0)
++ av_close_input_file(convert->context);
++#else
+ avformat_close_input(&convert->context);
++#endif
+ }
+ else{
+ if (info.frontend)