aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@fuz.su>2022-06-08 16:38:35 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-06-13 20:37:40 +0000
commit83e849f1f6dadadd5bb6beca5cf8662271b4a4ff (patch)
treee97d80551a9896827cfcdd632a898296b3d5c088 /multimedia
parent0888562d7ea51777bb6149c8a43b214e3ae54b38 (diff)
downloadports-83e849f1f6dadadd5bb6beca5cf8662271b4a4ff.tar.gz
ports-83e849f1f6dadadd5bb6beca5cf8662271b4a4ff.zip
multimedia/zoneminder: fix build on armv7 (again)
After pkubaj@ fixed armv7 support in ports commit 5094662, the fix was upstreamed. Unfortunately upstream made a mistake in processing the patch, leading to broken code on armv7. This was subsequently fixed in the linked commit, but has not made its way into the ports tree yet. Fix the build once again by importing the patch from the commit above. See also: https://cgit.freebsd.org/ports/commit/?id=50946628c31aff06f6ff06504d5164466d34428c See also: https://github.com/ZoneMinder/zoneminder/commit/78a10b6095b3759d341a1a336ac2b73a880871b4 PR: 264550 Approved by: bsd@abinet.ru (maintainer)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/zoneminder/distinfo2
-rw-r--r--multimedia/zoneminder/files/patch-src_zm__utils.cpp16
2 files changed, 17 insertions, 1 deletions
diff --git a/multimedia/zoneminder/distinfo b/multimedia/zoneminder/distinfo
index 3bde15a93e04..820a8dd29abf 100644
--- a/multimedia/zoneminder/distinfo
+++ b/multimedia/zoneminder/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1641049619
+TIMESTAMP = 1654708449
SHA256 (zoneminder-zoneminder-1.36.12_GH0.tar.gz) = 8f2772c9aa891e3e3de6b73e4ce95189af4d5faa886ac13d7ce20972d11c31dd
SIZE (zoneminder-zoneminder-1.36.12_GH0.tar.gz) = 11350267
SHA256 (FriendsOfCake-crud-1429237_GH0.tar.gz) = 4dc57f344623d3c0e735b53ed583e5382aa9e43012215f641cbd8ebad381aadc
diff --git a/multimedia/zoneminder/files/patch-src_zm__utils.cpp b/multimedia/zoneminder/files/patch-src_zm__utils.cpp
new file mode 100644
index 000000000000..aa450dd74cfe
--- /dev/null
+++ b/multimedia/zoneminder/files/patch-src_zm__utils.cpp
@@ -0,0 +1,16 @@
+Partial application of upstream commit 78a10b6 to fix
+armv7 support fix.
+
+https://github.com/ZoneMinder/zoneminder/commit/78a10b6095b3759d341a1a336ac2b73a880871b4
+
+--- src/zm_utils.cpp.orig 2021-12-10 22:36:30 UTC
++++ src/zm_utils.cpp
+@@ -231,6 +231,8 @@ void HwCapsDetect() {
+ unsigned long auxval = 0;
+ elf_aux_info(AT_HWCAP, &auxval, sizeof(auxval));
+ if (auxval & HWCAP_NEON) {
++ #else
++ {
+ #error Unsupported OS.
+ #endif
+ Debug(1,"Detected ARM (AArch32) processor with Neon");