aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-11 22:31:19 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-11 22:31:19 +0000
commit84a66afc908a45f044ec1a877f18622e84fc4119 (patch)
treea708aef807a417ad0af6a6ffc9b13f58533d438e /multimedia
parentfb6c587380649e9d1cbdd32c4f4b00120d9e3d86 (diff)
downloadports-84a66afc908a45f044ec1a877f18622e84fc4119.tar.gz
ports-84a66afc908a45f044ec1a877f18622e84fc4119.zip
multimedia/libopenshot: fix build on powerpc
LLVM doesn't have libomp on powerpc: CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:230 (message): Could NOT find OpenMP_C (missing: OpenMP_C_FLAGS OpenMP_C_LIB_NAMES)
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libopenshot/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/multimedia/libopenshot/Makefile b/multimedia/libopenshot/Makefile
index f54dd0a79d4d..6d0834c9c13c 100644
--- a/multimedia/libopenshot/Makefile
+++ b/multimedia/libopenshot/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libopenshot-audio.so:audio/libopenshot-audio \
libavformat.so:multimedia/ffmpeg \
libzmq.so:net/libzmq4
-USES= cmake compiler:c++11-lang pkgconfig python:3.5+ qt:5
+USES= cmake pkgconfig python:3.5+ qt:5
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= OpenShot
@@ -46,4 +46,12 @@ OPENCV_CMAKE_BOOL= ENABLE_OPENCV
OPENCV_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenCV\
CMAKE_DISABLE_FIND_PACKAGE_Protobuf
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == powerpc
+USES+= compiler:gcc-c++11-lib
+.else
+USES+= compiler:c++11-lang
+.endif
+
.include <bsd.port.mk>