aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-13 19:18:56 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-13 19:18:56 +0000
commit9eeb2b4a0c3cef877116b5f13e16f7f3c606bfe5 (patch)
tree62841e105d3d3bc6677b4d749b8ec016adaa3999 /multimedia
parent1fb2a4c12d8828f93b24eef313aefddb3a42604b (diff)
downloadports-9eeb2b4a0c3cef877116b5f13e16f7f3c606bfe5.tar.gz
ports-9eeb2b4a0c3cef877116b5f13e16f7f3c606bfe5.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/replex/Makefile30
-rw-r--r--multimedia/replex/distinfo4
-rw-r--r--multimedia/replex/files/patch-Makefile29
-rw-r--r--multimedia/replex/pkg-plist5
4 files changed, 18 insertions, 50 deletions
diff --git a/multimedia/replex/Makefile b/multimedia/replex/Makefile
index fa32e910f035..79fcc3d70a9f 100644
--- a/multimedia/replex/Makefile
+++ b/multimedia/replex/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= replex
-PORTVERSION= 0.1.3
-PORTREVISION= 1
+PORTVERSION= 0.1.4
PORTEPOCH= 1
CATEGORIES= multimedia
MASTER_SITES= http://www.metzlerbros.org/dvb/
@@ -15,13 +14,23 @@ MASTER_SITES= http://www.metzlerbros.org/dvb/
MAINTAINER= ports@FreeBSD.org
COMMENT= Remultiplex an MPEG2 TS into a PS for DVD
-USE_GMAKE= yes
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
-CFLAGS+= -I${LOCALBASE}/include -DO_LARGEFILE=0
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
-TOFIX= avi.h element.h mpg_common.h pes.h replex.h ringbuffer.h \
- replex.c ts.c
+USE_GMAKE= yes
+MAKE_ARGS= CFLAGS="${CFLAGS}" DEFINES="${CPPFLAGS} -DO_LARGEFILE=0" \
+ LIBS="${LDFLAGS}"
+
+PLIST_FILES= bin/replex
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES README TODO
+.endif
+
+post-patch:
+ @${GREP} -lR "<stdint\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<inttypes.h>|g'
+ @${REINPLACE_CMD} -e \
+ 's|-L. -lreplex|libreplex.a $${LIBS}|g' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/replex ${PREFIX}/bin/
@@ -32,11 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/TODO ${DOCSDIR}/
.endif
-do-configure:
-.if !exists(/usr/include/stdint.h)
-.for i in ${TOFIX}
- @${REINPLACE_CMD} -e 's|stdint.h|sys/types.h|g' ${WRKSRC}/${i}
-.endfor
-.endif
-
.include <bsd.port.mk>
diff --git a/multimedia/replex/distinfo b/multimedia/replex/distinfo
index 50a387baabae..bb9226b1ceb5 100644
--- a/multimedia/replex/distinfo
+++ b/multimedia/replex/distinfo
@@ -1,2 +1,2 @@
-MD5 (replex-0.1.3.tar.gz) = db10d1f8665adce061e277b0c0336c73
-SIZE (replex-0.1.3.tar.gz) = 43211
+MD5 (replex-0.1.4.tar.gz) = 4f7f8772528327f8eb592eeb93554f3a
+SIZE (replex-0.1.4.tar.gz) = 43292
diff --git a/multimedia/replex/files/patch-Makefile b/multimedia/replex/files/patch-Makefile
deleted file mode 100644
index 47549bc6f95a..000000000000
--- a/multimedia/replex/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig Sun Dec 28 17:57:19 2003
-+++ Makefile Tue Jan 20 05:17:32 2004
-@@ -2,7 +2,7 @@
- DISTNAME = replex-$(VERSION)
- TARNAME = $(DISTNAME).tar.gz
- INCS = -I..
--CFLAGS = -g -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
-+CFLAGS += -g -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
- LIBS = -L.
- MFLAG = -M
- OBJS = element.o pes.o mpg_common.o ts.o ringbuffer.o avi.o multiplex.o
-@@ -26,7 +26,7 @@
- ar -rcs libreplex.a $(OBJS)
-
- replex: libreplex.a replex.o
-- $(CC) -o replex replex.o -L. -lreplex
-+ $(CC) -o replex replex.o -L. -lreplex $(LDFLAGS)
-
- dist: $(SRC) $(HEADERS) Makefile
- mkdir $(DISTNAME)
-@@ -47,7 +47,7 @@
-
-
- .depend:
-- $(CC) $(DEFINES) $(MFLAG) $(SRC) $(CSRC) $(CPPSRC) $(INCS)> .depend
-+ $(CC) $(CFLAGS) $(DEFINES) $(MFLAG) $(SRC) $(CSRC) $(CPPSRC) $(INCS)> .depend
-
-
-
diff --git a/multimedia/replex/pkg-plist b/multimedia/replex/pkg-plist
deleted file mode 100644
index 48e2c3a5ec23..000000000000
--- a/multimedia/replex/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-bin/replex
-%%PORTDOCS%%%%DOCSDIR%%/CHANGES
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%@dirrm %%DOCSDIR%%