aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
commitd09ed096c44ca516f3e4922e292b4afabd03ff11 (patch)
tree8472e59ca02578120ca7b8bc5e2af50d2954440e /multimedia
parent31a195fb72446a7d02336b8fa1b9c1e0032f95cb (diff)
downloadports-d09ed096c44ca516f3e4922e292b4afabd03ff11.tar.gz
ports-d09ed096c44ca516f3e4922e292b4afabd03ff11.zip
*/*: Replace USE_GCC=any with USE_GCC=yes
USE_GCC=any has been equivalent to USE_GCC=yes in most cases (such as i386 and amd64 since 12.x and depending on configuration 11.x, most newer installations on other platforms, and 13.x across the board). Since commit 96c17633d90386b5bcf8 Mk/bsd.gcc.mk is treating them as different spellings of the same, so continue the deorbiting of the USE_GCC=any form and simply replace it with USE_GCC=yes. This should not make any functional difference at all. Discussed with: mat, linimon, pkubaj
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vdr/Makefile2
-rw-r--r--multimedia/x264/Makefile2
-rw-r--r--multimedia/xanim/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/multimedia/vdr/Makefile b/multimedia/vdr/Makefile
index 240e1f25a455..5e5a3666d6b0 100644
--- a/multimedia/vdr/Makefile
+++ b/multimedia/vdr/Makefile
@@ -68,7 +68,7 @@ IGNORE= will not work due to lack of driver support
.endif
.if ${ARCH} == "i386"
-USE_GCC= any
+USE_GCC= yes
.endif
post-patch:
diff --git a/multimedia/x264/Makefile b/multimedia/x264/Makefile
index 434d005f329b..788556e8738a 100644
--- a/multimedia/x264/Makefile
+++ b/multimedia/x264/Makefile
@@ -93,7 +93,7 @@ PGO_ALL_TARGET= fprofiled
# y4m sample video
Y4M_VIDEO= example.y4m
Y4M_VIDEO_DISTFILE= example.y4m.bz2
-PGO_VARS= USE_GCC=any \
+PGO_VARS= USE_GCC=yes \
LICENSE+=PGO LICENSE_COMB=multi
# ${Y4M_VIDEO_DISTFILE} file may not be mirrored
diff --git a/multimedia/xanim/Makefile b/multimedia/xanim/Makefile
index 35f67639d478..36e3c5806b17 100644
--- a/multimedia/xanim/Makefile
+++ b/multimedia/xanim/Makefile
@@ -22,7 +22,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
# which is fatal for imake.
USES= alias imake xorg
-USE_GCC= any
+USE_GCC= yes
USE_XORG= xext xt sm ice xext x11
MAKE_ARGS+= -j 2 # safe and helps even the single-CPU machines
DLLDIR= ${PREFIX}/lib/X11/xanim