aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-01 11:09:36 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-01 11:09:36 +0000
commitd44c8a67e3e96acb2bfabe2710f2d354a5bfa749 (patch)
treed52aa952005e31414368da0738941bf0917538d2 /multimedia
parentf7fa170dc83e135fb49504af17bb6fdaef5df7d5 (diff)
downloadports-d44c8a67e3e96acb2bfabe2710f2d354a5bfa749.tar.gz
ports-d44c8a67e3e96acb2bfabe2710f2d354a5bfa749.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile6
-rw-r--r--multimedia/mencoder/distinfo4
-rw-r--r--multimedia/mplayer/Makefile6
-rw-r--r--multimedia/mplayer/Makefile.options24
-rw-r--r--multimedia/mplayer/Makefile.shared6
-rw-r--r--multimedia/mplayer/distinfo4
-rw-r--r--multimedia/mplayer/files/patch-configure40
-rw-r--r--multimedia/mplayer/files/patch-libavcodec-x86-snowdsp_mmx.c19
-rw-r--r--multimedia/mplayer/files/patch-libavformat-udp.c11
-rw-r--r--multimedia/mplayer/files/patch-libmpcodecs-vd_ffmpeg.c11
-rw-r--r--multimedia/mplayer/files/pkg-message.in6
11 files changed, 102 insertions, 35 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index 9d2220ea3c78..8b059a40d5b0 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -6,7 +6,7 @@
PORTNAME= mencoder
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 0
COMMENT= Convenient video file and movie encoder
RESTRICTED= Port has restricted dependencies
@@ -27,7 +27,9 @@ OPTIONS+= OPENJPEG "Enable JPEG2000 support" off
OPTIONS+= MNG "Enable MNG input support" off
OPTIONS+= LIBDV "Enable libdv support" off
OPTIONS+= MAD "Enable mad MPEG audio engine support" off
-OPTIONS+= AMR "Enable opencore AMR audio codec support" off
+OPTIONS+= AMR_NB "AMR Narrow Band encoder (opencore)" off
+OPTIONS+= AMR_WB "AMR Wide Band encoder (opencore)" off
+OPTIONS+= GSM "GSM audio codec" off
OPTIONS+= TWOLAME "Enable twolame MPEG audio codec support" off
OPTIONS+= FAAC "Enable FAAC audio codec support" off
OPTIONS+= LADSPA "Enable LADSPA plugin support" off
diff --git a/multimedia/mencoder/distinfo b/multimedia/mencoder/distinfo
index b9b495d2cf4e..2a500c6069c1 100644
--- a/multimedia/mencoder/distinfo
+++ b/multimedia/mencoder/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mplayer-1.0rc20101106.tar.bz2) = 00ea68f869435b1a5e363d87cf35fd6711f703aaa05a93f9e4d03a52f3ec8751
-SIZE (mplayer-1.0rc20101106.tar.bz2) = 10014975
+SHA256 (mplayer-1.0rc20110329.tar.bz2) = 802a87f3d4ac77c2ea1e2b20c6a73951034d7553ac57acc496fea1b4b5565e17
+SIZE (mplayer-1.0rc20110329.tar.bz2) = 9864317
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 86baebf192a1..5326748b2e6a 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 0
COMMENT= High performance media player supporting many formats
.include "${.CURDIR}/Makefile.shared"
@@ -43,7 +43,9 @@ OPTIONS+= LIBCACA "Enable libcaca support" off
OPTIONS+= SVGALIB "Enable svgalib support" off
OPTIONS+= LIBDV "Enable libdv support" off
OPTIONS+= MAD "Enable mad MPEG audio engine support" off
-OPTIONS+= AMR "Enable opencore AMR audio codec support" off
+OPTIONS+= AMR_NB "AMR Narrow Band encoder (opencore)" off
+OPTIONS+= AMR_WB "AMR Wide Band encoder (opencore)" off
+OPTIONS+= GSM "GSM audio codec" off
OPTIONS+= LADSPA "Enable LADSPA plugin support" off
OPTIONS+= SPEEX "Enable speex audio codec support" on
OPTIONS+= THEORA "Enable ogg theora video support" off
diff --git a/multimedia/mplayer/Makefile.options b/multimedia/mplayer/Makefile.options
index 5a1b600d6251..006dad0955ad 100644
--- a/multimedia/mplayer/Makefile.options
+++ b/multimedia/mplayer/Makefile.options
@@ -207,11 +207,27 @@ BUILD_DEPENDS+= realplay:${PORTSDIR}/multimedia/linux-realplayer
CONFIGURE_ARGS+= --disable-real
.endif
-.if defined(WITH_AMR)
-LIB_DEPENDS+= opencore-amrwb.0:${PORTSDIR}/audio/opencore-amr
+.if defined(WITH_AMR_NB) || defined (WITH_AMR_WB)
+LIB_DEPENDS+= opencore-amrnb.0:${PORTSDIR}/audio/opencore-amr
+.endif
+
+.ifdef(WITH_AMR_NB)
+CONFIGURE_ARGS+= --enable-libopencore_amrnb --enable-version3
+.else
+CONFIGURE_ARGS+= --disable-libopencore_amrnb
+.endif
+
+.ifdef(WITH_AMR_WB)
+CONFIGURE_ARGS+= --enable-libopencore_amrwb --enable-version3
+.else
+CONFIGURE_ARGS+= --disable-libopencore_amrwb
+.endif
+
+.ifdef(WITH_GSM)
+LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
+CONFIGURE_ARGS+= --enable-libgsm
.else
-CONFIGURE_ARGS+= --disable-libopencore_amrnb \
- --disable-libopencore_amrwb
+CONFIGURE_ARGS+= --disable-libgsm
.endif
.if defined(WITH_V4L)
diff --git a/multimedia/mplayer/Makefile.shared b/multimedia/mplayer/Makefile.shared
index f7eea1a4c64c..40b7d5600da8 100644
--- a/multimedia/mplayer/Makefile.shared
+++ b/multimedia/mplayer/Makefile.shared
@@ -2,7 +2,7 @@
# mplayer and mencoder....the variables that we need to set
# before we include bsd.port.pre.mk
-MPLAYER_SNAPSHOT_DATE= 2010-11-06
+MPLAYER_SNAPSHOT_DATE= 2011-03-29
MPLAYER_PORT_VERSION= 1.0.r${MPLAYER_SNAPSHOT_DATE:S/-//g}
CATEGORIES?= multimedia audio
MASTER_SITES= http://freebsd.unixfreunde.de/sources/ \
@@ -26,7 +26,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
TMPDIR="${WRKSRC}"
-CONFIGURE_ARGS= --disable-bitmap-font \
+CONFIGURE_ARGS= --cc=${CC} \
+ --host-cc=${CC} \
+ --disable-bitmap-font \
--disable-liba52
WANT_GNOME= yes
diff --git a/multimedia/mplayer/distinfo b/multimedia/mplayer/distinfo
index b9b495d2cf4e..2a500c6069c1 100644
--- a/multimedia/mplayer/distinfo
+++ b/multimedia/mplayer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mplayer-1.0rc20101106.tar.bz2) = 00ea68f869435b1a5e363d87cf35fd6711f703aaa05a93f9e4d03a52f3ec8751
-SIZE (mplayer-1.0rc20101106.tar.bz2) = 10014975
+SHA256 (mplayer-1.0rc20110329.tar.bz2) = 802a87f3d4ac77c2ea1e2b20c6a73951034d7553ac57acc496fea1b4b5565e17
+SIZE (mplayer-1.0rc20110329.tar.bz2) = 9864317
diff --git a/multimedia/mplayer/files/patch-configure b/multimedia/mplayer/files/patch-configure
index 6d3ac192f2ad..d2675dbac8b4 100644
--- a/multimedia/mplayer/files/patch-configure
+++ b/multimedia/mplayer/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2010-11-03 17:12:22.000000000 +0900
-+++ configure 2011-01-05 23:58:07.000000000 +0900
-@@ -565,7 +565,7 @@
+--- configure.orig 2011-03-13 01:32:55.000000000 +0100
++++ configure 2011-03-18 17:05:13.932557908 +0100
+@@ -614,7 +614,7 @@
_iwmmxt=auto
_mtrr=auto
_altivec=auto
@@ -9,7 +9,7 @@
_ranlib=ranlib
_windres=windres
_cc=cc
-@@ -1371,7 +1371,6 @@
+@@ -1416,7 +1416,6 @@
*)
echo "Unknown parameter: $ac_option"
@@ -17,7 +17,7 @@
;;
esac
-@@ -1480,8 +1479,8 @@
+@@ -1525,8 +1524,8 @@
_timer=timer-linux.c
_getch=getch2.c
if freebsd ; then
@@ -28,7 +28,7 @@
fi
if netbsd || dragonfly ; then
-@@ -3535,22 +3534,10 @@
+@@ -3577,22 +3576,10 @@
if linux ; then
THREAD_CFLAGS=-D_REENTRANT
elif freebsd || netbsd || openbsd || bsdos ; then
@@ -54,16 +54,16 @@
if test "$_pthreads" = yes ; then
test $_ld_pthread && res_comment="using $_ld_pthread"
def_pthreads='#define HAVE_PTHREADS 1'
-@@ -3828,7 +3815,7 @@
- #define _ISOC99_SOURCE
- #include <stdarg.h>
- #include <stdio.h>
--int main(void) { va_list ap = NULL; vsscanf("foo", "bar", ap); return 0; }
-+int main(void) { va_list ap; vsscanf("foo", "bar", ap); return 0; }
- EOF
- _vsscanf=no
- cc_check && _vsscanf=yes
-@@ -6912,6 +6899,16 @@
+@@ -6354,7 +6341,7 @@
+ echocheck "libgsm"
+ if test "$_libgsm" = auto ; then
+ _libgsm=no
+- statement_check gsm/gsm.h 'gsm_create()' -lgsm && _libgsm=yes
++ statement_check gsm.h 'gsm_create()' -lgsm && _libgsm=yes
+ fi
+ if test "$_libgsm" = yes ; then
+ def_libgsm='#define CONFIG_LIBGSM 1'
+@@ -6852,6 +6839,16 @@
nolibrtmp=no
def_librtmp='#define CONFIG_LIBRTMP 1'
inputmodules="librtmp $inputmodules"
@@ -80,7 +80,7 @@
else
nolibrtmp=yes
_librtmp=no
-@@ -7283,7 +7280,7 @@
+@@ -7214,7 +7211,7 @@
def_muxers='#define CONFIG_MUXERS 1'
else
# mpeg1video for vf_lavc, snow for vf_uspp / vf_mcdeint,
@@ -89,7 +89,7 @@
libavmuxers=""
def_muxers='#define CONFIG_MUXERS 0'
fi
-@@ -7645,8 +7642,11 @@
+@@ -7559,8 +7556,11 @@
if test "$_gui" = yes ; then
# Required libraries
@@ -102,8 +102,8 @@
+ if ! echo $libavdecoders | grep -q PNG_DECODER ; then
die "The GUI requires libavcodec with PNG support (needs zlib)."
fi
- test "$_freetype" = no && test "$_bitmap_font" = no && \
-@@ -8034,7 +8034,7 @@
+ test "$_freetype" = no && test "$_bitmap_font" = no &&
+@@ -7947,7 +7947,7 @@
EXESUF = $_exesuf
EXESUFS_ALL = .exe
diff --git a/multimedia/mplayer/files/patch-libavcodec-x86-snowdsp_mmx.c b/multimedia/mplayer/files/patch-libavcodec-x86-snowdsp_mmx.c
new file mode 100644
index 000000000000..336a954375db
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavcodec-x86-snowdsp_mmx.c
@@ -0,0 +1,19 @@
+--- ffmpeg/libavcodec/x86/snowdsp_mmx.c.orig 2011-03-12 15:13:39.000000000 +0100
++++ ffmpeg/libavcodec/x86/snowdsp_mmx.c 2011-03-25 13:12:53.087099520 +0100
+@@ -675,14 +675,14 @@
+
+ #define snow_inner_add_yblock_sse2_end_8\
+ "sal $1, %%"REG_c" \n\t"\
+- "add $"PTR_SIZE"*2, %1 \n\t"\
++ "addb $"PTR_SIZE"*2, %1 \n\t"\
+ snow_inner_add_yblock_sse2_end_common1\
+ "sar $1, %%"REG_c" \n\t"\
+ "sub $2, %2 \n\t"\
+ snow_inner_add_yblock_sse2_end_common2
+
+ #define snow_inner_add_yblock_sse2_end_16\
+- "add $"PTR_SIZE"*1, %1 \n\t"\
++ "addw $"PTR_SIZE"*1, %1 \n\t"\
+ snow_inner_add_yblock_sse2_end_common1\
+ "dec %2 \n\t"\
+ snow_inner_add_yblock_sse2_end_common2
diff --git a/multimedia/mplayer/files/patch-libavformat-udp.c b/multimedia/mplayer/files/patch-libavformat-udp.c
new file mode 100644
index 000000000000..8efe47f4d638
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libavformat-udp.c
@@ -0,0 +1,11 @@
+--- ffmpeg/libavformat/udp.c.orig 2011-03-16 13:49:21.000000000 +0100
++++ ffmpeg/libavformat/udp.c 2011-03-18 17:18:12.884305376 +0100
+@@ -42,6 +42,8 @@
+ #define IPV6_DROP_MEMBERSHIP IPV6_LEAVE_GROUP
+ #endif
+
++#define IPPROTO_IPV6 41
++
+ typedef struct {
+ int udp_fd;
+ int ttl;
diff --git a/multimedia/mplayer/files/patch-libmpcodecs-vd_ffmpeg.c b/multimedia/mplayer/files/patch-libmpcodecs-vd_ffmpeg.c
new file mode 100644
index 000000000000..482e0a278059
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libmpcodecs-vd_ffmpeg.c
@@ -0,0 +1,11 @@
+--- libmpcodecs/vd_ffmpeg.c.orig 2011-02-05 15:02:49.000000000 +0100
++++ libmpcodecs/vd_ffmpeg.c 2011-03-24 19:10:08.064575435 +0100
+@@ -423,7 +423,7 @@
+ }
+ /* Pass palette to codec */
+ if (sh->bih && (sh->bih->biBitCount <= 8)) {
+- avctx->palctrl = calloc(1, sizeof(AVPaletteControl));
++ avctx->palctrl = av_malloc(sizeof(AVPaletteControl));
+ avctx->palctrl->palette_changed = 1;
+ if (sh->bih->biSize-sizeof(*sh->bih))
+ /* Palette size in biSize */
diff --git a/multimedia/mplayer/files/pkg-message.in b/multimedia/mplayer/files/pkg-message.in
index 01696af17ebe..e6902d63687d 100644
--- a/multimedia/mplayer/files/pkg-message.in
+++ b/multimedia/mplayer/files/pkg-message.in
@@ -5,7 +5,7 @@ output devices, video encoding, repairing broken files etc.
It is auto-generated daily and can be found on the project
homepage in the documentation section:
-http://www.mplayerhq.hu/design7/info.html#docs
+http://www.mplayerhq.hu/design7/documentation.html
===================================================================
MPlayer's system-wide configuration dir is
@@ -23,4 +23,8 @@ you and you dislike this behaviour, you have two options:
- Use mplayer's -softvol command line option
- Set the sysctl hw.snd.vpc_autoreset to 0
===================================================================
+ffmpeg's ogg demuxer is currently broken for ogg streams.
+A possible workaround is the command line option'-demuxer ogg' when
+playing these streams.
+===================================================================