aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-06-17 07:56:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-06-17 07:56:06 +0000
commitedc42f3c38101cea58c0f69ccf772c5103697878 (patch)
treef9db005d417d9a1e01cff49987eb731bc4211fb6 /multimedia
parentacad0de691a68b4b56a61bb2809ccbaa1405a18a (diff)
downloadports-edc42f3c38101cea58c0f69ccf772c5103697878.tar.gz
ports-edc42f3c38101cea58c0f69ccf772c5103697878.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-bad/files/patch-ext_openh264_gstopenh264enc.cpp17
-rw-r--r--multimedia/gstreamer1-plugins-openh264/Makefile2
-rw-r--r--multimedia/msopenh264/Makefile1
-rw-r--r--multimedia/msopenh264/files/patch-openh264-2.035
-rw-r--r--multimedia/openh264/Makefile2
-rw-r--r--multimedia/openh264/distinfo6
-rw-r--r--multimedia/openh264/files/patch-clang22
-rw-r--r--multimedia/openh264/pkg-plist6
9 files changed, 64 insertions, 29 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 14dd684b0d43..bb32ab1e2c50 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ffmpeg
PORTVERSION= 4.1.3
-PORTREVISION= 11
+PORTREVISION= 12
PORTEPOCH= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= https://ffmpeg.org/releases/
diff --git a/multimedia/gstreamer1-plugins-bad/files/patch-ext_openh264_gstopenh264enc.cpp b/multimedia/gstreamer1-plugins-bad/files/patch-ext_openh264_gstopenh264enc.cpp
new file mode 100644
index 000000000000..923327d49ec7
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-bad/files/patch-ext_openh264_gstopenh264enc.cpp
@@ -0,0 +1,17 @@
+https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/commit/d2f6facbfb89
+
+gstopenh264enc.cpp:745:14: error: no member named 'bEnableSpsPpsIdAddition' in 'TagEncParamExt'
+ enc_params.bEnableSpsPpsIdAddition = 0;
+ ~~~~~~~~~~ ^
+
+--- ext/openh264/gstopenh264enc.cpp.orig 2018-03-23 20:45:15 UTC
++++ ext/openh264/gstopenh264enc.cpp
+@@ -739,7 +739,7 @@ gst_openh264enc_set_format (GstVideoEncoder * encoder,
+ enc_params.bEnableSceneChangeDetect = openh264enc->scene_change_detection;
+ enc_params.bEnableFrameSkip = openh264enc->enable_frame_skip;
+ enc_params.bEnableLongTermReference = 0;
+-#if OPENH264_MINOR >= 4
++#if (OPENH264_MAJOR > 1 || (OPENH264_MAJOR == 1 && OPENH264_MINOR >= 4))
+ enc_params.eSpsPpsIdStrategy = CONSTANT_ID;
+ #else
+ enc_params.bEnableSpsPpsIdAddition = 0;
diff --git a/multimedia/gstreamer1-plugins-openh264/Makefile b/multimedia/gstreamer1-plugins-openh264/Makefile
index 5b5c388225c1..ad17bad74c1c 100644
--- a/multimedia/gstreamer1-plugins-openh264/Makefile
+++ b/multimedia/gstreamer1-plugins-openh264/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= multimedia
COMMENT= GStreamer (openh264) plugin
diff --git a/multimedia/msopenh264/Makefile b/multimedia/msopenh264/Makefile
index d7b8d90aed93..9c16d2c53eb0 100644
--- a/multimedia/msopenh264/Makefile
+++ b/multimedia/msopenh264/Makefile
@@ -2,6 +2,7 @@
PORTNAME= msopenh264
PORTVERSION= 1.2.1
+PORTREVISION= 1
CATEGORIES= multimedia net
MASTER_SITES= https://www.linphone.org/releases/sources/plugins/msopenh264/
diff --git a/multimedia/msopenh264/files/patch-openh264-2.0 b/multimedia/msopenh264/files/patch-openh264-2.0
new file mode 100644
index 000000000000..bcbe40c7c9c1
--- /dev/null
+++ b/multimedia/msopenh264/files/patch-openh264-2.0
@@ -0,0 +1,35 @@
+src/msopenh264dec.cpp:67:11: error: no member named 'eOutputColorFormat' in 'TagSVCDecodingParam'
+ params.eOutputColorFormat = videoFormatI420;
+ ~~~~~~ ^
+src/msopenh264enc.cpp:134:29: error: no member named 'sSliceCfg' in 'SSpatialLayerConfig'
+ params.sSpatialLayers[0].sSliceCfg.uiSliceMode = SM_DYN_SLICE;
+ ~~~~~~~~~~~~~~~~~~~~~~~~ ^
+src/msopenh264enc.cpp:134:53: error: use of undeclared identifier 'SM_DYN_SLICE'
+ params.sSpatialLayers[0].sSliceCfg.uiSliceMode = SM_DYN_SLICE;
+ ^
+src/msopenh264enc.cpp:135:29: error: no member named 'sSliceCfg' in 'SSpatialLayerConfig'
+ params.sSpatialLayers[0].sSliceCfg.sSliceArgument.uiSliceSizeConstraint = ms_factory_get_payload_max_size(mFilter->factory);
+ ~~~~~~~~~~~~~~~~~~~~~~~~ ^
+
+--- src/msopenh264dec.cpp.orig 2016-10-19 15:32:52 UTC
++++ src/msopenh264dec.cpp
+@@ -62,7 +62,7 @@ void MSOpenH264Decoder::initialize()
+ mUnpacker=rfc3984_new();
+ if (mDecoder != 0) {
+ SDecodingParam params = { 0 };
+-#if (OPENH264_MAJOR == 1) && (OPENH264_MINOR >=6)
++#if (OPENH264_MAJOR > 1) || ((OPENH264_MAJOR == 1) && (OPENH264_MINOR >=6))
+ #else
+ params.eOutputColorFormat = videoFormatI420;
+ #endif
+--- src/msopenh264enc.cpp.orig 2017-07-20 13:56:32 UTC
++++ src/msopenh264enc.cpp
+@@ -127,7 +127,7 @@ void MSOpenH264Encoder::initialize()
+ params.sSpatialLayers[0].iSpatialBitrate = targetBitrate;
+ params.sSpatialLayers[0].iMaxSpatialBitrate = maxBitrate;
+
+-#if (OPENH264_MAJOR == 1) && (OPENH264_MINOR >=6)
++#if (OPENH264_MAJOR > 1) || ((OPENH264_MAJOR == 1) && (OPENH264_MINOR >=6))
+ params.sSpatialLayers[0].sSliceArgument.uiSliceMode = SM_SIZELIMITED_SLICE;
+ params.sSpatialLayers[0].sSliceArgument.uiSliceSizeConstraint = ms_factory_get_payload_max_size(mFilter->factory);
+ #else
diff --git a/multimedia/openh264/Makefile b/multimedia/openh264/Makefile
index 1bf09ce7be5b..e8ee68f3be8c 100644
--- a/multimedia/openh264/Makefile
+++ b/multimedia/openh264/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= openh264
-PORTVERSION= 1.8.0
DISTVERSIONPREFIX=v
+DISTVERSION= 2.0.0
PORTEPOCH= 2
CATEGORIES= multimedia
diff --git a/multimedia/openh264/distinfo b/multimedia/openh264/distinfo
index 28581875bcf3..f6caaa9f5d21 100644
--- a/multimedia/openh264/distinfo
+++ b/multimedia/openh264/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1530063403
-SHA256 (cisco-openh264-v1.8.0_GH0.tar.gz) = 08670017fd0bb36594f14197f60bebea27b895511251c7c64df6cd33fc667d34
-SIZE (cisco-openh264-v1.8.0_GH0.tar.gz) = 38695675
+TIMESTAMP = 1557299237
+SHA256 (cisco-openh264-v2.0.0_GH0.tar.gz) = 73c35f80cc487560d11ecabb6d31ad828bd2f59d412f9cd726cc26bfaf4561fd
+SIZE (cisco-openh264-v2.0.0_GH0.tar.gz) = 60216105
diff --git a/multimedia/openh264/files/patch-clang b/multimedia/openh264/files/patch-clang
deleted file mode 100644
index 853016daff7a..000000000000
--- a/multimedia/openh264/files/patch-clang
+++ /dev/null
@@ -1,22 +0,0 @@
-Based on https://github.com/cisco/openh264/pull/2877
-
---- codec/common/arm64/arm_arch64_common_macro.S.orig 2018-06-27 01:36:43 UTC
-+++ codec/common/arm64/arm_arch64_common_macro.S
-@@ -52,13 +52,17 @@ ret
- .align 2
- .global \funcName
- .type \funcName, %function
-+#ifndef __clang__
- .func \funcName
-+#endif
- \funcName:
- .endm
-
- .macro WELS_ASM_AARCH64_FUNC_END
- ret
-+#ifndef __clang__
- .endfunc
-+#endif
- .endm
-
- #endif
diff --git a/multimedia/openh264/pkg-plist b/multimedia/openh264/pkg-plist
index b2e839c73c21..afbe2d82a118 100644
--- a/multimedia/openh264/pkg-plist
+++ b/multimedia/openh264/pkg-plist
@@ -3,16 +3,20 @@ include/wels/codec_app_def.h
include/wels/codec_def.h
include/wels/codec_ver.h
%%PLUGINS%%%%WEBPLUGIN_DIR%%/gmpopenh264.info
+%%PLUGINS%%@rmtry lib/cliqz/defaults/pref/gmpopenh264.js
%%PLUGINS%%@rmtry lib/firefox-nightly/defaults/pref/gmpopenh264.js
%%PLUGINS%%@rmtry lib/firefox/defaults/pref/gmpopenh264.js
%%PLUGINS%%@rmtry lib/seamonkey/defaults/pref/gmpopenh264.js
+%%PLUGINS%%@rmtry lib/thunderbird/defaults/pref/gmpopenh264.js
%%PLUGINS%%%%WEBPLUGIN_DIR%%/gmpopenh264.js
+%%PLUGINS%%@postexec ln -sf %D/%F %D/lib/cliqz/defaults/pref/ 2>/dev/null || true
%%PLUGINS%%@postexec ln -sf %D/%F %D/lib/firefox-nightly/defaults/pref/ 2>/dev/null || true
%%PLUGINS%%@postexec ln -sf %D/%F %D/lib/firefox/defaults/pref/ 2>/dev/null || true
%%PLUGINS%%@postexec ln -sf %D/%F %D/lib/seamonkey/defaults/pref/ 2>/dev/null || true
+%%PLUGINS%%@postexec ln -sf %D/%F %D/lib/thunderbird/defaults/pref/ 2>/dev/null || true
%%PLUGINS%%%%WEBPLUGIN_DIR%%/libgmpopenh264.so
lib/libopenh264.a
lib/libopenh264.so
lib/libopenh264.so.%%PORTVERSION%%
-lib/libopenh264.so.4
+lib/libopenh264.so.5
libdata/pkgconfig/openh264.pc