aboutsummaryrefslogtreecommitdiff
path: root/net-im/ayttm/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-26 19:43:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-05-26 19:43:36 +0000
commit32cd4f5876d2891d181ec965294805b62fa00d91 (patch)
treee01522f30c9342e9948972de5e80a52b90a624b4 /net-im/ayttm/Makefile
parent030ed576bafda7d4f5a59a1810bd8ff2cbd45ddb (diff)
downloadports-32cd4f5876d2891d181ec965294805b62fa00d91.tar.gz
ports-32cd4f5876d2891d181ec965294805b62fa00d91.zip
Notes
Diffstat (limited to 'net-im/ayttm/Makefile')
-rw-r--r--net-im/ayttm/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index ea79a247176f..f20e9ccdac06 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ayttm
PORTVERSION= 0.6.3
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF
@@ -10,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Chat program that combines AIM, ICQ, and Yahoo! Chat into one
LICENSE= GPLv2 # (or later)
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile \
libjasper.so:${PORTSDIR}/graphics/jasper \
@@ -21,17 +23,19 @@ OPTIONS_DEFINE= ESOUND YAHOO
OPTIONS_SUB= yes
YAHOO_DESC= Include Yahoo service
-USE_BZIP2= yes
-USES= gettext gmake iconv pkgconfig
+USES= gettext gmake iconv libtool pkgconfig shebangfix tar:bzip2
USE_XORG= xpm xscrnsaver
USE_GNOME= gtk20
USE_OPENSSL= yes
-USE_AUTOTOOLS= libtool libltdl
+USE_AUTOTOOLS= libltdl
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-oscar --disable-workwizu --enable-smtp --enable-lj \
--disable-arts
+SHEBANG_FILES= ${WRKSRC}/modules/image_filter/ayttm_streamer_wrapper
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
ESOUND_CONFIGURE_ENABLE= esd
ESOUND_USE= GNOME=esound