aboutsummaryrefslogtreecommitdiff
path: root/net-im/centerim
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-18 17:16:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-18 17:16:56 +0000
commit50ee481e0fe491da3c7fb59415b40ac8b52e3c99 (patch)
treefa2b6e55c4c34877fe637bf35a4baa8757299a45 /net-im/centerim
parenta254d0b65d72cba86d3b2b9603912788623df771 (diff)
downloadports-50ee481e0fe491da3c7fb59415b40ac8b52e3c99.tar.gz
ports-50ee481e0fe491da3c7fb59415b40ac8b52e3c99.zip
net-im/centerim: Unbreak by fixing shebang in misc/CenterIMLog2HTML.py
Port changes: * Add LICENSE * Add missing LIB_DEPENDS * Change spaces to tabs * Add USES=python Approved by: portmgr (port compliance, infrastructure)
Notes
Notes: svn path=/head/; revision=464936
Diffstat (limited to 'net-im/centerim')
-rw-r--r--net-im/centerim/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index 00e2f248013f..3e87f9d199d4 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -11,17 +11,21 @@ MASTER_SITES= http://www.centerim.org/download/releases/ \
MAINTAINER= frank@altpeter.de
COMMENT= Text mode menu- and window-driven IM interface
-LIB_DEPENDS= libcurl.so:ftp/curl
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= iconv gmake ncurses pkgconfig shebangfix ssl
+LIB_DEPENDS= libassuan.so:security/libassuan \
+ libcurl.so:ftp/curl \
+ libgpg-error.so:security/libgpg-error
+
+USES= iconv gmake ncurses pkgconfig python shebangfix ssl
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-ssl --with-openssl
CONFLICTS= centericq-[0-9]* centerim-devel-[0-9]*
-SHEBANG_FILES= misc/cimformathistory misc/cimextracthistory.pl
-SHEBANG_LANG= gawk
+SHEBANG_FILES= misc/CenterIMLog2HTML.py misc/cimformathistory misc/cimextracthistory.pl
gawk_OLD_CMD= /bin/gawk
gawk_CMD= /usr/bin/awk
@@ -36,7 +40,7 @@ RSS_DESC= RSS Support
LJ_DESC= LiveJournal Support
GG_DESC= Gadu-Gadu Protocol Support
-OPTIONS_DEFAULT= MULTIBYTE FRIBIDI MSN YAHOO IRC JABBER GPGME RSS LJ GG
+OPTIONS_DEFAULT= MULTIBYTE FRIBIDI MSN YAHOO IRC JABBER GPGME RSS LJ GG
OPTIONS_SUB= yes
@@ -59,8 +63,6 @@ GPGME_LIB_DEPENDS= libgpgme.so:security/gpgme
GPGME_CONFIGURE_OFF= --with-gpgme-prefix=/nonexistent
post-patch:
- @${REINPLACE_CMD} -e '1 s|/usr/bin/python|/usr/bin/env python|' \
- ${WRKSRC}/misc/CenterIMLog2HTML.py
@${REINPLACE_CMD} -e 's|-R$$found_dir|-Wl,-rpath,$$found_dir|' \
${WRKSRC}/configure