aboutsummaryrefslogtreecommitdiff
path: root/net-im/centerim
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-07 11:36:25 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-03-07 11:36:25 +0000
commit60fd2f2773c6242c72154380e879ac407c5e929e (patch)
tree4001971827ef9c3015aaf540232fe88b954cc680 /net-im/centerim
parenteba46cdcb7150c242e100f4dba1591feccfec2b0 (diff)
downloadports-60fd2f2773c6242c72154380e879ac407c5e929e.tar.gz
ports-60fd2f2773c6242c72154380e879ac407c5e929e.zip
- Fix build on 10.x
- Support staging - Use new LIB_DEPENDS syntax - Convert USE_GMAKE to USES - Use new OPTIONS features - Enable options by default as centerim-devel does PR: 185982 Submitted by: amdmi3 Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=347365
Diffstat (limited to 'net-im/centerim')
-rw-r--r--net-im/centerim/Makefile95
-rw-r--r--net-im/centerim/files/patch-libicq2000-src-ContactTree.cpp11
-rw-r--r--net-im/centerim/files/patch-libjabber-jconn.c54
-rw-r--r--net-im/centerim/files/patch-src-hooks-abstracthook.h27
-rw-r--r--net-im/centerim/pkg-plist2
5 files changed, 118 insertions, 71 deletions
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index bc650077901f..c886e24d8801 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -11,11 +11,10 @@ MASTER_SITES= http://www.centerim.org/download/releases/ \
MAINTAINER= frank@altpeter.de
COMMENT= Text mode menu- and window-driven IM interface
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
-USES= iconv
+USES= iconv gmake pkgconfig
USE_OPENSSL= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
@@ -24,6 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFLICTS= centericq-[0-9]* centerim-devel-[0-9]*
OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO AIM IRC JABBER GPGME RSS LJ GG
+
FRIBIDI_DESC= Fribidi Support
MSN_DESC= MSN Protocol
YAHOO_DESC= Yahoo! Messenger Protocol
@@ -34,82 +34,35 @@ RSS_DESC= RSS Support
LJ_DESC= LiveJournal Support
GG_DESC= Gadu-Gadu Protocol Support
-MAN1= cimconv.1 centerim.1
-
-PORTDOCS= FAQ README
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMULTIBYTE}
-CONFIGURE_ARGS+= --enable-locales-fix
-.endif
-
-.if ${PORT_OPTIONS:MFRIBIDI}
-LIB_DEPENDS+= fribidi.3:${PORTSDIR}/converters/fribidi
-CONFIGURE_ARGS+= --with-fribidi
-.endif
+OPTIONS_DEFAULT= MULTIBYTE FRIBIDI MSN YAHOO AIM IRC JABBER GPGME RSS LJ GG
-.if ! ${PORT_OPTIONS:MMSN}
-CONFIGURE_ARGS+= --disable-msn
-.endif
+OPTIONS_SUB= yes
-.if ! ${PORT_OPTIONS:MYAHOO}
-CONFIGURE_ARGS+= --disable-yahoo
-.endif
-
-.if ! ${PORT_OPTIONS:MAIM}
-CONFIGURE_ARGS+= --disable-aim
-.endif
-
-.if ! ${PORT_OPTIONS:MIRC}
-CONFIGURE_ARGS+= --disable-irc
-.endif
-
-.if ! ${PORT_OPTIONS:MJABBER}
-CONFIGURE_ARGS+= --disable-jabber
-.else
-.endif
-
-.if ${PORT_OPTIONS:MGPGME}
-LIB_DEPENDS+= gpgme.19:${PORTSDIR}/security/gpgme
-#CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
-CONFIGURE_ARGS+= --with-ssl
-.else
-CONFIGURE_ARGS+= --without-gpgme
-.endif
-
-.if ! ${PORT_OPTIONS:MRSS}
-CONFIGURE_ARGS+= --disable-rss
-.endif
-
-.if ! ${PORT_OPTIONS:MLJ}
-CONFIGURE_ARGS+= --disable-lj
-.endif
+PORTDOCS= FAQ README
-.if ! ${PORT_OPTIONS:MGG}
-CONFIGURE_ARGS+= --disable-gg
-.else
-LIB_DEPENDS+= gadu.3:${PORTSDIR}/polish/ekg
-LIBGADU= -lgadu
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+MULTIBYTE_CONFIGURE_ENABLE=locales-fix
+FRIBIDI_LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi
+FRIBIDI_CONFIGURE_WITH= fribidi
+MSN_CONFIGURE_ENABLE= msn
+YAHOO_CONFIGURE_ENABLE= yahoo
+AIM_CONFIGURE_ENABLE= aim
+IRC_CONFIGURE_ENABLE= irc
+JABBER_CONFIGURE_ENABLE=jabber
+RSS_CONFIGURE_ENABLE= rss
+LJ_CONFIGURE_ENABLE= lj
+GG_LIB_DEPENDS= libgadu.so:${PORTSDIR}/polish/ekg
+GG_CONFIGURE_ENABLE= gg
+GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
+GPGME_CONFIGURE_OFF= --with-gpgme-prefix=/nonexistent
post-patch:
@${REINPLACE_CMD} -e '1 s|/usr/bin/python|/usr/bin/env python|' \
${WRKSRC}/misc/CenterIMLog2HTML.py
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC} ; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKSRC} ; ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/)
.include <bsd.port.mk>
diff --git a/net-im/centerim/files/patch-libicq2000-src-ContactTree.cpp b/net-im/centerim/files/patch-libicq2000-src-ContactTree.cpp
new file mode 100644
index 000000000000..8341ef22672a
--- /dev/null
+++ b/net-im/centerim/files/patch-libicq2000-src-ContactTree.cpp
@@ -0,0 +1,11 @@
+--- libicq2000/src/ContactTree.cpp.orig 2010-10-26 21:19:06.000000000 +0400
++++ libicq2000/src/ContactTree.cpp 2014-01-21 07:26:17.940860269 +0400
+@@ -19,6 +19,8 @@
+ *
+ */
+
++#include <cstdlib>
++
+ #include "ContactTree.h"
+ #include "events.h"
+
diff --git a/net-im/centerim/files/patch-libjabber-jconn.c b/net-im/centerim/files/patch-libjabber-jconn.c
new file mode 100644
index 000000000000..7f019ce5659e
--- /dev/null
+++ b/net-im/centerim/files/patch-libjabber-jconn.c
@@ -0,0 +1,54 @@
+--- libjabber/jconn.c.orig 2011-05-23 01:06:31.000000000 +0400
++++ libjabber/jconn.c 2014-01-21 07:29:07.642848274 +0400
+@@ -824,7 +824,7 @@
+ free(hash);
+ close(sock);
+ close(fd_file);
+- return;
++ return NULL;
+ }
+
+ recv( sock, buff, SEND_BUF, 0 );
+@@ -833,7 +833,7 @@
+ free(hash);
+ close(sock);
+ close(fd_file);
+- return;
++ return NULL;
+ }
+
+ //socks5 bytestream packet
+@@ -851,7 +851,7 @@
+ free(hash);
+ close(sock);
+ close(fd_file);
+- return;
++ return NULL;
+ }
+ recv( sock, buff, 47, 0 );
+ if( buff[0] != 0x05 || buff[3] != 0x03 )
+@@ -859,7 +859,7 @@
+ free(hash);
+ close(sock);
+ close(fd_file);
+- return;
++ return NULL;
+ }
+
+
+@@ -889,6 +889,7 @@
+
+
+ #endif
++ return NULL;
+ }
+
+
+@@ -961,5 +962,6 @@
+
+ pthread_exit(0);
+ #endif
+-
++
++ return NULL;
+ }
diff --git a/net-im/centerim/files/patch-src-hooks-abstracthook.h b/net-im/centerim/files/patch-src-hooks-abstracthook.h
new file mode 100644
index 000000000000..1aa62b5bfa62
--- /dev/null
+++ b/net-im/centerim/files/patch-src-hooks-abstracthook.h
@@ -0,0 +1,27 @@
+--- src/hooks/abstracthook.h.orig 2011-05-23 01:06:31.000000000 +0400
++++ src/hooks/abstracthook.h 2014-01-21 08:30:44.206593005 +0400
+@@ -47,11 +47,7 @@
+ };
+
+ class abstracthook {
+- protected:
+- enum Encoding {
+- encUTF, encKOI, encUnknown
+- };
+-
++ public:
+ enum logevent {
+ logConnecting,
+ logLogged,
+@@ -63,6 +59,11 @@
+ logConfMembers
+ };
+
++ protected:
++ enum Encoding {
++ encUTF, encKOI, encUnknown
++ };
++
+ protocolname proto;
+ imstatus manualstatus;
+ verticalmenu *searchdest;
diff --git a/net-im/centerim/pkg-plist b/net-im/centerim/pkg-plist
index 4c38d538ca4a..7f561f95edf1 100644
--- a/net-im/centerim/pkg-plist
+++ b/net-im/centerim/pkg-plist
@@ -3,6 +3,8 @@ bin/centerim
bin/cimconv
bin/cimextracthistory.pl
bin/cimformathistory
+man/man1/cimconv.1.gz
+man/man1/centerim.1.gz
%%DATADIR%%/email.wav
%%DATADIR%%/msg.wav
%%DATADIR%%/offline.wav