aboutsummaryrefslogtreecommitdiff
path: root/net-im/climm
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-07-26 07:19:30 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-07-26 07:19:30 +0000
commit308388d3cfa43aacda3627e8ada1576c3a87a4b5 (patch)
tree6898c8e5b497ade10b301620183eb80b68ef6acf /net-im/climm
parentbd510d4f155659ce81bb1af63e52c3e16ef0745b (diff)
downloadports-308388d3cfa43aacda3627e8ada1576c3a87a4b5.tar.gz
ports-308388d3cfa43aacda3627e8ada1576c3a87a4b5.zip
For ports that depend on security/libotr, add the new USE_PKGCONFIG macro.
For all but kdenetwork4 use =build. For it use both just in case. For net-im/clim also fix the manual call to pkg-config for CONFIGURE_ENV
Notes
Notes: svn path=/head/; revision=301551
Diffstat (limited to 'net-im/climm')
-rw-r--r--net-im/climm/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index a4f11c6e6cf8..2c564d90c30b 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -17,6 +17,7 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= CLI-based Multi-Messenger
USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -70,7 +71,7 @@ CONFIGURE_ARGS+= --disable-remote
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-xmpp --enable-ssl=gnutls \
--with-libgcrypt-prefix=${LOCALBASE}
-CONFIGURE_ENV+= LIBGNUTLS_CONFIG="${LOCALBASE}/bin/pkg-config gnutls"
+CONFIGURE_ENV+= LIBGNUTLS_CONFIG="${LOCALBASE}/bin/pkgconf gnutls"
USE_PKGCONFIG= yes
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel \
gnutls:${PORTSDIR}/security/gnutls \