aboutsummaryrefslogtreecommitdiff
path: root/net-im/climm
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-06-16 20:54:21 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-06-16 20:54:21 +0000
commitf232757d1a2463ff553204699fd200ed83cd119f (patch)
tree8d6f153c665725ca2baa43794f656773d7114c97 /net-im/climm
parent08145b44dbcd42f5e8ec4a2770b008268a413333 (diff)
downloadports-f232757d1a2463ff553204699fd200ed83cd119f.tar.gz
ports-f232757d1a2463ff553204699fd200ed83cd119f.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=299430
Diffstat (limited to 'net-im/climm')
-rw-r--r--net-im/climm/Makefile50
1 files changed, 27 insertions, 23 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
index 2a9f2167ceec..fe064b6f744c 100644
--- a/net-im/climm/Makefile
+++ b/net-im/climm/Makefile
@@ -24,48 +24,49 @@ MAN1= climm.1
MAN5= climmrc.5
MAN7= climmcmds.7
-OPTIONS= LIBICONV "Iconv character set conversion" on \
- P2P "Peer2peer connection support" on \
- TCL "TCL scripting support" on \
- OTR "OTR encryption support" on \
- REMOTE "Remote control fifo support" on \
- XMPP "XMPP Jabber support" off
+OPTIONS_DEFINE= ICONV P2P TCL OTR REMOTE XMPP
+OPTIONS_DEFAULT=ICONV P2P TCL OTR REMOTE
+P2P_DESC= Enable Peer2peer connection support
+OTR_DESC= Enable OTR encryption support
+REMOTE_DESC= Enable Remote control fifo support
+XMPP_DESC= Enable XMPP Jabber support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_OTR)
-CONFIGURE_ARGS+= --disable-otr
-.else
+.if ${PORT_OPTIONS:MOTR}
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-otr
LIB_DEPENDS+= otr:${PORTSDIR}/security/libotr
+.else
+CONFIGURE_ARGS+= --disable-otr
.endif
-.if defined(WITHOUT_LIBICONV)
-CONFIGURE_ARGS+= --disable-iconv
-.else
+.if ${PORT_OPTIONS:MICONV}
USE_ICONV= yes
+.else
+CONFIGURE_ARGS+= --disable-iconv
.endif
-.if defined(WITHOUT_P2P)
+.if ${PORT_OPTIONS:MOTR}
+CONFIGURE_ARGS+= --enable-peer2peer
+.else
CONFIGURE_ARGS+= --disable-peer2peer
.endif
-.if defined(WITHOUT_TCL)
-CONFIGURE_ARGS+= --disable-tcl
-.else
+.if ${PORT_OPTIONS:MTCL}
USE_TCL= yes
.include "${PORTSDIR}/Mk/bsd.tcl.mk"
+.else
+CONFIGURE_ARGS+= --disable-tcl
.endif
-.if defined(WITHOUT_REMOTE)
+.if ${PORT_OPTIONS:MREMOTE}
+CONFIGURE_ARGS+= --enable-remote
+.else
CONFIGURE_ARGS+= --disable-remote
.endif
-.if defined(WITHOUT_XMPP)
-USE_OPENSSL= yes
-CONFIGURE_ARGS+= --disable-xmpp --enable-ssl=openssl
-.else
+.if ${PORT_OPTIONS:MXMPP}
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --enable-xmpp --enable-ssl=gnutls \
--with-libgcrypt-prefix=${LOCALBASE}
@@ -75,6 +76,9 @@ LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel \
gnutls:${PORTSDIR}/security/gnutls \
gcrypt:${PORTSDIR}/security/libgcrypt \
gpg-error:${PORTSDIR}/security/libgpg-error
+.else
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --disable-xmpp --enable-ssl=openssl
.endif
post-patch:
@@ -95,4 +99,4 @@ post-install:
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>