aboutsummaryrefslogtreecommitdiff
path: root/net-im/coccinella
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-09 21:49:53 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-03-09 21:49:53 +0000
commit49511559316bc8783516a72df296c59a770a32e6 (patch)
tree16622639ed2f17e354f4c899c7d02da72d3619d4 /net-im/coccinella
parent06a334744e9b2c27f79d8ac7cf07c5e9a94db3f8 (diff)
downloadports-49511559316bc8783516a72df296c59a770a32e6.tar.gz
ports-49511559316bc8783516a72df296c59a770a32e6.zip
Use USES=shebangfix
- Resolve absolute pathnames - Do not silence installation messages - Update pkg-descr - Update WWW - Bump PORTREVISION for package change
Notes
Notes: svn path=/head/; revision=464027
Diffstat (limited to 'net-im/coccinella')
-rw-r--r--net-im/coccinella/Makefile40
-rw-r--r--net-im/coccinella/pkg-descr7
2 files changed, 25 insertions, 22 deletions
diff --git a/net-im/coccinella/Makefile b/net-im/coccinella/Makefile
index bfd8495774cc..55d5cabe544e 100644
--- a/net-im/coccinella/Makefile
+++ b/net-im/coccinella/Makefile
@@ -3,7 +3,7 @@
PORTNAME= coccinella
PORTVERSION= 0.96.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im tk
MASTER_SITES= SF
DISTNAME= Coccinella-${PORTVERSION}Src
@@ -20,42 +20,46 @@ RUN_DEPENDS= snack>=0:audio/snack \
tktray>=0:x11-toolkits/tktray \
tktreectrl>=0:x11-toolkits/tktreectrl
-USES= tk
+USES= shebangfix tk
NO_BUILD= yes
NO_ARCH= yes
PORTDOCS= *
-DESKTOP_ENTRIES="Coccinella" "" "${PORTNAME}" \
- "${PORTNAME}" "Network;InstantMessaging;" ""
+SHEBANG_FILES= Coccinella.tcl
+SHEBANG_LANG= wish
+wish_CMD= ${WISH}
+
+DESKTOP_ENTRIES="Coccinella" "" "${PORTNAME}" "${PORTNAME}" "Network;InstantMessaging;" ""
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
NLS_USES= gettext
-post-patch:
- @${REINPLACE_CMD} -e '1s|/usr/bin/env wish|${WISH}|' \
- ${WRKSRC}/Coccinella.tcl
- @${REINPLACE_CMD} -e 's|exec tclsh|exec ${TCLSH}|' \
- ${WRKSRC}/po/compile.tcl
+post-patch-NLS-on:
+ @${REINPLACE_CMD} -e 's|exec tclsh|exec ${TCLSH}|' ${WRKSRC}/po/compile.tcl
+ @${CHMOD} 755 ${WRKSRC}/po/compile.tcl
+
+post-build-NLS-on:
+ (cd ${WRKSRC}/po && ./compile.tcl)
do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${INSTALL_SCRIPT} ${WRKSRC}/Coccinella.tcl ${STAGEDIR}${DATADIR}
+ ${RLN} ${STAGEDIR}${DATADIR}/Coccinella.tcl ${STAGEDIR}${PREFIX}/bin/coccinella
.for dir in TclXML certificates components contrib docs httpd iconsets items \
jabber jabberlib lib plugins resources themes whiteboard xmpp
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} ${dir} ${STAGEDIR}${DATADIR})
.endfor
- ${INSTALL_SCRIPT} ${WRKSRC}/Coccinella.tcl ${STAGEDIR}${DATADIR}
- ${LN} -sf ${DATADIR}/Coccinella.tcl ${STAGEDIR}${PREFIX}/bin/coccinella
- ${LN} -sf ${DATADIR}/themes/Oxygen/icons/64x64/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
+ ${RLN} ${STAGEDIR}${DATADIR}/themes/Oxygen/icons/64x64/coccinella.png ${STAGEDIR}${PREFIX}/share/pixmaps/coccinella.png
do-install-NLS-on:
- @(cd ${WRKSRC}/po && ${CHMOD} 755 compile.tcl && \
- ./compile.tcl)
- @(cd ${WRKSRC}/msgs && ${COPYTREE_SHARE} "*.msg" ${STAGEDIR}${DATADIR}/msgs)
+ @${MKDIR} ${STAGEDIR}${DATADIR}/msgs
+ ${INSTALL_DATA} ${WRKSRC}/msgs/*.msg ${STAGEDIR}${DATADIR}/msgs
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${COPYTREE_SHARE} "AUTHORS.txt CHANGES.txt README.txt READMEs" ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS.txt CHANGES.txt README.txt ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC}/READMEs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net-im/coccinella/pkg-descr b/net-im/coccinella/pkg-descr
index 29e7cef91336..ccebd6e28ec2 100644
--- a/net-im/coccinella/pkg-descr
+++ b/net-im/coccinella/pkg-descr
@@ -1,6 +1,5 @@
-Coccinella is a Jabber chat client with whiteboard communication. The
-whiteboard let you share your mp3s, photos, and lots of other stuff.
-Further it accepts any fonts. So you will also be able to share mathematical
-formulas with your contacts.
+Coccinella is a free and open-source cross-platform communication tool with a
+built-in whiteboard for improved collaboration with other people.
+WWW: http://thecoccinella.org/
WWW: https://sourceforge.net/projects/coccinella/