aboutsummaryrefslogtreecommitdiff
path: root/net-im/freetalk/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-22 20:34:50 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-22 20:34:50 +0000
commit060caef571c11a2119be3df899bf19a68792265f (patch)
tree60c4e5518fe04751c9d8879aee37965ce2e0cfbe /net-im/freetalk/Makefile
parentd81f8b7c34ca8aa4871ad125acca0f921bbfd1e5 (diff)
downloadports-060caef571c11a2119be3df899bf19a68792265f.tar.gz
ports-060caef571c11a2119be3df899bf19a68792265f.zip
Notes
Diffstat (limited to 'net-im/freetalk/Makefile')
-rw-r--r--net-im/freetalk/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
new file mode 100644
index 000000000000..0a63326c67f3
--- /dev/null
+++ b/net-im/freetalk/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: freetalk
+# Date created: 19 June 2009
+# Whom: Oleg Ginzburg (oleg.ginzburg@nevosoft.ru)
+#
+# $FreeBSD$
+#
+
+PORTNAME= freetalk
+PORTVERSION= 3.2
+CATEGORIES= net-im
+MASTER_SITES= SAVANNAH/freetalk \
+ http://itdev.spb.ru/mirror/
+
+MAINTAINER= oleg.ginzburg@nevosoft.ru
+COMMENT= GNU console based Jabber client
+
+LIB_DEPENDS= loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
+BUILD_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
+RUN_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
+
+USE_GNOME= pkgconfig glib20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+MAN1= freetalk.1
+INFO= freetalk
+
+OPTIONS= BEEP "Use beep program" off
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_BEEP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/beep:${PORTSDIR}/audio/beep
+.endif
+
+.include <bsd.port.mk>