aboutsummaryrefslogtreecommitdiff
path: root/net-im/gajim
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2018-01-30 17:43:34 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2018-01-30 17:43:34 +0000
commit33316eee7fc4cb225b9a7854cfd37971f0b4a0d5 (patch)
tree73dd599ef275beb6306b6fde29109f3683d63e7c /net-im/gajim
parent162e92ca8b39f2d39d9172233e7db1bd4b46e23c (diff)
downloadports-33316eee7fc4cb225b9a7854cfd37971f0b4a0d5.tar.gz
ports-33316eee7fc4cb225b9a7854cfd37971f0b4a0d5.zip
Notes
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/Makefile3
-rw-r--r--net-im/gajim/distinfo6
-rw-r--r--net-im/gajim/files/patch-3dd35f5e762dcef2cf05e325705d0e7a2db2191787
3 files changed, 4 insertions, 92 deletions
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index ca66aaf77ddf..90d4535665c8 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= gajim
-PORTVERSION= 0.16.8
-PORTREVISION= 1
+PORTVERSION= 0.16.9
CATEGORIES= net-im
MASTER_SITES= http://gajim.org/downloads/0.16/
diff --git a/net-im/gajim/distinfo b/net-im/gajim/distinfo
index ce71bada5842..156d02b223b3 100644
--- a/net-im/gajim/distinfo
+++ b/net-im/gajim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496754428
-SHA256 (gajim-0.16.8.tar.bz2) = 46d4887857455b6e104d0478735edb51569bfa384578ffb4f4da81f1649b6a32
-SIZE (gajim-0.16.8.tar.bz2) = 4465521
+TIMESTAMP = 1517301219
+SHA256 (gajim-0.16.9.tar.bz2) = 21b3973676fb04c8b665c83e65377623f321754634d87e3b072f2a7c77fb086c
+SIZE (gajim-0.16.9.tar.bz2) = 4469275
diff --git a/net-im/gajim/files/patch-3dd35f5e762dcef2cf05e325705d0e7a2db21917 b/net-im/gajim/files/patch-3dd35f5e762dcef2cf05e325705d0e7a2db21917
deleted file mode 100644
index 89e5f92e3fa9..000000000000
--- a/net-im/gajim/files/patch-3dd35f5e762dcef2cf05e325705d0e7a2db21917
+++ /dev/null
@@ -1,87 +0,0 @@
---- src/common/crypto.py.orig
-+++ src/common/crypto.py
-@@ -76,50 +76,8 @@
- else:
- return base28_chr[n]
-
--def add_entropy_sources_OpenSSL():
-- # Other possibly variable data. This are very low quality sources of
-- # entropy, but some of them are installation dependent and can be hard
-- # to guess for the attacker.
-- # Data available on all platforms Unix, Windows
-- sources = [sys.argv, sys.builtin_module_names,
-- sys.copyright, sys.getfilesystemencoding(), sys.hexversion,
-- sys.modules, sys.path, sys.version, sys.api_version,
-- os.environ, os.getcwd(), os.getpid()]
--
-- for s in sources:
-- OpenSSL.rand.add(str(s), 1)
--
-- # The /proc filesystem on POSIX systems contains many random variables:
-- # memory statistics, interrupt counts, network packet counts
-- if os.name == 'posix':
-- dirs = ['/proc', '/proc/net', '/proc/self']
-- for d in dirs:
-- if os.access(d, os.R_OK):
-- for filename in os.listdir(d):
-- OpenSSL.rand.add(filename, 0)
-- try:
-- with open(d + os.sep + filename, "r") as fp:
-- # Limit the ammount of read bytes, in case a memory
-- # file was opened
-- OpenSSL.rand.add(str(fp.read(5000)), 1)
-- except IOError:
-- # Ignore all read and access errors
-- pass
--
--PYOPENSSL_PRNG_PRESENT = False
--try:
-- import OpenSSL.rand
-- PYOPENSSL_PRNG_PRESENT = True
--except ImportError:
-- # PyOpenSSL PRNG not available
-- pass
--
- def random_bytes(bytes_):
-- if PYOPENSSL_PRNG_PRESENT:
-- OpenSSL.rand.add(os.urandom(bytes_), bytes_)
-- return OpenSSL.rand.bytes(bytes_)
-- else:
-- return os.urandom(bytes_)
-+ return os.urandom(bytes_)
-
- def generate_nonce():
- return random_bytes(8)
---- src/gajim.py.orig
-+++ src/gajim.py
-@@ -296,20 +296,6 @@
- pid_filename = gajimpaths['PID_FILE']
- config_filename = gajimpaths['CONFIG_FILE']
-
--# Seed the OpenSSL pseudo random number generator from file and initialize
--RNG_SEED = gajimpaths['RNG_SEED']
--PYOPENSSL_PRNG_PRESENT = False
--try:
-- import OpenSSL.rand
-- from common import crypto
-- PYOPENSSL_PRNG_PRESENT = True
-- # Seed from file
-- OpenSSL.rand.load_file(str(RNG_SEED))
-- crypto.add_entropy_sources_OpenSSL()
-- OpenSSL.rand.write_file(str(RNG_SEED))
--except ImportError:
-- log.info("PyOpenSSL PRNG not available")
--
- import traceback
- import errno
- import dialogs
-@@ -456,9 +442,6 @@
- del pid_dir
-
- def on_exit():
-- # Save the entropy from OpenSSL PRNG
-- if PYOPENSSL_PRNG_PRESENT:
-- OpenSSL.rand.write_file(str(RNG_SEED))
- # delete pid file on normal exit
- if os.path.exists(pid_filename):
- os.remove(pid_filename)