aboutsummaryrefslogtreecommitdiff
path: root/net-im/gajim
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-05-01 15:19:41 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-05-01 15:19:41 +0000
commitee01891805aa8a35af0a71b60919b4ae374346bf (patch)
tree44e023c68452dd144bc9313faf4d910e3b491a03 /net-im/gajim
parent532b553a8a8e21224c8f8a3fba2f50c970869f5c (diff)
downloadports-ee01891805aa8a35af0a71b60919b4ae374346bf.tar.gz
ports-ee01891805aa8a35af0a71b60919b4ae374346bf.zip
- add upstream patch to fix connection to servers w/o StartTLS support (r14476)
- remove conflicts with no more existing gajim-devel, while here - bump PORTREVISION Reported by: arrowdodger <6yearold@gmail.com> (by email)
Notes
Notes: svn path=/head/; revision=317027
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/Makefile3
-rw-r--r--net-im/gajim/files/patch-src-common_connection.py11
2 files changed, 12 insertions, 2 deletions
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index 6964eb693fe6..97003584b024 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -2,6 +2,7 @@
PORTNAME= gajim
PORTVERSION= 0.15.3
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.gajim.org/downloads/0.15/
@@ -14,8 +15,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openssl>=0:${PORTSDIR}/security/py-openssl \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:${PORTSDIR}/databases/py-sqlite3 \
${PYTHON_PKGNAMEPREFIX}asn1>=0:${PORTSDIR}/devel/py-asn1
-CONFLICTS= gajim-devel-[0-9]*
-
FETCH_ARGS= -Fpr
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/net-im/gajim/files/patch-src-common_connection.py b/net-im/gajim/files/patch-src-common_connection.py
new file mode 100644
index 000000000000..2c346954394d
--- /dev/null
+++ b/net-im/gajim/files/patch-src-common_connection.py
@@ -0,0 +1,11 @@
+--- src/common/connection.py.orig 2013-03-17 21:55:32.000000000 +0400
++++ src/common/connection.py 2013-05-01 18:47:51.000000000 +0400
+@@ -1331,7 +1331,7 @@
+ certificate=con.Connection.ssl_certificate[i]))
+ return True
+ i += 1
+- if hasattr(con.Connection, 'ssl_fingerprint_sha1'):
++ if con.Connection.ssl_fingerprint_sha1:
+ saved_fingerprint = gajim.config.get_per('accounts', self.name,
+ 'ssl_fingerprint_sha1')
+ if saved_fingerprint: