aboutsummaryrefslogtreecommitdiff
path: root/net-im/gloox
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-01-17 12:27:30 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-01-17 12:27:30 +0000
commita54b9bae02d89d6a0f5e5cd833e7b6afcb21f8b3 (patch)
tree27c2f49e0dffad203e065be5a0328ce4ee77c9e8 /net-im/gloox
parent2a66bb8ec187ed8b1558d8af2fa4635f2c7370b4 (diff)
downloadports-a54b9bae02d89d6a0f5e5cd833e7b6afcb21f8b3.tar.gz
ports-a54b9bae02d89d6a0f5e5cd833e7b6afcb21f8b3.zip
- Fix build on head/10
- Support staging - Use new LIB_DEPENDS format - Unsilence post-install commands
Notes
Notes: svn path=/head/; revision=340030
Diffstat (limited to 'net-im/gloox')
-rw-r--r--net-im/gloox/Makefile14
-rw-r--r--net-im/gloox/files/patch-src-examples-bosh_example.cpp10
-rw-r--r--net-im/gloox/files/patch-src-examples-e2ee_client.cpp10
-rw-r--r--net-im/gloox/files/patch-src-examples-e2ee_server.cpp10
-rw-r--r--net-im/gloox/files/patch-src-examples-ft_recv.cpp10
-rw-r--r--net-im/gloox/files/patch-src-examples-ft_send.cpp10
-rw-r--r--net-im/gloox/files/patch-src-examples-message_example.cpp10
-rw-r--r--net-im/gloox/files/patch-src-examples-pubsub_example.cpp10
-rw-r--r--net-im/gloox/files/patch-src-util.h10
9 files changed, 87 insertions, 7 deletions
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index 35373705c346..f14a45201cf2 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://camaya.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Jabber/XMPP client library
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
- gnutls.26:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
+ libgnutls.so:${PORTSDIR}/security/gnutls
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
@@ -21,13 +21,13 @@ CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|libgnutls-config|pkg-config gnutls|' ${WRKSRC}/configure
+
post-install:
- @${FIND} ${PREFIX}/include/gloox ! -type d | \
- ${SED} "s,${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${PREFIX}/include/gloox -type d | ${SORT} -r | \
- ${SED} "s,${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/include/gloox ! -type d | \
+ ${SED} "s,${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/include/gloox -type d | ${SORT} -r | \
+ ${SED} "s,${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/net-im/gloox/files/patch-src-examples-bosh_example.cpp b/net-im/gloox/files/patch-src-examples-bosh_example.cpp
new file mode 100644
index 000000000000..95078daef4f8
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-bosh_example.cpp
@@ -0,0 +1,10 @@
+--- src/examples/bosh_example.cpp.orig 2009-06-22 11:39:04.000000000 +0200
++++ src/examples/bosh_example.cpp 2013-12-26 22:57:50.576228531 +0100
+@@ -22,6 +22,7 @@
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string>
++#include <ctime>
+
+ #include <cstdio> // [s]print[f]
+
diff --git a/net-im/gloox/files/patch-src-examples-e2ee_client.cpp b/net-im/gloox/files/patch-src-examples-e2ee_client.cpp
new file mode 100644
index 000000000000..eff39267a7a2
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-e2ee_client.cpp
@@ -0,0 +1,10 @@
+--- src/examples/e2ee_client.cpp.orig 2009-10-13 20:57:34.000000000 +0200
++++ src/examples/e2ee_client.cpp 2013-12-26 22:57:55.817222888 +0100
+@@ -15,6 +15,7 @@
+ #include <stdio.h>
+ #include <locale.h>
+ #include <string>
++#include <ctime>
+
+ #include <cstdio> // [s]print[f]
+
diff --git a/net-im/gloox/files/patch-src-examples-e2ee_server.cpp b/net-im/gloox/files/patch-src-examples-e2ee_server.cpp
new file mode 100644
index 000000000000..718256006924
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-e2ee_server.cpp
@@ -0,0 +1,10 @@
+--- src/examples/e2ee_server.cpp.orig 2009-10-13 20:47:21.000000000 +0200
++++ src/examples/e2ee_server.cpp 2013-12-26 22:58:00.534218841 +0100
+@@ -15,6 +15,7 @@
+ #include <stdio.h>
+ #include <locale.h>
+ #include <string>
++#include <ctime>
+
+ #include <cstdio> // [s]print[f]
+
diff --git a/net-im/gloox/files/patch-src-examples-ft_recv.cpp b/net-im/gloox/files/patch-src-examples-ft_recv.cpp
new file mode 100644
index 000000000000..5779773800d1
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-ft_recv.cpp
@@ -0,0 +1,10 @@
+--- src/examples/ft_recv.cpp.orig 2009-10-06 15:14:26.000000000 +0200
++++ src/examples/ft_recv.cpp 2013-12-26 22:58:05.182220399 +0100
+@@ -13,6 +13,7 @@
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string>
++#include <ctime>
+
+ #include <cstdio> // [s]print[f]
+
diff --git a/net-im/gloox/files/patch-src-examples-ft_send.cpp b/net-im/gloox/files/patch-src-examples-ft_send.cpp
new file mode 100644
index 000000000000..b72c4bedbdef
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-ft_send.cpp
@@ -0,0 +1,10 @@
+--- src/examples/ft_send.cpp.orig 2009-10-06 15:15:09.000000000 +0200
++++ src/examples/ft_send.cpp 2013-12-26 22:58:11.944229970 +0100
+@@ -16,6 +16,7 @@
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string>
++#include <ctime>
+ #include <fstream>
+ #include <ios>
+
diff --git a/net-im/gloox/files/patch-src-examples-message_example.cpp b/net-im/gloox/files/patch-src-examples-message_example.cpp
new file mode 100644
index 000000000000..79a5c1b7c6f8
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-message_example.cpp
@@ -0,0 +1,10 @@
+--- src/examples/message_example.cpp.orig 2009-10-26 00:34:48.000000000 +0100
++++ src/examples/message_example.cpp 2013-12-26 22:58:16.855221562 +0100
+@@ -23,6 +23,7 @@
+
+ #include <stdio.h>
+ #include <string>
++#include <ctime>
+
+ #include <cstdio> // [s]print[f]
+
diff --git a/net-im/gloox/files/patch-src-examples-pubsub_example.cpp b/net-im/gloox/files/patch-src-examples-pubsub_example.cpp
new file mode 100644
index 000000000000..8ae8d4a4ed11
--- /dev/null
+++ b/net-im/gloox/files/patch-src-examples-pubsub_example.cpp
@@ -0,0 +1,10 @@
+--- src/examples/pubsub_example.cpp.orig 2009-06-22 11:35:17.000000000 +0200
++++ src/examples/pubsub_example.cpp 2013-12-26 22:58:22.252225373 +0100
+@@ -22,6 +22,7 @@
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <string>
++#include <ctime>
+
+ #if defined( WIN32 ) || defined( _WIN32 )
+ # include <windows.h>
diff --git a/net-im/gloox/files/patch-src-util.h b/net-im/gloox/files/patch-src-util.h
new file mode 100644
index 000000000000..ba86da3fd60c
--- /dev/null
+++ b/net-im/gloox/files/patch-src-util.h
@@ -0,0 +1,10 @@
+--- src/util.h.orig 2009-10-30 18:47:43.000000000 +0100
++++ src/util.h 2013-12-26 21:42:43.366548503 +0100
+@@ -16,6 +16,7 @@
+ #include "gloox.h"
+
+ #include <cmath>
++#include <cstdlib>
+ #include <algorithm>
+ #include <string>
+ #include <list>