aboutsummaryrefslogtreecommitdiff
path: root/net-im/icmpchat
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-04 16:19:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-04 16:19:56 +0000
commit8585fce32bc440dfc15985cd0c59758bf88ccb51 (patch)
treecd256aaaeee3ef4dd7ec7f90d9b0cccea00245b8 /net-im/icmpchat
parent9ea926045826a81a287cc7ae59893e96ae4b5006 (diff)
downloadports-8585fce32bc440dfc15985cd0c59758bf88ccb51.tar.gz
ports-8585fce32bc440dfc15985cd0c59758bf88ccb51.zip
- Fix the build with GCC 4.2 [1]
- Kill EOF whitespace in pkg-descr - Utilize PORTDOCS macro in pkg-plist - Miscellaneous cleanups Reported by: pointyhat (logs) [1]
Notes
Notes: svn path=/head/; revision=194920
Diffstat (limited to 'net-im/icmpchat')
-rw-r--r--net-im/icmpchat/Makefile18
-rw-r--r--net-im/icmpchat/pkg-descr5
-rw-r--r--net-im/icmpchat/pkg-plist12
3 files changed, 15 insertions, 20 deletions
diff --git a/net-im/icmpchat/Makefile b/net-im/icmpchat/Makefile
index 4ba770d27e6c..d21df3d4ee3b 100644
--- a/net-im/icmpchat/Makefile
+++ b/net-im/icmpchat/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: icmpchat
+# New ports collection makefile for: ICMP-Chat
# Date created: 8 October 2002
-# Whom: mwest@uct.ac.za
+# Whom: Matthew West <mwest@uct.ac.za>
#
# $FreeBSD$
#
@@ -12,17 +12,15 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= icmpchat
MAINTAINER= ports@FreeBSD.org
-COMMENT= Simple console-based chat that uses the ICMP protocol
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
+COMMENT= Simple console-based chat that uses ICMP protocol
pre-patch:
@${REINPLACE_CMD} -e 's|-O2 -Wall -pedantic|${CFLAGS}|;\
s|= gcc|?= gcc|;s|default|all|' ${WRKSRC}/Makefile
+# Fix for GCC 4.2
+ @${REINPLACE_CMD} -e \
+ 's|((uint8_t \*) data) +=|data += sizeof(uint8_t *) *|' \
+ ${WRKSRC}/sha256.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icmpchat ${PREFIX}/bin
@@ -35,4 +33,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Todo ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/icmpchat/pkg-descr b/net-im/icmpchat/pkg-descr
index 2c1a202201c4..437d254ceaac 100644
--- a/net-im/icmpchat/pkg-descr
+++ b/net-im/icmpchat/pkg-descr
@@ -1,7 +1,4 @@
ICMP-Chat is a simple console-based chat that uses ICMP packets for
-communication. The data is encrypted using the Rijndael-256 algorithm.
+communication. The data is encrypted using the Rijndael-256 algorithm.
WWW: http://icmpchat.sourceforge.net/
-
---
-mwest@uct.ac.za
diff --git a/net-im/icmpchat/pkg-plist b/net-im/icmpchat/pkg-plist
index 543d8019c927..6201a59ec149 100644
--- a/net-im/icmpchat/pkg-plist
+++ b/net-im/icmpchat/pkg-plist
@@ -1,7 +1,7 @@
bin/icmpchat
-%%PORTDOCS%%share/doc/icmpchat/Changes
-%%PORTDOCS%%share/doc/icmpchat/License
-%%PORTDOCS%%share/doc/icmpchat/Problems
-%%PORTDOCS%%share/doc/icmpchat/Readme
-%%PORTDOCS%%share/doc/icmpchat/Todo
-%%PORTDOCS%%@dirrm share/doc/icmpchat
+%%PORTDOCS%%%%DOCSDIR%%/Changes
+%%PORTDOCS%%%%DOCSDIR%%/License
+%%PORTDOCS%%%%DOCSDIR%%/Problems
+%%PORTDOCS%%%%DOCSDIR%%/Readme
+%%PORTDOCS%%%%DOCSDIR%%/Todo
+%%PORTDOCS%%@dirrm %%DOCSDIR%%