aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber/files
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2001-02-12 19:44:39 +0000
committerJosef Karthauser <joe@FreeBSD.org>2001-02-12 19:44:39 +0000
commit59b10374be5b01bc62003cdc6189859deccde37b (patch)
tree58ba8cb0e20f5d679f59e371b62e4d168af844eb /net-im/jabber/files
parenta1e14fe51f034a56df8f2a3ba49ce2fffe8529ea (diff)
downloadports-59b10374be5b01bc62003cdc6189859deccde37b.tar.gz
ports-59b10374be5b01bc62003cdc6189859deccde37b.zip
Notes
Diffstat (limited to 'net-im/jabber/files')
-rw-r--r--net-im/jabber/files/jabberd.sh17
-rw-r--r--net-im/jabber/files/jserver.sh27
-rw-r--r--net-im/jabber/files/patch-aa38
-rw-r--r--net-im/jabber/files/patch-ab35
-rw-r--r--net-im/jabber/files/patch-ac18
-rw-r--r--net-im/jabber/files/patch-ad50
6 files changed, 97 insertions, 88 deletions
diff --git a/net-im/jabber/files/jabberd.sh b/net-im/jabber/files/jabberd.sh
index c550ee513139..b9ed328b640e 100644
--- a/net-im/jabber/files/jabberd.sh
+++ b/net-im/jabber/files/jabberd.sh
@@ -1,27 +1,26 @@
#! /bin/sh
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/jserver\.sh\$"); then
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/jabberd\.sh\$"); then
echo "$0: Cannot determine the PREFIX" >&2
exit 1
fi
-user=jserver
+user=jabber
rundir=/tmp
-out=${rundir}/jserver.out
+out=/var/log/jabber.log
+hostname=`/bin/hostname`
export PATH=/bin:/usr/bin:${PREFIX}/bin
umask 077
-test -x ${PREFIX}/bin/jserver || exit 1
-echo -n " jserver"
+test -x ${PREFIX}/bin/jabberd || exit 1
+echo -n " jabberd"
cd ${rundir} || exit
arg=${1:-start}
case $arg in
start)
- su -f -m ${user} -c \
- "jserver" \
- >>${out} 2>&1 &;;
+ su -f -m ${user} -c "jabberd -h ${hostname} -c ${PREFIX}/etc/jabber.xml" >${out} 2>&1 &;;
stop)
- killall jserver;;
+ killall jabberd;;
esac
diff --git a/net-im/jabber/files/jserver.sh b/net-im/jabber/files/jserver.sh
deleted file mode 100644
index c550ee513139..000000000000
--- a/net-im/jabber/files/jserver.sh
+++ /dev/null
@@ -1,27 +0,0 @@
-#! /bin/sh
-
-if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/jserver\.sh\$"); then
- echo "$0: Cannot determine the PREFIX" >&2
- exit 1
-fi
-user=jserver
-rundir=/tmp
-out=${rundir}/jserver.out
-
-export PATH=/bin:/usr/bin:${PREFIX}/bin
-umask 077
-
-test -x ${PREFIX}/bin/jserver || exit 1
-echo -n " jserver"
-cd ${rundir} || exit
-
-arg=${1:-start}
-case $arg in
-start)
- su -f -m ${user} -c \
- "jserver" \
- >>${out} 2>&1 &;;
-
-stop)
- killall jserver;;
-esac
diff --git a/net-im/jabber/files/patch-aa b/net-im/jabber/files/patch-aa
index 20549a78e67d..46021cd44f7b 100644
--- a/net-im/jabber/files/patch-aa
+++ b/net-im/jabber/files/patch-aa
@@ -1,27 +1,11 @@
---- src/jserver.xml.in.orig Mon May 1 11:30:00 2000
-+++ src/jserver.xml.in Wed May 10 18:22:14 2000
-@@ -37,12 +37,12 @@
- <log>
-
- <!-- replace with <error>syslog</error> to log to syslog instead, remove to log to STDERR -->
-- <error>@prefix@/var/log/jserver.error</error>
-+ <error>/var/log/jserver.error</error>
-
-- <session>@prefix@/var/log/jserver.log</session>
-+ <session>/var/log/jserver.log</session>
-
- <!-- This will log some basic tracking information about every packet of data (TONS!)
-- <packet>@prefix@/var/log/jserver_packet.log</packet>
-+ <packet>/var/log/jserver_packet.log</packet>
- -->
-
- </log>
-@@ -50,7 +50,7 @@
-
- Data is stored on the filesystem for each user, make sure the folder exists!
-
-- <spool>@prefix@/var/jspool</spool>
-+ <spool>/var/jspool</spool>
-
- Registration instructions and fields, remove to disallow registration:
-
+--- configure.orig Sat Feb 3 05:06:24 2001
++++ configure Sat Feb 10 23:46:59 2001
+@@ -32,7 +32,7 @@
+ LDFLAGS="$LDFLAGS"
+ LIBS="$LIBS"
+ XLDFLAGS="$XLDFLAGS "
+-JHOME=`pwd`
++JHOME='${PREFIX}/lib/jabber'
+
+ ##
+ # Print a cool header
diff --git a/net-im/jabber/files/patch-ab b/net-im/jabber/files/patch-ab
index 6272a4f76e86..5daa875ef780 100644
--- a/net-im/jabber/files/patch-ab
+++ b/net-im/jabber/files/patch-ab
@@ -1,19 +1,22 @@
---- src/Makefile.in.orig Mon May 1 19:47:49 2000
-+++ src/Makefile.in Wed May 17 17:05:17 2000
-@@ -442,14 +442,8 @@
+--- Makefile.orig Sun Jan 21 05:32:48 2001
++++ Makefile Sun Feb 11 17:03:13 2001
+@@ -14,7 +14,18 @@
+ single: single-recursive
+ install:
+- printf "\n\nNo actual make install, you just run it out of the directory!\n"
++ install -c jabberd/jabberd ${PREFIX}/bin
++ install -c jabber.xml ${PREFIX}/etc/jabber.xml.sample
++ install -d ${PREFIX}/lib/jabber/jsm
++ install -c jsm/jsm.so ${PREFIX}/lib/jabber/jsm
++ install -d ${PREFIX}/lib/jabber/xdb_file
++ install -c xdb_file/xdb_file.so ${PREFIX}/lib/jabber/xdb_file
++ install -d ${PREFIX}/lib/jabber/pthsock
++ install -c pthsock/pthsock_client.so ${PREFIX}/lib/jabber/pthsock
++ install -d ${PREFIX}/lib/jabber/dnsrv
++ install -c dnsrv/dnsrv.so ${PREFIX}/lib/jabber/dnsrv
++ install -d ${PREFIX}/lib/jabber/dialback
++ install -c dialback/dialback.so ${PREFIX}/lib/jabber/dialback
- install-data-local:
-- $(SH) if test ! -f $(sysconfdir)/jserver.xml; then \
-- $(mkinstalldirs) $(sysconfdir); \
-- $(INSTALL_DATA) $(top_builddir)/src/jserver.xml $(sysconfdir)/jserver.xml; \
-- else \
-- echo "You already have a jserver.xml installed, not overwriting"; \
-- fi
-- $(mkinstalldirs) $(prefix)/var/jspool
-- $(mkinstalldirs) $(prefix)/var/log
-+ $(mkinstalldirs) $(sysconfdir);
-+ $(INSTALL_DATA) $(top_builddir)/src/jserver.xml $(sysconfdir)/jserver.xml.default
+ all-local:
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/net-im/jabber/files/patch-ac b/net-im/jabber/files/patch-ac
index b2ae73998fab..45e15e08afaa 100644
--- a/net-im/jabber/files/patch-ac
+++ b/net-im/jabber/files/patch-ac
@@ -1,11 +1,11 @@
---- configure.orig Sun Apr 30 20:32:29 2000
-+++ configure Sun Apr 30 20:33:08 2000
-@@ -2321,7 +2321,7 @@
- #define $ac_tr_lib 1
- EOF
+--- jabber.xml.orig Sat Feb 3 22:46:56 2001
++++ jabber.xml Sun Feb 11 01:19:01 2001
+@@ -576,7 +576,7 @@
+ <!--
+ This specifies the file to store the pid of the process in.
+ -->
+- <pidfile>./jabber.pid</pidfile>
++ <pidfile>/var/tmp/jabber.pid</pidfile>
-- LIBS="-lpth $LIBS"
-+ LIBS="-L$prefix/lib -lpth $LIBS"
- else
- echo "$ac_t""no" 1>&6
+ </jabber>
diff --git a/net-im/jabber/files/patch-ad b/net-im/jabber/files/patch-ad
new file mode 100644
index 000000000000..63266c9a12eb
--- /dev/null
+++ b/net-im/jabber/files/patch-ad
@@ -0,0 +1,50 @@
+--- jabber.xml.orig Sun Feb 11 17:24:48 2001
++++ jabber.xml Sun Feb 11 17:26:23 2001
+@@ -41,6 +41,10 @@
+ Multiple <host/> entries are allowed - each one is for a
+ separate virtual server. Note that each host entry must
+ be on one line, the server doesn't like it otherwise! :)
++
++ Currently on FreeBSD jabberd is started with the -h option
++ from /usr/local/etc/rc.d/jabberd.sh. You'll need to modify
++ this before changing below.
+ -->
+
+ <host><jabberd:cmdline flag="h">localhost</jabberd:cmdline></host>
+@@ -193,7 +197,9 @@
+ entry for <host/> above.
+ -->
+
++ <!--
+ <update><jabberd:cmdline flag="h">localhost</jabberd:cmdline></update>
++ -->
+
+ <!--
+ This enables the server to automatically update the
+@@ -298,7 +304,7 @@
+ <xdb_file>./xdb_file/xdb_file.so</xdb_file>
+ </load>
+ <xdb_file xmlns="jabber:config:xdb_file">
+- <spool><jabberd:cmdline flag='s'>./spool</jabberd:cmdline></spool>
++ <spool><jabberd:cmdline flag='s'>/var/spool/jabber</jabberd:cmdline></spool>
+ </xdb_file>
+ </xdb>
+
+@@ -357,7 +363,7 @@
+ <host/>
+ <logtype/>
+ <format>%d: [%t] (%h): %s</format>
+- <file>error.log</file>
++ <file>/var/log/jabber.error</file>
+ <stderr/>
+ </log>
+
+@@ -370,7 +376,7 @@
+ <host/>
+ <logtype>record</logtype>
+ <format>%d %h %s</format>
+- <file>record.log</file>
++ <file>/var/log/jabber.record</file>
+ </log>
+
+ <!-- The following two services are for handling server-to-server traffic. -->