aboutsummaryrefslogtreecommitdiff
path: root/net-im/kaccounts-integration
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2023-07-01 07:23:39 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2023-07-01 07:30:31 +0000
commite329c603964f87f721a96e49f7ac137c3344e4c6 (patch)
tree2b97c040d2ae2607cfbde04397f35c751fa7fe07 /net-im/kaccounts-integration
parent93aa38dc68ed607ebee1ebe257926a14b3f7357f (diff)
downloadports-e329c603964f87f721a96e49f7ac137c3344e4c6.tar.gz
ports-e329c603964f87f721a96e49f7ac137c3344e4c6.zip
net-im/kaccounts-integration: fix build on powerpc* with llvm < 16
fatal error: error in backend: failed to perform tail call elimination on a call site marked musttail
Diffstat (limited to 'net-im/kaccounts-integration')
-rw-r--r--net-im/kaccounts-integration/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-im/kaccounts-integration/Makefile b/net-im/kaccounts-integration/Makefile
index 069f829bfd1a..d06a5c382a71 100644
--- a/net-im/kaccounts-integration/Makefile
+++ b/net-im/kaccounts-integration/Makefile
@@ -23,4 +23,11 @@ USE_KDE= auth codecs config configwidgets coreaddons dbusaddons \
USE_QT= concurrent core dbus declarative gui network widgets xml \
buildtools:build qmake:build
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*} && ${OSVERSION} < 1400092
+CXX= clang++${LLVM_VERSION}
+USES+= llvm:min=16
+.endif
+
.include <bsd.port.mk>