aboutsummaryrefslogtreecommitdiff
path: root/net-im/libaccounts-qt5
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-07-11 11:38:30 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-07-11 11:38:30 +0000
commit72deea76ea544555493ca8da126514d5d0bf96c6 (patch)
treeb861073a25af8e42fdfa597bcbb47ef0a2365213 /net-im/libaccounts-qt5
parent0d5bcfa2a9242af41718a9f14465fdc3dec7b815 (diff)
downloadports-72deea76ea544555493ca8da126514d5d0bf96c6.tar.gz
ports-72deea76ea544555493ca8da126514d5d0bf96c6.zip
Update accounts-sso ports
- this fixes for example kio-gdrive
Notes
Notes: svn path=/head/; revision=541960
Diffstat (limited to 'net-im/libaccounts-qt5')
-rw-r--r--net-im/libaccounts-qt5/Makefile25
-rw-r--r--net-im/libaccounts-qt5/distinfo5
-rw-r--r--net-im/libaccounts-qt5/files/patch-accounts-qt.pro15
-rw-r--r--net-im/libaccounts-qt5/files/patch-common-project-config.pri11
-rw-r--r--net-im/libaccounts-qt5/pkg-plist232
5 files changed, 146 insertions, 142 deletions
diff --git a/net-im/libaccounts-qt5/Makefile b/net-im/libaccounts-qt5/Makefile
index 1e15dda20aef..37c7e9b4f907 100644
--- a/net-im/libaccounts-qt5/Makefile
+++ b/net-im/libaccounts-qt5/Makefile
@@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= libaccounts-qt5
-PORTVERSION= 1.13
-PORTREVISION= 10
+DISTVERSION= 1.16
+PORTREVISION= 1
CATEGORIES= net-im
-MASTER_SITES= https://drive.google.com/uc?export=download&id=0B8fX9XOwH_g4cTRCaktXNDRmMXM&dummy= \
- LOCAL/rakuco
-DISTNAME= accounts-qt-${PORTVERSION}
+DIST_SUBDIR= KDE/${GL_ACCOUNT}
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt5 wrapper for SSO framework
@@ -16,13 +14,22 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libaccounts-glib.so:net-im/libaccounts-glib
-BUILD_DEPENDS= doxygen:devel/doxygen
-FETCH_BEFORE_ARGS= -o ${DISTFILES}
-
-USES= compiler:c++11-lib qmake pathfix pkgconfig python qt:5 tar:bz2
+USES= compiler:c++17-lang qmake pathfix pkgconfig python qt:5 tar:bz2
USE_QT= buildtools_build core qmake_build testlib xml
+# gitlab variables
+USE_GITLAB= yes
+GL_ACCOUNT= accounts-sso
+GL_PROJECT= libaccounts-qt
+GL_COMMIT= 525ec684cfa8d234f797d7e49e21c476eea04d8e
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+DOCS_QMAKE_ON= CONFIG+=docs
+
pre-configure:
${REINPLACE_CMD} -e 's,$$$${INSTALL_LIBDIR},${LOCALBASE}/libdata,' \
${WRKSRC}/common-pkgconfig.pri
diff --git a/net-im/libaccounts-qt5/distinfo b/net-im/libaccounts-qt5/distinfo
index 87fd911d1e58..98558958bce7 100644
--- a/net-im/libaccounts-qt5/distinfo
+++ b/net-im/libaccounts-qt5/distinfo
@@ -1,2 +1,3 @@
-SHA256 (accounts-qt-1.13.tar.bz2) = 9033891b7f122f578d0ccf22b0e31fc478e644e97f24e7ad8fb54ef0a5da30f0
-SIZE (accounts-qt-1.13.tar.bz2) = 544655
+TIMESTAMP = 1594316326
+SHA256 (KDE/accounts-sso/accounts-sso-libaccounts-qt-525ec684cfa8d234f797d7e49e21c476eea04d8e_GL0.tar.gz) = 3ca41242436f4020a7a4f5222fdf95561c24756a9aebdaa749850f02d40b39c4
+SIZE (KDE/accounts-sso/accounts-sso-libaccounts-qt-525ec684cfa8d234f797d7e49e21c476eea04d8e_GL0.tar.gz) = 64324
diff --git a/net-im/libaccounts-qt5/files/patch-accounts-qt.pro b/net-im/libaccounts-qt5/files/patch-accounts-qt.pro
new file mode 100644
index 000000000000..369c06028e7e
--- /dev/null
+++ b/net-im/libaccounts-qt5/files/patch-accounts-qt.pro
@@ -0,0 +1,15 @@
+--- accounts-qt.pro.orig 2019-09-18 19:00:34 UTC
++++ accounts-qt.pro
+@@ -2,10 +2,10 @@ include( common-vars.pri )
+
+ TEMPLATE = subdirs
+ CONFIG += ordered
+-SUBDIRS += Accounts tests
++SUBDIRS += Accounts
+
+ include( common-project-config.pri )
+-include( doc/doc.pri )
++docs { include( doc/doc.pri ) }
+
+ DISTNAME = $${PROJECT_NAME}-$${PROJECT_VERSION}
+ EXCLUDES = \
diff --git a/net-im/libaccounts-qt5/files/patch-common-project-config.pri b/net-im/libaccounts-qt5/files/patch-common-project-config.pri
new file mode 100644
index 000000000000..7122b58bbe1b
--- /dev/null
+++ b/net-im/libaccounts-qt5/files/patch-common-project-config.pri
@@ -0,0 +1,11 @@
+--- common-project-config.pri.orig 2020-07-09 18:52:52 UTC
++++ common-project-config.pri
+@@ -19,7 +19,7 @@ UI_SOURCES_DIR = ui/src
+ # we don't like warnings...
+ #QMAKE_CXXFLAGS *= -Werror
+
+-CONFIG += c++11
++CONFIG += c++17
+
+ #-----------------------------------------------------------------------------
+ # setup the installation prefix
diff --git a/net-im/libaccounts-qt5/pkg-plist b/net-im/libaccounts-qt5/pkg-plist
index 5543aa7fc5a2..a32bc1a35550 100644
--- a/net-im/libaccounts-qt5/pkg-plist
+++ b/net-im/libaccounts-qt5/pkg-plist
@@ -1,4 +1,3 @@
-bin/accountstest
include/accounts-qt5/Accounts/Account
include/accounts-qt5/Accounts/AccountService
include/accounts-qt5/Accounts/Application
@@ -24,134 +23,105 @@ lib/cmake/AccountsQt5/AccountsQt5Config.cmake
lib/cmake/AccountsQt5/AccountsQt5ConfigVersion.cmake
lib/libaccounts-qt5.so
lib/libaccounts-qt5.so.1
-lib/libaccounts-qt5.so.1.2
-lib/libaccounts-qt5.so.1.2.0
+lib/libaccounts-qt5.so.1.4
+lib/libaccounts-qt5.so.1.4.0
libdata/pkgconfig/accounts-qt5.pc
-share/doc/accounts-qt/html/account-service_8cpp_source.html
-share/doc/accounts-qt/html/account-service_8h_source.html
-share/doc/accounts-qt/html/account_8cpp_source.html
-share/doc/accounts-qt/html/account_8h_source.html
-share/doc/accounts-qt/html/accountscommon_8h_source.html
-share/doc/accounts-qt/html/annotated.html
-share/doc/accounts-qt/html/annotated.js
-share/doc/accounts-qt/html/annotated_dup.js
-share/doc/accounts-qt/html/application_8cpp_source.html
-share/doc/accounts-qt/html/application_8h_source.html
-share/doc/accounts-qt/html/auth-data_8cpp_source.html
-share/doc/accounts-qt/html/auth-data_8h_source.html
-share/doc/accounts-qt/html/bc_s.png
-share/doc/accounts-qt/html/bdwn.png
-share/doc/accounts-qt/html/classAccounts_1_1Account-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Account.html
-share/doc/accounts-qt/html/classAccounts_1_1Account.js
-share/doc/accounts-qt/html/classAccounts_1_1AccountService-members.html
-share/doc/accounts-qt/html/classAccounts_1_1AccountService.html
-share/doc/accounts-qt/html/classAccounts_1_1AccountService.js
-share/doc/accounts-qt/html/classAccounts_1_1Application-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Application.html
-share/doc/accounts-qt/html/classAccounts_1_1Application.js
-share/doc/accounts-qt/html/classAccounts_1_1AuthData-members.html
-share/doc/accounts-qt/html/classAccounts_1_1AuthData.html
-share/doc/accounts-qt/html/classAccounts_1_1AuthData.js
-share/doc/accounts-qt/html/classAccounts_1_1Error-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Error.html
-share/doc/accounts-qt/html/classAccounts_1_1Error.js
-share/doc/accounts-qt/html/classAccounts_1_1Manager-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Manager.html
-share/doc/accounts-qt/html/classAccounts_1_1Manager.js
-share/doc/accounts-qt/html/classAccounts_1_1Provider-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Provider.html
-share/doc/accounts-qt/html/classAccounts_1_1Provider.js
-share/doc/accounts-qt/html/classAccounts_1_1Service-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Service.html
-share/doc/accounts-qt/html/classAccounts_1_1Service.js
-share/doc/accounts-qt/html/classAccounts_1_1ServiceType-members.html
-share/doc/accounts-qt/html/classAccounts_1_1ServiceType.html
-share/doc/accounts-qt/html/classAccounts_1_1ServiceType.js
-share/doc/accounts-qt/html/classAccounts_1_1Watch-members.html
-share/doc/accounts-qt/html/classAccounts_1_1Watch.html
-share/doc/accounts-qt/html/classAccounts_1_1Watch.js
-share/doc/accounts-qt/html/classes.html
-share/doc/accounts-qt/html/closed.png
-share/doc/accounts-qt/html/deprecated.html
-share/doc/accounts-qt/html/dir_61c9e5842729cb34568d93cb98ad85b9.html
-share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c.html
-share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c.js
-share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c_dep.map
-share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c_dep.md5
-share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c_dep.png
-share/doc/accounts-qt/html/dir_e68e8157741866f444e17edd764ebbae.html
-share/doc/accounts-qt/html/doc.png
-share/doc/accounts-qt/html/doxygen.css
-share/doc/accounts-qt/html/doxygen.png
-share/doc/accounts-qt/html/dynsections.js
-share/doc/accounts-qt/html/error_8cpp_source.html
-share/doc/accounts-qt/html/error_8h_source.html
-share/doc/accounts-qt/html/files.html
-share/doc/accounts-qt/html/files.js
-share/doc/accounts-qt/html/files_dup.js
-share/doc/accounts-qt/html/folderclosed.png
-share/doc/accounts-qt/html/folderopen.png
-share/doc/accounts-qt/html/ftv2blank.png
-share/doc/accounts-qt/html/ftv2cl.png
-share/doc/accounts-qt/html/ftv2doc.png
-share/doc/accounts-qt/html/ftv2folderclosed.png
-share/doc/accounts-qt/html/ftv2folderopen.png
-share/doc/accounts-qt/html/ftv2lastnode.png
-share/doc/accounts-qt/html/ftv2link.png
-share/doc/accounts-qt/html/ftv2mlastnode.png
-share/doc/accounts-qt/html/ftv2mnode.png
-share/doc/accounts-qt/html/ftv2mo.png
-share/doc/accounts-qt/html/ftv2node.png
-share/doc/accounts-qt/html/ftv2ns.png
-share/doc/accounts-qt/html/ftv2plastnode.png
-share/doc/accounts-qt/html/ftv2pnode.png
-share/doc/accounts-qt/html/ftv2splitbar.png
-share/doc/accounts-qt/html/ftv2vertline.png
-share/doc/accounts-qt/html/functions.html
-share/doc/accounts-qt/html/functions_enum.html
-share/doc/accounts-qt/html/functions_eval.html
-share/doc/accounts-qt/html/functions_func.html
-share/doc/accounts-qt/html/graph_legend.html
-share/doc/accounts-qt/html/graph_legend.md5
-share/doc/accounts-qt/html/graph_legend.png
-share/doc/accounts-qt/html/index.html
-share/doc/accounts-qt/html/index.qhp
-share/doc/accounts-qt/html/jquery.js
-share/doc/accounts-qt/html/manager_8cpp_source.html
-share/doc/accounts-qt/html/manager_8h_source.html
-share/doc/accounts-qt/html/manager__p_8h_source.html
-share/doc/accounts-qt/html/menu.js
-share/doc/accounts-qt/html/menudata.js
-share/doc/accounts-qt/html/nav_f.png
-share/doc/accounts-qt/html/nav_g.png
-share/doc/accounts-qt/html/nav_h.png
-share/doc/accounts-qt/html/navtree.css
-share/doc/accounts-qt/html/navtree.js
-share/doc/accounts-qt/html/navtreedata.js
-share/doc/accounts-qt/html/navtreeindex0.js
-share/doc/accounts-qt/html/open.png
-share/doc/accounts-qt/html/pages.html
-share/doc/accounts-qt/html/provider_8cpp_source.html
-share/doc/accounts-qt/html/provider_8h_source.html
-share/doc/accounts-qt/html/resize.js
-share/doc/accounts-qt/html/service-type_8cpp_source.html
-share/doc/accounts-qt/html/service-type_8h_source.html
-share/doc/accounts-qt/html/service_8cpp_source.html
-share/doc/accounts-qt/html/service_8h_source.html
-share/doc/accounts-qt/html/splitbar.png
-share/doc/accounts-qt/html/sync_off.png
-share/doc/accounts-qt/html/sync_on.png
-share/doc/accounts-qt/html/tab_a.png
-share/doc/accounts-qt/html/tab_b.png
-share/doc/accounts-qt/html/tab_h.png
-share/doc/accounts-qt/html/tab_s.png
-share/doc/accounts-qt/html/tabs.css
-share/doc/accounts-qt/html/utils_8cpp_source.html
-share/doc/accounts-qt/html/utils_8h_source.html
-share/doc/accounts-qt/qch/accounts.qch
-share/libaccounts-qt-tests/MyProvider.provider
-share/libaccounts-qt-tests/MyService.service
-share/libaccounts-qt-tests/OtherService.service
-share/libaccounts-qt-tests/e-mail.service-type
-share/libaccounts-qt-tests/tests.xml
+%%DOCS%%share/doc/accounts-qt/html/account-service_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/account-service_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/account_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/account_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/accountscommon_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/annotated.html
+%%DOCS%%share/doc/accounts-qt/html/annotated_dup.js
+%%DOCS%%share/doc/accounts-qt/html/application_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/application_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/auth-data_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/auth-data_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/bc_s.png
+%%DOCS%%share/doc/accounts-qt/html/bdwn.png
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1AccountService-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1AccountService.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1AccountService.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Application-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Application.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Application.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1AuthData-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1AuthData.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1AuthData.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Error-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Error.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Error.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Manager-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Manager.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Manager.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Provider-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Provider.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Provider.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Service-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Service.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Service.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1ServiceType-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1ServiceType.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1ServiceType.js
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Watch-members.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Watch.html
+%%DOCS%%share/doc/accounts-qt/html/classAccounts_1_1Watch.js
+%%DOCS%%share/doc/accounts-qt/html/classes.html
+%%DOCS%%share/doc/accounts-qt/html/closed.png
+%%DOCS%%share/doc/accounts-qt/html/deprecated.html
+%%DOCS%%share/doc/accounts-qt/html/dir_61c9e5842729cb34568d93cb98ad85b9.html
+%%DOCS%%share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c.html
+%%DOCS%%share/doc/accounts-qt/html/dir_c3d1d086c816c0518443c9e800634b9c.js
+%%DOCS%%share/doc/accounts-qt/html/dir_e68e8157741866f444e17edd764ebbae.html
+%%DOCS%%share/doc/accounts-qt/html/doc.png
+%%DOCS%%share/doc/accounts-qt/html/doxygen.css
+%%DOCS%%share/doc/accounts-qt/html/doxygen.png
+%%DOCS%%share/doc/accounts-qt/html/dynsections.js
+%%DOCS%%share/doc/accounts-qt/html/error_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/error_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/files.html
+%%DOCS%%share/doc/accounts-qt/html/files_dup.js
+%%DOCS%%share/doc/accounts-qt/html/folderclosed.png
+%%DOCS%%share/doc/accounts-qt/html/folderopen.png
+%%DOCS%%share/doc/accounts-qt/html/functions.html
+%%DOCS%%share/doc/accounts-qt/html/functions_enum.html
+%%DOCS%%share/doc/accounts-qt/html/functions_eval.html
+%%DOCS%%share/doc/accounts-qt/html/functions_func.html
+%%DOCS%%share/doc/accounts-qt/html/graph_legend.html
+%%DOCS%%share/doc/accounts-qt/html/graph_legend.md5
+%%DOCS%%share/doc/accounts-qt/html/graph_legend.png
+%%DOCS%%share/doc/accounts-qt/html/index.html
+%%DOCS%%share/doc/accounts-qt/html/index.qhp
+%%DOCS%%share/doc/accounts-qt/html/jquery.js
+%%DOCS%%share/doc/accounts-qt/html/manager_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/manager_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/manager__p_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/menu.js
+%%DOCS%%share/doc/accounts-qt/html/menudata.js
+%%DOCS%%share/doc/accounts-qt/html/nav_f.png
+%%DOCS%%share/doc/accounts-qt/html/nav_g.png
+%%DOCS%%share/doc/accounts-qt/html/nav_h.png
+%%DOCS%%share/doc/accounts-qt/html/navtree.css
+%%DOCS%%share/doc/accounts-qt/html/navtree.js
+%%DOCS%%share/doc/accounts-qt/html/navtreedata.js
+%%DOCS%%share/doc/accounts-qt/html/navtreeindex0.js
+%%DOCS%%share/doc/accounts-qt/html/open.png
+%%DOCS%%share/doc/accounts-qt/html/pages.html
+%%DOCS%%share/doc/accounts-qt/html/provider_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/provider_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/resize.js
+%%DOCS%%share/doc/accounts-qt/html/service-type_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/service-type_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/service_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/service_8h_source.html
+%%DOCS%%share/doc/accounts-qt/html/splitbar.png
+%%DOCS%%share/doc/accounts-qt/html/sync_off.png
+%%DOCS%%share/doc/accounts-qt/html/sync_on.png
+%%DOCS%%share/doc/accounts-qt/html/tab_a.png
+%%DOCS%%share/doc/accounts-qt/html/tab_b.png
+%%DOCS%%share/doc/accounts-qt/html/tab_h.png
+%%DOCS%%share/doc/accounts-qt/html/tab_s.png
+%%DOCS%%share/doc/accounts-qt/html/tabs.css
+%%DOCS%%share/doc/accounts-qt/html/utils_8cpp_source.html
+%%DOCS%%share/doc/accounts-qt/html/utils_8h_source.html
+%%DOCS%%@dir share/doc/accounts-qt/qch