aboutsummaryrefslogtreecommitdiff
path: root/net-im/libnice
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/libnice
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/libnice')
-rw-r--r--net-im/libnice/Makefile23
-rw-r--r--net-im/libnice/distinfo4
-rw-r--r--net-im/libnice/files/patch-agent_interfaces.c19
-rw-r--r--net-im/libnice/files/patch-stun_md5.c10
-rw-r--r--net-im/libnice/files/patch-stun_sha1.c10
-rw-r--r--net-im/libnice/pkg-plist9
6 files changed, 12 insertions, 63 deletions
diff --git a/net-im/libnice/Makefile b/net-im/libnice/Makefile
index 8be2a43aaa4e..d0ec8679480f 100644
--- a/net-im/libnice/Makefile
+++ b/net-im/libnice/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: libnice
-# Date created: 27 February 2009
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
+# $MCom$
PORTNAME= libnice
-PORTVERSION= 0.0.13
-PORTREVISION= 3
+PORTVERSION= 0.1.3
CATEGORIES= net-im devel
MASTER_SITES= http://nice.freedesktop.org/releases/
@@ -17,25 +13,18 @@ COMMENT= Library and transmitter that implements ICE-19
USE_GMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack pkgconfig glib20 ltverhack
+USE_GNOME= gnomehack glib20 ltverhack
+USE_PKGCONFIG= build
USE_GSTREAMER= yes
USE_AUTOTOOLS= libtool
+CONFIGURE_ARGS= --without-gstreamer --with-gstreamer-0.10
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_GETIFADDRS
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
- @${REINPLACE_CMD} -e 's|__BYTE_ORDER|_BYTE_ORDER|g ; \
- s|__BIG_ENDIAN|_BIG_ENDIAN|g' \
- ${WRKSRC}/stun/md5.c \
- ${WRKSRC}/stun/sha1.c
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|-Wno-missing-field-initializers|#|g'
@${REINPLACE_CMD} -e 's|-Wno-missing-field-initializers|#|g' \
${WRKSRC}/common.mk
-post-configure:
- @${TOUCH} -f ${WRKSRC}/config.h ${WRKSRC}/aclocal.m4 \
- ${WRKSRC}/configure ${WRKSRC}/Makefile.in \
- ${WRKSRC}/Makefile
-
.include <bsd.port.mk>
diff --git a/net-im/libnice/distinfo b/net-im/libnice/distinfo
index 7bedd8d7b330..fbc6a2d7b975 100644
--- a/net-im/libnice/distinfo
+++ b/net-im/libnice/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libnice-0.0.13.tar.gz) = d8dd260c486a470a6052a5323920878a084e44a19df09b15728b85c9e3d6edf0
-SIZE (libnice-0.0.13.tar.gz) = 635783
+SHA256 (libnice-0.1.3.tar.gz) = 046ce11f66638b54f2e042e7b1fbcc537ec99c27185fb006edbfd80d7f990074
+SIZE (libnice-0.1.3.tar.gz) = 672174
diff --git a/net-im/libnice/files/patch-agent_interfaces.c b/net-im/libnice/files/patch-agent_interfaces.c
deleted file mode 100644
index d3d33d3a376f..000000000000
--- a/net-im/libnice/files/patch-agent_interfaces.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- agent/interfaces.c.orig 2010-07-20 17:54:40.000000000 -0400
-+++ agent/interfaces.c 2010-07-24 20:24:19.000000000 -0400
-@@ -46,6 +46,7 @@
- #include <ifaddrs.h>
- #endif
-
-+#include <netinet/in.h>
- #include <net/if.h>
- #include <net/if_arp.h>
- #include <arpa/inet.h>
-@@ -198,7 +199,7 @@ nice_interfaces_get_local_ips (gboolean
- struct sockaddr_in6 *sa6 = (struct sockaddr_in6 *)ifa->ifa_addr;
-
- /* Skip link-local addresses, they require a scope */
-- if (IN6_IS_ADDR_LINKLOCAL (sa6->sin6_addr.s6_addr))
-+ if (IN6_IS_ADDR_LINKLOCAL (&sa6->sin6_addr))
- continue;
-
- if (inet_ntop (AF_INET6, &sa6->sin6_addr, addr_as_string,
diff --git a/net-im/libnice/files/patch-stun_md5.c b/net-im/libnice/files/patch-stun_md5.c
deleted file mode 100644
index 8f787548f7ea..000000000000
--- a/net-im/libnice/files/patch-stun_md5.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- stun/md5.c.orig 2009-02-27 23:04:31.000000000 -0500
-+++ stun/md5.c 2009-02-27 23:05:15.000000000 -0500
-@@ -13,6 +13,7 @@
- */
-
- #include "md5.h"
-+#include <sys/endian.h>
- #include <string.h>
-
- /* ===== start - public domain MD5 implementation ===== */
diff --git a/net-im/libnice/files/patch-stun_sha1.c b/net-im/libnice/files/patch-stun_sha1.c
deleted file mode 100644
index 33e3775b2981..000000000000
--- a/net-im/libnice/files/patch-stun_sha1.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- stun/sha1.c.orig 2009-02-27 23:05:24.000000000 -0500
-+++ stun/sha1.c 2009-02-27 23:05:33.000000000 -0500
-@@ -13,6 +13,7 @@
- */
-
- #include "sha1.h"
-+#include <sys/endian.h>
- #include <string.h>
-
-
diff --git a/net-im/libnice/pkg-plist b/net-im/libnice/pkg-plist
index ea510f2bacf7..fd0cae2d3277 100644
--- a/net-im/libnice/pkg-plist
+++ b/net-im/libnice/pkg-plist
@@ -16,13 +16,13 @@ include/stun/usages/ice.h
include/stun/usages/timer.h
include/stun/usages/turn.h
include/stun/win32_common.h
-lib/gstreamer-0.10/libgstnice.a
-lib/gstreamer-0.10/libgstnice.la
-lib/gstreamer-0.10/libgstnice.so
+lib/gstreamer-0.10/libgstnice010.a
+lib/gstreamer-0.10/libgstnice010.la
+lib/gstreamer-0.10/libgstnice010.so
lib/libnice.a
lib/libnice.la
lib/libnice.so
-lib/libnice.so.0
+lib/libnice.so.10
libdata/pkgconfig/nice.pc
share/gtk-doc/html/libnice/NiceAgent.html
share/gtk-doc/html/libnice/ch01.html
@@ -45,7 +45,6 @@ share/gtk-doc/html/libnice/libnice-StunAgent.html
share/gtk-doc/html/libnice/libnice-StunMessage.html
share/gtk-doc/html/libnice/libnice-TURN.html
share/gtk-doc/html/libnice/libnice-Timer.html
-share/gtk-doc/html/libnice/libnice.devhelp
share/gtk-doc/html/libnice/libnice.devhelp2
share/gtk-doc/html/libnice/pt01.html
share/gtk-doc/html/libnice/pt02.html