aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq-qt-gui
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-02-18 08:00:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-02-18 08:00:14 +0000
commit39f234b762ed510a159bd20f3e208c9dbd54ce8a (patch)
tree5de3e9aa1630e72dd74ca3ad2583f00aa17b37a3 /net-im/licq-qt-gui
parentfd59e8bd1bed585bbb68844f8bfcdd8ca165076c (diff)
downloadports-39f234b762ed510a159bd20f3e208c9dbd54ce8a.tar.gz
ports-39f234b762ed510a159bd20f3e208c9dbd54ce8a.zip
- make portlint happier
- add dependecies
Notes
Notes: svn path=/head/; revision=434331
Diffstat (limited to 'net-im/licq-qt-gui')
-rw-r--r--net-im/licq-qt-gui/Makefile4
-rw-r--r--net-im/licq-qt-gui/files/patch-contactuserdata.h4
-rw-r--r--net-im/licq-qt-gui/files/patch-plugin.cpp4
-rw-r--r--net-im/licq-qt-gui/files/patch-usereventcommon.h4
4 files changed, 8 insertions, 8 deletions
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index d6bde30efcc9..0a27ee0a20a2 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -15,10 +15,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/lib/licq/protocol_icq.so:${LICQ_PORT}-icq
-USE_XORG= x11 xext ice xscrnsaver
+USE_XORG= x11 xext ice xscrnsaver sm
USES= cmake
USE_QT4= qmake_build moc_build rcc_build uic_build linguisttools_build \
- corelib xml gui
+ corelib xml gui network dbus svg
OPTIONS_DEFINE= HUNSPELL KDE4
OPTIONS_DEFAULT=HUNSPELL
diff --git a/net-im/licq-qt-gui/files/patch-contactuserdata.h b/net-im/licq-qt-gui/files/patch-contactuserdata.h
index 9cf5faba7616..fd4c2238309a 100644
--- a/net-im/licq-qt-gui/files/patch-contactuserdata.h
+++ b/net-im/licq-qt-gui/files/patch-contactuserdata.h
@@ -1,5 +1,5 @@
---- src/contactlist/contactuserdata.h.orig 2013-08-25 11:45:17.000000000 +0200
-+++ src/contactlist/contactuserdata.h 2014-02-13 21:44:51.000000000 +0100
+--- src/contactlist/contactuserdata.h.orig 2014-06-01 19:16:42 UTC
++++ src/contactlist/contactuserdata.h
@@ -20,6 +20,8 @@
#ifndef CONTACTUSERDATA_H
#define CONTACTUSERDATA_H
diff --git a/net-im/licq-qt-gui/files/patch-plugin.cpp b/net-im/licq-qt-gui/files/patch-plugin.cpp
index df1a020d83f3..60396e4990fd 100644
--- a/net-im/licq-qt-gui/files/patch-plugin.cpp
+++ b/net-im/licq-qt-gui/files/patch-plugin.cpp
@@ -1,5 +1,5 @@
---- src/core/plugin.cpp.orig 2014-06-01 21:16:42.000000000 +0200
-+++ src/core/plugin.cpp 2014-06-06 22:08:35.000000000 +0200
+--- src/core/plugin.cpp.orig 2014-06-01 19:16:42 UTC
++++ src/core/plugin.cpp
@@ -31,6 +31,7 @@
# include <QInternal>
#include <KDE/KCmdLineArgs>
diff --git a/net-im/licq-qt-gui/files/patch-usereventcommon.h b/net-im/licq-qt-gui/files/patch-usereventcommon.h
index 469fa802084d..524a8d7ac972 100644
--- a/net-im/licq-qt-gui/files/patch-usereventcommon.h
+++ b/net-im/licq-qt-gui/files/patch-usereventcommon.h
@@ -1,5 +1,5 @@
---- src/userevents/usereventcommon.h.orig 2013-08-25 11:45:17.000000000 +0200
-+++ src/userevents/usereventcommon.h 2014-02-13 21:45:16.000000000 +0100
+--- src/userevents/usereventcommon.h.orig 2014-06-01 19:16:42 UTC
++++ src/userevents/usereventcommon.h
@@ -20,6 +20,8 @@
#ifndef USEREVENTCOMMON_H
#define USEREVENTCOMMON_H