aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq-qt-gui
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-03-29 07:54:18 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-03-29 07:54:18 +0000
commit6b0c9caa74dce42017eb23de5b99e5217de9579e (patch)
tree1df9571a9f7b217c3a177c6f26d174139d5b33ad /net-im/licq-qt-gui
parentf63f4af345a2f132cb81ca3ec4754278c35c83c2 (diff)
downloadports-6b0c9caa74dce42017eb23de5b99e5217de9579e.tar.gz
ports-6b0c9caa74dce42017eb23de5b99e5217de9579e.zip
Notes
Diffstat (limited to 'net-im/licq-qt-gui')
-rw-r--r--net-im/licq-qt-gui/Makefile1
-rw-r--r--net-im/licq-qt-gui/files/patch-usereventdlg.cpp22
2 files changed, 23 insertions, 0 deletions
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index dfbd14bb72d1..98ebc416d677 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qt-gui
PORTVERSION= ${QT_LICQ_VER}
+PORTREVISION= 1
CATEGORIES= net
.if defined(WITH_KDE)
PKGNAMESUFFIX= -kde
diff --git a/net-im/licq-qt-gui/files/patch-usereventdlg.cpp b/net-im/licq-qt-gui/files/patch-usereventdlg.cpp
new file mode 100644
index 000000000000..06d168aa28a4
--- /dev/null
+++ b/net-im/licq-qt-gui/files/patch-usereventdlg.cpp
@@ -0,0 +1,22 @@
+--- src/usereventdlg.cpp.orig Sun Mar 23 18:49:39 2003
++++ src/usereventdlg.cpp Sat Mar 29 08:31:33 2003
+@@ -1390,7 +1390,7 @@
+ {
+ CEventMsg *ue = (CEventMsg *)e->UserEvent();
+ // create initial strings (implicit copying, no allocation impact :)
+- char *tmp = gTranslator.NToRN(codec->fromUnicode(ue->Message()));
++ char *tmp = gTranslator.NToRN(ue->Message());
+ QCString wholeMessageRaw(tmp);
+ delete [] tmp;
+ unsigned int wholeMessagePos = 0;
+@@ -1439,8 +1439,8 @@
+ }
+ else
+ {
+- message = ue->Message();
+- messageRaw = codec->fromUnicode(message);
++ messageRaw = wholeMessageRaw;
++ message = codec->toUnicode(wholeMessageRaw);
+ }
+
+ icqEventTag = server->icqSendMessage(m_nUin, messageRaw.data(),