aboutsummaryrefslogtreecommitdiff
path: root/net-im/licq
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2001-04-10 20:09:53 +0000
committerBrian Feldman <green@FreeBSD.org>2001-04-10 20:09:53 +0000
commit11d86ccd31a76d611a3c66d2ebf87ee38e4e33bf (patch)
tree3e97cdc030d89288de02d03ad7bd120da81fb02c /net-im/licq
parent1b592585f2098f44e1525e779f76bef8d268e6a5 (diff)
downloadports-11d86ccd31a76d611a3c66d2ebf87ee38e4e33bf.tar.gz
ports-11d86ccd31a76d611a3c66d2ebf87ee38e4e33bf.zip
Convert the monolithic Licq port into an licq-base port and satellite
ports for different plugins. Commit the first of the plugins, qt-gui, as that has in the past been part of the normal licq port. The rest are coming after I've tried them out. I'd like to thank Jeremy Norris greatly for doing this work :) Submitted by: Jeremy Norris <ishmael27@home.com>
Notes
Notes: svn path=/head/; revision=41226
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/Makefile65
-rw-r--r--net-im/licq/files/patch-aa11
-rw-r--r--net-im/licq/files/patch-ab31
-rw-r--r--net-im/licq/files/patch-ac11
-rw-r--r--net-im/licq/files/patch-ad48
-rw-r--r--net-im/licq/pkg-comment2
-rw-r--r--net-im/licq/pkg-descr4
-rw-r--r--net-im/licq/pkg-plist310
8 files changed, 74 insertions, 408 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 5fc3130f8b56..33173d5ff041 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -5,64 +5,31 @@
# $FreeBSD$
#
-PORTNAME= licq
-PORTVERSION= 1.0.3
+PORTNAME= base
+PORTVERSION= ${LICQ_VER}
CATEGORIES= net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- ftp://ftp.wibble.net/pub/licq/srcs/ \
- ftp://licq.darkorb.net/srcs/ \
- ftp://ftp.fanfic.org/pub/licq/srcs/ \
- ftp://ftp.inter-i.uni-mainz.de/pub/licq/srcs/
-MASTER_SITE_SUBDIR= ${PORTNAME}
+.if defined(WITH_SOCKS)
+PKGNAMESUFFIX= -socks
+.endif
MAINTAINER= green@FreeBSD.org
-BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake
+.if defined(WITH_SOCKS)
+BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+.endif
-USE_QT_VER= 2
-USE_GMAKE= yes
-USE_AUTOCONF= yes
USE_OPENSSL= yes
-USE_PERL5= yes
-
-CONFIGURE_TARGET= $(ARCH)-unknown-freebsdelf$(OSREL)
+WRKSRC= ${WRKDIR}/${DISTNAME}
+.if defined(WITH_SOCKS)
+CONFIGURE_ARGS+=--enable-socks5
+.endif
post-patch:
- @${PERL} -pi.orig -e 's:<wait\.h>:<sys/wait.h>:g' \
- ${WRKSRC}/src/sighandler.c
-
-post-configure:
- @(cd ${WRKSRC}/plugins/qt-gui-${PORTVERSION} && ${AUTOCONF})
- @(cd ${WRKSRC}/plugins/qt-gui-${PORTVERSION} && \
- if ! ${SETENV} CC="${CC}" CXX="${CXX}" \
- CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
- INSTALL="/usr/bin/install -c -o ${BINOWN} -g ${BINGRP}" \
- INSTALL_DATA="${INSTALL_DATA}" \
- INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
- INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
- QTBASE="${X11BASE}" \
- ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS} \
- --enable-spoofing; then \
- ${ECHO} "===> Script \"${CONFIGURE_SCRIPT}\" failed: here are the contents of \"${CONFIGURE_LOG}\""; \
- ${CAT} ${CONFIGURE_LOG}; \
- ${ECHO} "(end of \"${CONFIGURE_LOG}\")"; \
- ${FALSE}; \
- fi)
-
-post-build:
- @(cd ${WRKSRC}/plugins/qt-gui-${PORTVERSION}; \
- ${SETENV} ${MAKE_ENV} \
- ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
-
-pre-install:
- ${RM} -rf ${PREFIX}/share/licq
- ${MKDIR} -m 700 ${PREFIX}/share/licq
+ @${PERL5} -pi -e 's|<wait.h>|<sys/wait.h>|g' \
+ ${WRKSRC}/src/sighandler.c
post-install:
- cd ${WRKSRC}/plugins/qt-gui-${PORTVERSION}; \
- ${SETENV} ${MAKE_ENV} \
- ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
- ${CHMOD} -R a-w ${PREFIX}/share/licq
- ${CHMOD} 755 ${PREFIX}/share/licq
+ @${CAT} ${PKGMESSAGE}
+.include "${.CURDIR}/Makefile.inc"
.include <bsd.port.mk>
diff --git a/net-im/licq/files/patch-aa b/net-im/licq/files/patch-aa
deleted file mode 100644
index ebda08f5a29f..000000000000
--- a/net-im/licq/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qt-gui-1.0.3/configure.in.orig Wed Aug 9 14:07:59 2000
-+++ plugins/qt-gui-1.0.3/configure.in Wed Aug 9 14:15:46 2000
-@@ -51,8 +51,6 @@
- LICQ_CHECK_X11HEADERS
-
- XSS_LIBS="no"
--AC_CHECK_X_LIB(Xext, XScreenSaverRegister,[XSS_LIBS=""],[], [-lX11 -lXext -lm])
--AC_CHECK_X_LIB(Xss, XScreenSaverRegister,[XSS_LIBS="-lXss"],[],[-lX11 -lXext -lm])
- if test \! "$XSS_LIBS" = "no"; then
- AC_CHECK_X_HEADER(X11/extensions/scrnsaver.h,[AC_DEFINE(USE_SCRNSAVER)])
- else
diff --git a/net-im/licq/files/patch-ab b/net-im/licq/files/patch-ab
deleted file mode 100644
index f3a6d5b88496..000000000000
--- a/net-im/licq/files/patch-ab
+++ /dev/null
@@ -1,31 +0,0 @@
---- plugins/qt-gui-1.0.3/acinclude.m4.in.orig Sun Jun 18 06:20:57 2000
-+++ plugins/qt-gui-1.0.3/acinclude.m4.in Mon Jul 24 03:09:28 2000
-@@ -48,7 +48,7 @@
- fi
-
- for qt_dir in $qt_library_dirs; do
-- for qt_check_lib in $qt_dir/libqt.so.2; do
-+ for qt_check_lib in $qt_dir/libqt2.so.3; do
- if test -r $qt_check_lib; then
- ac_qt_libraries=$qt_dir
- break 2
-@@ -68,7 +68,7 @@
- else
- have_qt_lib="yes"
- dnl Check if we have the right lib
-- output=`eval "strings $ac_cv_lib_qtlib/libqt.so | grep -l QCString"`
-+ output=`eval "strings $ac_cv_lib_qtlib/libqt2.so | grep -l QCString"`
- if test -z "$output"; then
- AC_MSG_ERROR([
- The Qt lib directory "$ac_cv_lib_qtlib"
-@@ -185,8 +185,8 @@
-
- AC_PATH_PROG(
- MOC,
-- moc,
-- $QTDIR/bin/moc,
-+ moc2,
-+ $QTDIR/bin/moc2,
- $QTDIR/bin:/usr/lib/qt2/bin:/usr/bin:/usr/X11R6/bin:/usr/lib/qt/bin:/usr/local/qt/bin:$PATH
- )
- else
diff --git a/net-im/licq/files/patch-ac b/net-im/licq/files/patch-ac
deleted file mode 100644
index 908462c6faf7..000000000000
--- a/net-im/licq/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugins/qt-gui-1.0.3/src/Makefile.in.orig Tue Jul 11 18:54:27 2000
-+++ plugins/qt-gui-1.0.3/src/Makefile.in Mon Jul 24 03:12:25 2000
-@@ -119,7 +119,7 @@
-
- licq_qt_gui_la_LDFLAGS = $(X_LIBS) $(QT_LDFLAGS) $(KDE_LDFLAGS) -module -avoid-version -rpath $(libdir) -R$(QT_LIBDIR)
-
--licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS)
-+licq_qt_gui_la_LIBADD = $(KDE_LIBS) -lqt2 $(X_PRE_LIBS) -lX11 -lXext $(XSS_LIBS) $(X_EXTRA_LIBS)
-
-
- #>- METASOURCES = AUTO
diff --git a/net-im/licq/files/patch-ad b/net-im/licq/files/patch-ad
deleted file mode 100644
index 7bf734c85ce6..000000000000
--- a/net-im/licq/files/patch-ad
+++ /dev/null
@@ -1,48 +0,0 @@
---- src/socket.cpp.orig Tue Jul 4 20:51:50 2000
-+++ src/socket.cpp Mon Jul 24 03:32:56 2000
-@@ -12,6 +12,7 @@
- #include <netdb.h>
- #include <fcntl.h>
- #include <unistd.h>
-+#include <osreldate.h>
-
- #ifndef MSG_DONTWAIT
- #define MSG_DONTWAIT 0
-@@ -288,7 +289,12 @@
- bool INetSocket::SetLocalAddress(bool bIp)
- {
- // Setup the local structure
-+
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- if (getsockname(m_nDescriptor, (struct sockaddr *)&m_sLocalAddr, &sizeofSockaddr) < 0)
- {
- m_nErrorType = SOCK_ERROR_errno;
-@@ -372,7 +378,11 @@
- m_sRemoteAddr.sin_family = AF_INET;
-
- // if connect fails then call CloseConnection to clean up before returning
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr);
-+#else
- socklen_t sizeofSockaddr = sizeof(struct sockaddr);
-+#endif
- if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
- {
- // errno has been set
-@@ -504,7 +514,11 @@
- *---------------------------------------------------------------------------*/
- void TCPSocket::RecvConnection(TCPSocket &newSocket)
- {
-- socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#if __FreeBSD_version < 400013
-+ int sizeofSockaddr = sizeof(struct sockaddr_in);
-+#else
-+ socklen_t sizeofSockaddr = sizeof(struct sockaddr_in);
-+#endif
- newSocket.m_nDescriptor = accept(m_nDescriptor, (struct sockaddr *)&newSocket.m_sRemoteAddr, &sizeofSockaddr);
- newSocket.SetLocalAddress();
- }
diff --git a/net-im/licq/pkg-comment b/net-im/licq/pkg-comment
index 9d3275098511..772acc2f8c54 100644
--- a/net-im/licq/pkg-comment
+++ b/net-im/licq/pkg-comment
@@ -1 +1 @@
-X11 and QT-based ICQ-compatible program
+A popular ICQ-compatible plugin-based program
diff --git a/net-im/licq/pkg-descr b/net-im/licq/pkg-descr
index ae3421e48382..d0fcb6465b59 100644
--- a/net-im/licq/pkg-descr
+++ b/net-im/licq/pkg-descr
@@ -1,3 +1,5 @@
-This is an unofficial ICQ clone, written in C++ for X11 and the QT interface.
+This is an unofficial ICQ clone, written in C++.
It is in no way endorsed by Mirabilis, and now is the most full-featured
ICQ-compatible program with the exception of Java ICQ.
+
+WWW: http://www.licq.org/
diff --git a/net-im/licq/pkg-plist b/net-im/licq/pkg-plist
index b4246d124e53..ae5ddc74ce01 100644
--- a/net-im/licq/pkg-plist
+++ b/net-im/licq/pkg-plist
@@ -4,53 +4,48 @@ bin/viewurl-ncftp.sh
bin/viewurl-netscape.sh
bin/viewurl-w3m.sh
include/licq/licq_buffer.h
-include/licq/licq_icq.h
-include/licq/licq_remoteserver.h
include/licq/licq_chat.h
-include/licq/licq_icqd.h
-include/licq/licq_sar.h
+include/licq/licq_color.h
include/licq/licq_constants.h
-include/licq/licq_languagecodes.h
-include/licq/licq_sighandler.h
include/licq/licq_countrycodes.h
-include/licq/licq_log.h
-include/licq/licq_socket.h
include/licq/licq_events.h
-include/licq/licq_message.h
-include/licq/licq_translate.h
include/licq/licq_file.h
-include/licq/licq_onevent.h
-include/licq/licq_user.h
include/licq/licq_filetransfer.h
-include/licq/licq_packets.h
-include/licq/licq_utility.h
include/licq/licq_history.h
+include/licq/licq_icq.h
+include/licq/licq_icqd.h
+include/licq/licq_languagecodes.h
+include/licq/licq_log.h
+include/licq/licq_message.h
+include/licq/licq_onevent.h
+include/licq/licq_packets.h
include/licq/licq_plugin.h
-include/licq/pthread_rdwr.h
include/licq/licq_plugind.h
-include/licq/licq_color.h
-@dirrm include/licq
-lib/licq/licq_qt-gui.so
-lib/licq/licq_qt-gui.la
-@dirrm lib/licq
-share/licq/utilities/BackOrifice.utility
-share/licq/utilities/finger.utility
-share/licq/utilities/ftp.utility
-share/licq/utilities/gftp.utility
-share/licq/utilities/hostname.utility
-share/licq/utilities/kmail.utility
-share/licq/utilities/mutt.utility
-share/licq/utilities/netscape.utility
-share/licq/utilities/nmap.utility
-share/licq/utilities/pine.utility
-share/licq/utilities/ping.utility
-share/licq/utilities/queso.utility
-share/licq/utilities/speakfreely.utility
-share/licq/utilities/talk.utility
-share/licq/utilities/traceroute.utility
-share/licq/utilities/vnc.utility
-share/licq/utilities/xtraceroute.utility
-@dirrm share/licq/utilities
+include/licq/licq_remoteserver.h
+include/licq/licq_sar.h
+include/licq/licq_sighandler.h
+include/licq/licq_socket.h
+include/licq/licq_translate.h
+include/licq/licq_user.h
+include/licq/licq_utility.h
+include/licq/pthread_rdwr.h
+share/licq/sounds/Monty-Python.wav
+share/licq/sounds/fun/Auth.wav
+share/licq/sounds/fun/Chat.wav
+share/licq/sounds/fun/Contact.wav
+share/licq/sounds/fun/File.wav
+share/licq/sounds/fun/Message.wav
+share/licq/sounds/fun/Online.wav
+share/licq/sounds/fun/System.wav
+share/licq/sounds/fun/URL.wav
+share/licq/sounds/icq/Auth.wav
+share/licq/sounds/icq/Chat.wav
+share/licq/sounds/icq/Contact.wav
+share/licq/sounds/icq/File.wav
+share/licq/sounds/icq/Message.wav
+share/licq/sounds/icq/Online.wav
+share/licq/sounds/icq/System.wav
+share/licq/sounds/icq/URL.wav
share/licq/translations/ASCII
share/licq/translations/CP437
share/licq/translations/CP850
@@ -85,225 +80,28 @@ share/licq/translations/SWEDISH_NAMES_COM
share/licq/translations/SWISS
share/licq/translations/UNITED_KINGDOM
share/licq/translations/UNITED_KINGDOM_COM
-@dirrm share/licq/translations
-share/licq/sounds/Monty-Python.wav
-share/licq/sounds/fun/Auth.wav
-share/licq/sounds/fun/Chat.wav
-share/licq/sounds/fun/Contact.wav
-share/licq/sounds/fun/File.wav
-share/licq/sounds/fun/Message.wav
-share/licq/sounds/fun/Online.wav
-share/licq/sounds/fun/System.wav
-share/licq/sounds/fun/URL.wav
+share/licq/utilities/BackOrifice.utility
+share/licq/utilities/finger.utility
+share/licq/utilities/ftp.utility
+share/licq/utilities/gftp.utility
+share/licq/utilities/hostname.utility
+share/licq/utilities/kmail.utility
+share/licq/utilities/mutt.utility
+share/licq/utilities/netscape.utility
+share/licq/utilities/nmap.utility
+share/licq/utilities/pine.utility
+share/licq/utilities/ping.utility
+share/licq/utilities/queso.utility
+share/licq/utilities/speakfreely.utility
+share/licq/utilities/talk.utility
+share/licq/utilities/traceroute.utility
+share/licq/utilities/vnc.utility
+share/licq/utilities/xtraceroute.utility
+@dirrm include/licq
+@dirrm lib/licq
@dirrm share/licq/sounds/fun
-share/licq/sounds/icq/Auth.wav
-share/licq/sounds/icq/Chat.wav
-share/licq/sounds/icq/Contact.wav
-share/licq/sounds/icq/File.wav
-share/licq/sounds/icq/Message.wav
-share/licq/sounds/icq/Online.wav
-share/licq/sounds/icq/System.wav
-share/licq/sounds/icq/URL.wav
@dirrm share/licq/sounds/icq
@dirrm share/licq/sounds
-share/licq/qt-gui/locale/cs_CZ.qm
-share/licq/qt-gui/locale/de.qm
-share/licq/qt-gui/locale/es.qm
-share/licq/qt-gui/locale/fr.qm
-share/licq/qt-gui/locale/it.qm
-share/licq/qt-gui/locale/ja_JP.eucJP.qm
-share/licq/qt-gui/locale/pl.qm
-share/licq/qt-gui/locale/pt.qm
-share/licq/qt-gui/locale/ru_RU.KOI8-R.qm
-share/licq/qt-gui/locale/sv.qm
-share/licq/qt-gui/locale/tr.qm
-share/licq/qt-gui/locale/ru.qm
-share/licq/qt-gui/locale/cs.qm
-@dirrm share/licq/qt-gui/locale
-share/licq/qt-gui/skin.basic/basic.skin
-@dirrm share/licq/qt-gui/skin.basic
-share/licq/qt-gui/skin.basic-ncb/basic-ncb.skin
-@dirrm share/licq/qt-gui/skin.basic-ncb
-share/licq/qt-gui/skin.bheart/Frame.png
-share/licq/qt-gui/skin.bheart/MenuButtonDown.png
-share/licq/qt-gui/skin.bheart/MenuButtonUp.png
-share/licq/qt-gui/skin.bheart/MenuButtonlight.png
-share/licq/qt-gui/skin.bheart/README
-share/licq/qt-gui/skin.bheart/bheart.skin
-@dirrm share/licq/qt-gui/skin.bheart
-share/licq/qt-gui/skin.compact/button.png
-share/licq/qt-gui/skin.compact/compact.skin
-share/licq/qt-gui/skin.compact/frame.png
-share/licq/qt-gui/skin.compact/msg.png
-share/licq/qt-gui/skin.compact/status.png
-@dirrm share/licq/qt-gui/skin.compact
-share/licq/qt-gui/skin.dim/Frame.png
-share/licq/qt-gui/skin.dim/Label-small.png
-share/licq/qt-gui/skin.dim/MenuDown.png
-share/licq/qt-gui/skin.dim/MenuUpFocus.png
-share/licq/qt-gui/skin.dim/MenuUpNoFocus.png
-share/licq/qt-gui/skin.dim/Status.png
-share/licq/qt-gui/skin.dim/dim.skin
-share/licq/qt-gui/skin.dim/mask.png
-@dirrm share/licq/qt-gui/skin.dim
-share/licq/qt-gui/skin.e/butMenu.png
-share/licq/qt-gui/skin.e/butMenuDown.png
-share/licq/qt-gui/skin.e/butMenuFocus.png
-share/licq/qt-gui/skin.e/e.skin
-share/licq/qt-gui/skin.e/frame.png
-share/licq/qt-gui/skin.e/msg.png
-share/licq/qt-gui/skin.e/status.png
-@dirrm share/licq/qt-gui/skin.e
-share/licq/qt-gui/skin.gradient/background.png
-share/licq/qt-gui/skin.gradient/buttonLowered.png
-share/licq/qt-gui/skin.gradient/buttonRaised.png
-share/licq/qt-gui/skin.gradient/gradient.skin
-share/licq/qt-gui/skin.gradient/msg.png
-share/licq/qt-gui/skin.gradient/status.png
-@dirrm share/licq/qt-gui/skin.gradient
-share/licq/qt-gui/skin.icq/icq.skin
-@dirrm share/licq/qt-gui/skin.icq
-share/licq/qt-gui/skin.icq-ncb/icq-ncb.skin
-@dirrm share/licq/qt-gui/skin.icq-ncb
-share/licq/qt-gui/skin.pli/Frame.png
-share/licq/qt-gui/skin.pli/MenuButtonDown.png
-share/licq/qt-gui/skin.pli/MenuButtonUp.png
-share/licq/qt-gui/skin.pli/pli.skin
-@dirrm share/licq/qt-gui/skin.pli
-share/licq/qt-gui/skin.shale/butMenu.png
-share/licq/qt-gui/skin.shale/butMenuDown.png
-share/licq/qt-gui/skin.shale/butMenuFocus.png
-share/licq/qt-gui/skin.shale/frame.png
-share/licq/qt-gui/skin.shale/shale.skin
-share/licq/qt-gui/skin.shale/status.png
-@dirrm share/licq/qt-gui/skin.shale
-share/licq/qt-gui/dock.console/away.xpm
-share/licq/qt-gui/dock.console/bothmsg.xpm
-share/licq/qt-gui/dock.console/console.dock
-share/licq/qt-gui/dock.console/dnd.xpm
-share/licq/qt-gui/dock.console/ffc.xpm
-share/licq/qt-gui/dock.console/invisible.xpm
-share/licq/qt-gui/dock.console/mask.xpm
-share/licq/qt-gui/dock.console/na.xpm
-share/licq/qt-gui/dock.console/nomsg.xpm
-share/licq/qt-gui/dock.console/occupied.xpm
-share/licq/qt-gui/dock.console/offline.xpm
-share/licq/qt-gui/dock.console/online.xpm
-share/licq/qt-gui/dock.console/regmsg.xpm
-share/licq/qt-gui/dock.console/statusmask.xpm
-share/licq/qt-gui/dock.console/sysmsg.xpm
-@dirrm share/licq/qt-gui/dock.console
-share/licq/qt-gui/dock.flower/away.xpm
-share/licq/qt-gui/dock.flower/bothmsg.xpm
-share/licq/qt-gui/dock.flower/dnd.xpm
-share/licq/qt-gui/dock.flower/ffc.xpm
-share/licq/qt-gui/dock.flower/flower.dock
-share/licq/qt-gui/dock.flower/invisible.xpm
-share/licq/qt-gui/dock.flower/mask.xpm
-share/licq/qt-gui/dock.flower/na.xpm
-share/licq/qt-gui/dock.flower/nomsg.xpm
-share/licq/qt-gui/dock.flower/occupied.xpm
-share/licq/qt-gui/dock.flower/offline.xpm
-share/licq/qt-gui/dock.flower/online.xpm
-share/licq/qt-gui/dock.flower/regmsg.xpm
-share/licq/qt-gui/dock.flower/statusmask.xpm
-share/licq/qt-gui/dock.flower/sysmsg.xpm
-@dirrm share/licq/qt-gui/dock.flower
-share/licq/qt-gui/dock.flower-ns/flower-ns.dock
-share/licq/qt-gui/dock.flower-ns/nomsg-mask.xpm
-share/licq/qt-gui/dock.flower-ns/nomsg.xpm
-share/licq/qt-gui/dock.flower-ns/regmsg-mask.xpm
-share/licq/qt-gui/dock.flower-ns/regmsg.xpm
-@dirrm share/licq/qt-gui/dock.flower-ns
-share/licq/qt-gui/dock.glicq/glicq.dock
-share/licq/qt-gui/dock.glicq/msg.xpm
-share/licq/qt-gui/dock.glicq/nomsg.xpm
-share/licq/qt-gui/dock.glicq/sysmsg.xpm
-@dirrm share/licq/qt-gui/dock.glicq
-share/licq/qt-gui/dock.kde2/away.xpm
-share/licq/qt-gui/dock.kde2/bothmsg.xpm
-share/licq/qt-gui/dock.kde2/dnd.xpm
-share/licq/qt-gui/dock.kde2/ffc.xpm
-share/licq/qt-gui/dock.kde2/invisible.xpm
-share/licq/qt-gui/dock.kde2/kde2.dock
-share/licq/qt-gui/dock.kde2/mask.xpm
-share/licq/qt-gui/dock.kde2/na.xpm
-share/licq/qt-gui/dock.kde2/nomsg.xpm
-share/licq/qt-gui/dock.kde2/occupied.xpm
-share/licq/qt-gui/dock.kde2/offline.xpm
-share/licq/qt-gui/dock.kde2/online.xpm
-share/licq/qt-gui/dock.kde2/regmsg.xpm
-share/licq/qt-gui/dock.kde2/statusmask.xpm
-share/licq/qt-gui/dock.kde2/sysmsg.xpm
-@dirrm share/licq/qt-gui/dock.kde2
-share/licq/qt-gui/dock.pli/bothmsg.xpm
-share/licq/qt-gui/dock.pli/iconAway.xpm
-share/licq/qt-gui/dock.pli/iconDND.xpm
-share/licq/qt-gui/dock.pli/iconFFC.xpm
-share/licq/qt-gui/dock.pli/iconInvisible.xpm
-share/licq/qt-gui/dock.pli/iconNA.xpm
-share/licq/qt-gui/dock.pli/iconNoMsg.xpm
-share/licq/qt-gui/dock.pli/iconOccupied.xpm
-share/licq/qt-gui/dock.pli/iconOffline.xpm
-share/licq/qt-gui/dock.pli/iconOnline.xpm
-share/licq/qt-gui/dock.pli/mask.xpm
-share/licq/qt-gui/dock.pli/nomsg.xpm
-share/licq/qt-gui/dock.pli/pli.dock
-share/licq/qt-gui/dock.pli/regmsg.xpm
-share/licq/qt-gui/dock.pli/statusmask.xpm
-share/licq/qt-gui/dock.pli/sysmsg.xpm
-@dirrm share/licq/qt-gui/dock.pli
-share/licq/qt-gui/icons.computer/chat.xpm
-share/licq/qt-gui/icons.computer/chess.xpm
-share/licq/qt-gui/icons.computer/computer.icons
-share/licq/qt-gui/icons.computer/cross.xpm
-share/licq/qt-gui/icons.computer/ffchat.xpm
-share/licq/qt-gui/icons.computer/file.xpm
-share/licq/qt-gui/icons.computer/lock.xpm
-share/licq/qt-gui/icons.computer/message.xpm
-share/licq/qt-gui/icons.computer/offline.xpm
-share/licq/qt-gui/icons.computer/online.xpm
-share/licq/qt-gui/icons.computer/private.xpm
-share/licq/qt-gui/icons.computer/sign.xpm
-share/licq/qt-gui/icons.computer/url.xpm
-@dirrm share/licq/qt-gui/icons.computer
-share/licq/qt-gui/icons.icq/away.ppm
-share/licq/qt-gui/icons.icq/dnd.ppm
-share/licq/qt-gui/icons.icq/icq.icons
-share/licq/qt-gui/icons.icq/message.ppm
-share/licq/qt-gui/icons.icq/na.ppm
-share/licq/qt-gui/icons.icq/occupied.ppm
-share/licq/qt-gui/icons.icq/offline.ppm
-share/licq/qt-gui/icons.icq/online.ppm
-share/licq/qt-gui/icons.icq/private.ppm
-@dirrm share/licq/qt-gui/icons.icq
-share/licq/qt-gui/icons.icq2/away.xpm
-share/licq/qt-gui/icons.icq2/chat.xpm
-share/licq/qt-gui/icons.icq2/dnd.xpm
-share/licq/qt-gui/icons.icq2/ffc.xpm
-share/licq/qt-gui/icons.icq2/file.xpm
-share/licq/qt-gui/icons.icq2/icq2.icons
-share/licq/qt-gui/icons.icq2/invisible.xpm
-share/licq/qt-gui/icons.icq2/message.xpm
-share/licq/qt-gui/icons.icq2/na.xpm
-share/licq/qt-gui/icons.icq2/occ.xpm
-share/licq/qt-gui/icons.icq2/offline.xpm
-share/licq/qt-gui/icons.icq2/online.xpm
-share/licq/qt-gui/icons.icq2/url.xpm
-@dirrm share/licq/qt-gui/icons.icq2
-share/licq/qt-gui/icons.mark/away.ppm
-share/licq/qt-gui/icons.mark/chat.ppm
-share/licq/qt-gui/icons.mark/dnd.ppm
-share/licq/qt-gui/icons.mark/ffc.ppm
-share/licq/qt-gui/icons.mark/file.ppm
-share/licq/qt-gui/icons.mark/mark.icons
-share/licq/qt-gui/icons.mark/message.ppm
-share/licq/qt-gui/icons.mark/na.ppm
-share/licq/qt-gui/icons.mark/occupied.ppm
-share/licq/qt-gui/icons.mark/offline.ppm
-share/licq/qt-gui/icons.mark/online.ppm
-share/licq/qt-gui/icons.mark/private.ppm
-share/licq/qt-gui/icons.mark/url.ppm
-@dirrm share/licq/qt-gui/icons.mark
-@dirrm share/licq/qt-gui
+@dirrm share/licq/translations
+@dirrm share/licq/utilities
@dirrm share/licq