aboutsummaryrefslogtreecommitdiff
path: root/net-im/loudmouth
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-03-27 14:57:59 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-03-27 14:57:59 +0000
commit6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418 (patch)
tree95ab4f85bf7bf8cb530a6cecc47ac36a30dcab4b /net-im/loudmouth
parent37e8aaec0258c9c628ea0ecb9fd1f26a00577d4b (diff)
downloadports-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.tar.gz
ports-6bc6f3a9e07f4647594e7ad34d21cff7b6cd3418.zip
- Update security/gnutls to 3.4.10.
- Rename the LIBDANE option DANE because that's the name of the protocol supported by libgnutls-dane and gnutls-cli. Also clarify the option description. - Add an IDN option. - libgnutls-openssl has been removed in 3.4. Some ports used this library in their LIB_DEPENDS but no port actually required it. - Some old API functions have been removed. Ports that used these have been updated or patched to use the new API. - Add a patch to print/cups to prevent overlinking of libgnutls.so. - Bump PORTREVISION on dependent ports. net-im/jabber: This port used the old API to give users fine grained control over which crypto algorithms were used via a configuration file. It's not immediately obvious how to port this to the new API so the port always uses the defaults now. www/hydra: Mark BROKEN. This uses more removed calls than the other ports, is said to be alpha quality and not fully functional and has been abandoned 10 years ago. PR: 207768 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=411990
Diffstat (limited to 'net-im/loudmouth')
-rw-r--r--net-im/loudmouth/Makefile33
-rw-r--r--net-im/loudmouth/distinfo4
-rw-r--r--net-im/loudmouth/files/patch-configure28
-rw-r--r--net-im/loudmouth/files/patch-loudmouth_Makefile.in12
-rw-r--r--net-im/loudmouth/files/patch-loudmouth_lm-error.c11
-rw-r--r--net-im/loudmouth/files/patch-loudmouth_lm-ssl-gnutls.c28
-rw-r--r--net-im/loudmouth/pkg-descr2
-rw-r--r--net-im/loudmouth/pkg-plist38
8 files changed, 37 insertions, 119 deletions
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index 1ab625ec2511..b9a502b49517 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -3,27 +3,28 @@
# $MCom: ports/trunk/net-im/loudmouth/Makefile 19914 2014-09-25 22:33:21Z kwm $
PORTNAME= loudmouth
-PORTVERSION= 1.4.3
-PORTREVISION= 11
-CATEGORIES= net-im gnome
-MASTER_SITES= GNOME
+PORTVERSION= 1.5.3
+CATEGORIES= net-im
+MASTER_SITES= https://mcabber.com/files/loudmouth/ \
+ http://www.lilotux.net/~mikael/mcabber/files/loudmouth/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Lightweight Jabber client library
-LICENSE= GPLv2
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn
-USES= gettext gmake libtool pathfix pkgconfig tar:bzip2
+USES= gettext gmake libtool pkgconfig tar:bzip2
USE_GNOME= glib20
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-gtk-doc
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -Wl,-Bsymbolic -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-gtk-doc --disable-rebuilds \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT=GNUTLS
OPTIONS_RADIO= SSL
OPTIONS_RADIO_SSL= GNUTLS OPENSSL
@@ -32,21 +33,13 @@ OPTIONS_RADIO_SSL= GNUTLS OPENSSL
.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
-RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-.endif
-
-.if ${PORT_OPTIONS:MOPENSSL}
+CONFIGURE_ARGS+=--with-ssl=gnutls
+.elif ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ssl=openssl
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
-.endif
-
-.if !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MOPENSSL}
+.else
CONFIGURE_ARGS+=--without-ssl
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/loudmouth/lm-ssl-gnutls.c
-
.include <bsd.port.mk>
diff --git a/net-im/loudmouth/distinfo b/net-im/loudmouth/distinfo
index 703c9f195e78..0ec15d3ab041 100644
--- a/net-im/loudmouth/distinfo
+++ b/net-im/loudmouth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (loudmouth-1.4.3.tar.bz2) = 95a93f5d009b71ea8193d994aa11f311bc330a3efe1b7cd74dc48f11c7f929e3
-SIZE (loudmouth-1.4.3.tar.bz2) = 366818
+SHA256 (loudmouth-1.5.3.tar.bz2) = 54329415cb1bacb783c20f5f1f975de4fc460165d0d8a1e3b789367b5f69d32c
+SIZE (loudmouth-1.5.3.tar.bz2) = 375974
diff --git a/net-im/loudmouth/files/patch-configure b/net-im/loudmouth/files/patch-configure
deleted file mode 100644
index 2c37af283331..000000000000
--- a/net-im/loudmouth/files/patch-configure
+++ /dev/null
@@ -1,28 +0,0 @@
---- configure.orig 2009-08-17 03:50:55.000000000 -0400
-+++ configure 2009-08-17 03:50:59.000000000 -0400
-@@ -21983,12 +21983,14 @@ fi
- if test x$libgnutls_config_prefix != x ; then
- libgnutls_config_args="$libgnutls_config_args --prefix=$libgnutls_config_prefix"
- if test x${LIBGNUTLS_CONFIG+set} != xset ; then
-- LIBGNUTLS_CONFIG=$libgnutls_config_prefix/bin/libgnutls-config
-+ LIBGNUTLS_CONFIG=pkg-config
- fi
- fi
-
-+ libgnutls_config_args="$libgnutls_config_args gnutls"
-+
- # Extract the first word of "libgnutls-config", so it can be a program name with args.
--set dummy libgnutls-config; ac_word=$2
-+set dummy pkg-config; ac_word=$2
- { echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6; }
- if test "${ac_cv_path_LIBGNUTLS_CONFIG+set}" = set; then
-@@ -22037,7 +22039,7 @@ echo $ECHO_N "checking for libgnutls - v
- else
- LIBGNUTLS_CFLAGS=`$LIBGNUTLS_CONFIG $libgnutls_config_args --cflags`
- LIBGNUTLS_LIBS=`$LIBGNUTLS_CONFIG $libgnutls_config_args --libs`
-- libgnutls_config_version=`$LIBGNUTLS_CONFIG $libgnutls_config_args --version`
-+ libgnutls_config_version=`$LIBGNUTLS_CONFIG $libgnutls_config_args --modversion`
-
-
- ac_save_CFLAGS="$CFLAGS"
diff --git a/net-im/loudmouth/files/patch-loudmouth_Makefile.in b/net-im/loudmouth/files/patch-loudmouth_Makefile.in
deleted file mode 100644
index 99c8782e6ced..000000000000
--- a/net-im/loudmouth/files/patch-loudmouth_Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- loudmouth/Makefile.in.orig 2008-07-06 15:44:25.000000000 -0400
-+++ loudmouth/Makefile.in 2008-07-06 15:43:53.000000000 -0400
-@@ -306,8 +306,7 @@ libloudmouthinclude_HEADERS = \
-
- libloudmouth_1_la_LIBADD = \
- $(LOUDMOUTH_LIBS) \
-- $(LIBIDN_LIBS) \
-- -lresolv
-+ $(LIBIDN_LIBS)
-
- libloudmouth_1_la_LDFLAGS = \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
diff --git a/net-im/loudmouth/files/patch-loudmouth_lm-error.c b/net-im/loudmouth/files/patch-loudmouth_lm-error.c
deleted file mode 100644
index 61f65fce2447..000000000000
--- a/net-im/loudmouth/files/patch-loudmouth_lm-error.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- loudmouth/lm-error.c.orig 2012-05-22 10:05:29.000000000 +0200
-+++ loudmouth/lm-error.c 2012-05-22 10:05:41.000000000 +0200
-@@ -19,7 +19,7 @@
- */
-
- #include <config.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include "lm-error.h"
-
- /**
diff --git a/net-im/loudmouth/files/patch-loudmouth_lm-ssl-gnutls.c b/net-im/loudmouth/files/patch-loudmouth_lm-ssl-gnutls.c
deleted file mode 100644
index 5a202430c684..000000000000
--- a/net-im/loudmouth/files/patch-loudmouth_lm-ssl-gnutls.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- loudmouth/lm-ssl-gnutls.c.orig 2010-04-17 15:56:39.000000000 -0400
-+++ loudmouth/lm-ssl-gnutls.c 2010-04-17 15:56:43.000000000 -0400
-@@ -32,7 +32,7 @@
-
- #include <gnutls/x509.h>
-
--#define CA_PEM_FILE "/etc/ssl/certs/ca-certificates.crt"
-+#define CA_PEM_FILE "%%LOCALBASE%%/share/certs/ca-root-nss.crt"
-
- struct _LmSSL {
- LmSSLBase base;
-@@ -200,6 +200,7 @@ _lm_ssl_begin (LmSSL *ssl, gint fd, cons
- { GNUTLS_CRT_X509, GNUTLS_CRT_OPENPGP, 0 };
- const int compression_priority[] =
- { GNUTLS_COMP_DEFLATE, GNUTLS_COMP_NULL, 0 };
-+ gnutls_priority_t priorities_cache;
-
- gnutls_init (&ssl->gnutls_session, GNUTLS_CLIENT);
- gnutls_set_default_priority (ssl->gnutls_session);
-@@ -213,6 +214,8 @@ _lm_ssl_begin (LmSSL *ssl, gint fd, cons
-
- gnutls_transport_set_ptr (ssl->gnutls_session,
- (gnutls_transport_ptr_t)(glong) fd);
-+ gnutls_priority_init (&priorities_cache, "NONE:+VERS-TLS1.0:+AES-128-CBC:+RSA:+SHA1:+COMP-NULL:NORMAL:%COMPAT", NULL);
-+ gnutls_priority_set (ssl->gnutls_session, priorities_cache);
-
- ret = gnutls_handshake (ssl->gnutls_session);
-
diff --git a/net-im/loudmouth/pkg-descr b/net-im/loudmouth/pkg-descr
index bd4242f0e024..6fda35f7d6d7 100644
--- a/net-im/loudmouth/pkg-descr
+++ b/net-im/loudmouth/pkg-descr
@@ -1,3 +1,5 @@
Loudmouth is a lightweight and easy-to-use C library for programming with the
Jabber protocol. It's designed to be easy to get started with and yet
extensible to let you do anything the Jabber protocol allows.
+
+WWW: https://mcabber.com/
diff --git a/net-im/loudmouth/pkg-plist b/net-im/loudmouth/pkg-plist
index a7824e37d336..656f333df002 100644
--- a/net-im/loudmouth/pkg-plist
+++ b/net-im/loudmouth/pkg-plist
@@ -12,21 +12,23 @@ lib/libloudmouth-1.so
lib/libloudmouth-1.so.0
lib/libloudmouth-1.so.0.1.0
libdata/pkgconfig/loudmouth-1.0.pc
-share/gtk-doc/html/loudmouth/ch01.html
-share/gtk-doc/html/loudmouth/home.png
-share/gtk-doc/html/loudmouth/index.html
-share/gtk-doc/html/loudmouth/index.sgml
-share/gtk-doc/html/loudmouth/left.png
-share/gtk-doc/html/loudmouth/loudmouth-lm-connection.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-error.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-message-handler.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-message.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-message-node.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-proxy.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-ssl.html
-share/gtk-doc/html/loudmouth/loudmouth-lm-utils.html
-share/gtk-doc/html/loudmouth/loudmouth.devhelp
-share/gtk-doc/html/loudmouth/loudmouth.devhelp2
-share/gtk-doc/html/loudmouth/right.png
-share/gtk-doc/html/loudmouth/style.css
-share/gtk-doc/html/loudmouth/up.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/ch01.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/home.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/index.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/index.sgml
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/left-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/left.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmConnection.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmError.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmMessage.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmMessageHandler.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmMessageNode.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmProxy.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-LmSSL.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth-Miscellaneous-Utility-Functions.html
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/loudmouth.devhelp2
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/right-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/right.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/style.css
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/up-insensitive.png
+%%PORTDOCS%%share/gtk-doc/html/loudmouth/up.png