aboutsummaryrefslogtreecommitdiff
path: root/net-im/loudmouth
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/loudmouth
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/loudmouth')
-rw-r--r--net-im/loudmouth/Makefile25
-rw-r--r--net-im/loudmouth/files/patch-loudmouth_lm-error.c11
2 files changed, 22 insertions, 14 deletions
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index ae26d4726e5a..ffc876b020ab 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: loudmouth
-# Date created: 08 July 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= loudmouth
PORTVERSION= 1.4.3
@@ -14,7 +10,7 @@ MASTER_SITES= GNOME
MAINTAINER= gnome@FreeBSD.org
COMMENT= Lightweight Jabber client library
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn
+LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn
USE_BZIP2= yes
USE_GMAKE= yes
@@ -26,23 +22,24 @@ CONFIGURE_ARGS= --disable-gtk-doc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -Wl,-Bsymbolic -L${LOCALBASE}/lib
-OPTIONS= GNUTLS "Enable SSL (via GnuTLS) support" on \
- OPENSSL "Enable SSL (via OpenSSL) support" off
+OPTIONS_DEFAULT=GNUTLS
+OPTIONS_RADIO= SSL
+OPTIONS_RADIO_SSL= GNUTLS OPENSSL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GNUTLS)
-LIB_DEPENDS+= gnutls.26:${PORTSDIR}/security/gnutls
+.if ${PORT_OPTIONS:MGNUTLS}
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
.endif
-.if defined(WITH_OPENSSL)
+.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ssl=openssl
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
.endif
-.if !defined(WITH_GNUTLS) && !defined(WITH_OPENSSL)
+.if !${PORT_OPTIONS:MGNUTLS} && !${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+=--without-ssl
.endif
@@ -50,4 +47,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/loudmouth/lm-ssl-gnutls.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/loudmouth/files/patch-loudmouth_lm-error.c b/net-im/loudmouth/files/patch-loudmouth_lm-error.c
new file mode 100644
index 000000000000..61f65fce2447
--- /dev/null
+++ b/net-im/loudmouth/files/patch-loudmouth_lm-error.c
@@ -0,0 +1,11 @@
+--- loudmouth/lm-error.c.orig 2012-05-22 10:05:29.000000000 +0200
++++ loudmouth/lm-error.c 2012-05-22 10:05:41.000000000 +0200
+@@ -19,7 +19,7 @@
+ */
+
+ #include <config.h>
+-#include <glib/gerror.h>
++#include <glib.h>
+ #include "lm-error.h"
+
+ /**