aboutsummaryrefslogtreecommitdiff
path: root/net-im/neochat
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-11-20 22:23:30 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-11-20 22:23:30 +0000
commit238967e2daa6a870ed2a90429f115aa6e99aefd9 (patch)
tree77f746862eecc2b7245975f9a56fc8af2933d020 /net-im/neochat
parent1700edcf38d6fe6afb694517c4b630f72a168424 (diff)
downloadports-238967e2daa6a870ed2a90429f115aa6e99aefd9.tar.gz
ports-238967e2daa6a870ed2a90429f115aa6e99aefd9.zip
New port: net-im/neochat
neochat is a KDE fork of net-im/spectral, using KDE technologies on top of the Qt bits from spectral. It's not clear if spectral is still being developed. If not, I'll deprecate the spectral port in a while. One UI glitch is present, because of KDE Frameworks 5.75 -- the requirement for 5.76 is patched out in the port, because 5.76 has not landed yet.
Notes
Notes: svn path=/head/; revision=555794
Diffstat (limited to 'net-im/neochat')
-rw-r--r--net-im/neochat/Makefile34
-rw-r--r--net-im/neochat/distinfo3
-rw-r--r--net-im/neochat/files/patch-CMakeLists.txt11
-rw-r--r--net-im/neochat/pkg-descr5
-rw-r--r--net-im/neochat/pkg-plist5
5 files changed, 58 insertions, 0 deletions
diff --git a/net-im/neochat/Makefile b/net-im/neochat/Makefile
new file mode 100644
index 000000000000..c83b73539461
--- /dev/null
+++ b/net-im/neochat/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= neochat
+PORTVERSION= 0.1.0
+CATEGORIES= net-im
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Glossy Matrix IM client based on KDE technologies
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSES/GPL-3.0-only.txt
+
+LIB_DEPENDS= libcmark.so:textproc/cmark \
+ libqt5keychain.so:security/qtkeychain
+BUILD_DEPENDS= libquotient>=0.6.2:net-im/libquotient
+
+USES= cmake compiler:c++17-lang gl kde:5 pkgconfig qt:5 tar:bz2
+USE_GL= gl
+USE_QT= core dbus declarative graphicaleffects gui imageformats \
+ multimedia network quickcontrols quickcontrols2 \
+ svg widgets xml \
+ buildtools_build linguist_build qmake_build
+USE_KDE= config i18n kirigami2 notifications \
+ ecm_build
+
+COMMIT= 1c6f1f7353dee450228d14a44f4d23968a4d890d
+DISTFILES= ${PORTNAME}-${COMMIT}.tar.bz2:neochat
+MASTER_SITES= https://invent.kde.org/network/${PORTNAME}/-/archive/${COMMIT}/:neochat
+
+# This is a hack before the first KDE release service release, since we're
+# fetching GIT hashes rather than a tidy tarball.
+WRKSRC= ${WRKDIR}/${PORTNAME}-${COMMIT}
+
+.include <bsd.port.mk>
diff --git a/net-im/neochat/distinfo b/net-im/neochat/distinfo
new file mode 100644
index 000000000000..4298c16f9347
--- /dev/null
+++ b/net-im/neochat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1605890058
+SHA256 (neochat-1c6f1f7353dee450228d14a44f4d23968a4d890d.tar.bz2) = 67a2f558f137ee9babdd4e6b029e950819f5481d2e1edc706c35fa3c425b2c3d
+SIZE (neochat-1c6f1f7353dee450228d14a44f4d23968a4d890d.tar.bz2) = 131918
diff --git a/net-im/neochat/files/patch-CMakeLists.txt b/net-im/neochat/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..483c192697d3
--- /dev/null
+++ b/net-im/neochat/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2020-11-20 16:39:59 UTC
++++ CMakeLists.txt
+@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.1)
+
+ project(Neochat)
+
+-set(KF5_MIN_VERSION "5.76.0")
++set(KF5_MIN_VERSION "5.75.0")
+ set(QT_MIN_VERSION "5.15.0")
+
+ find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
diff --git a/net-im/neochat/pkg-descr b/net-im/neochat/pkg-descr
new file mode 100644
index 000000000000..d0185becfb63
--- /dev/null
+++ b/net-im/neochat/pkg-descr
@@ -0,0 +1,5 @@
+Neochat is a client for Matrix, the decentralized communication protocol
+for instant messaging. It is a fork of Spectral, using KDE frameworks,
+most notably Kirigami, KConfig and KI18n.
+
+WWW: https://invent.kde.org/network/neochat
diff --git a/net-im/neochat/pkg-plist b/net-im/neochat/pkg-plist
new file mode 100644
index 000000000000..970ccd890197
--- /dev/null
+++ b/net-im/neochat/pkg-plist
@@ -0,0 +1,5 @@
+bin/neochat
+share/applications/org.kde.neochat.desktop
+share/icons/hicolor/scalable/apps/neochat.svg
+share/knotifications5/neochat.notifyrc
+share/metainfo/org.kde.neochat.appdata.xml