aboutsummaryrefslogtreecommitdiff
path: root/net-im/nheko
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-03-06 21:32:42 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-03-06 21:34:19 +0000
commit3450e834d4e19eef34def6ba009fc94ca70e8c66 (patch)
tree32f5d7383c76b686e893494543b19310c487b4b4 /net-im/nheko
parent40b7d72e022a0c1db66feaf306888639774662bc (diff)
downloadports-3450e834d4e19eef34def6ba009fc94ca70e8c66.tar.gz
ports-3450e834d4e19eef34def6ba009fc94ca70e8c66.zip
net-im/nheko: update to 0.11.3 (also dependencies)
Update the nheko stack - coeurl, mtxclient, nheko - to the latest release. Try to add a VOIP option for Matrix VOIP calls.
Diffstat (limited to 'net-im/nheko')
-rw-r--r--net-im/nheko/Makefile15
-rw-r--r--net-im/nheko/distinfo6
-rw-r--r--net-im/nheko/files/patch-src_notifications_Manager.h12
3 files changed, 27 insertions, 6 deletions
diff --git a/net-im/nheko/Makefile b/net-im/nheko/Makefile
index bbefd843b8d6..9e4a59365576 100644
--- a/net-im/nheko/Makefile
+++ b/net-im/nheko/Makefile
@@ -1,7 +1,6 @@
PORTNAME= nheko
DISTVERSIONPREFIX=v
-DISTVERSION= 0.10.2
-PORTREVISION= 1
+DISTVERSION= 0.11.3
CATEGORIES= net-im
MAINTAINER= adridg@FreeBSD.org
@@ -32,10 +31,20 @@ USE_QT= concurrent core dbus declarative gui multimedia network \
graphicaleffects:run \
buildtools:build linguist:build qmake:build
+OPTIONS_DEFINE= VOIP
+OPTIONS_DEFAULT=
+
+VOIP_DESC= Enable VOIP calls (experimental)
+VOIP_CMAKE_BOOL= VOIP
+VOIP_USES= gstreamer gettext-runtime
+VOIP_USE_GSTREAMER1= bad dtls srtp
+VOIP_USE_XORG= xcb
+VOIP_USE_GNOME= glib20
+VOIP_LIB_DEPENDS= libnice.so:net-im/libnice
+
# There is one external dependency: lmdb++
# - lmdb++ is a single header file, it just needs to be included
CMAKE_ARGS= -DLMDBXX_INCLUDE_DIR=${WRKSRC}/deps/lmdb \
- -DVOIP=OFF \
-DCMAKE_INSTALL_MANDIR=share/man
CFLAGS+= -DSPDLOG_FMT_EXTERNAL=1
LDFLAGS+= -L${LOCALBASE}/lib -lfmt
diff --git a/net-im/nheko/distinfo b/net-im/nheko/distinfo
index f5ddc44114f5..e1696c765077 100644
--- a/net-im/nheko/distinfo
+++ b/net-im/nheko/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1665094209
-SHA256 (Nheko-Reborn-nheko-v0.10.2_GH0.tar.gz) = 00a0da9f134e070753efefc3bc86802b60fe385f2dea937979c0824634b4c248
-SIZE (Nheko-Reborn-nheko-v0.10.2_GH0.tar.gz) = 1608905
+TIMESTAMP = 1678131554
+SHA256 (Nheko-Reborn-nheko-v0.11.3_GH0.tar.gz) = f285156884a3a0c6870f3fba89c13d1fd70c8727bd179d8310b13819f8a63a37
+SIZE (Nheko-Reborn-nheko-v0.11.3_GH0.tar.gz) = 1780179
SHA256 (hoytech-lmdbxx-029fb681213af3020f5e3a86045445552bd024c5_GH0.tar.gz) = f1d048d7ec720667a3ea091ed44f06eb79171e77d646a59dac45b9e5ff75f33b
SIZE (hoytech-lmdbxx-029fb681213af3020f5e3a86045445552bd024c5_GH0.tar.gz) = 52468
diff --git a/net-im/nheko/files/patch-src_notifications_Manager.h b/net-im/nheko/files/patch-src_notifications_Manager.h
new file mode 100644
index 000000000000..fcb2b875f358
--- /dev/null
+++ b/net-im/nheko/files/patch-src_notifications_Manager.h
@@ -0,0 +1,12 @@
+--- src/notifications/Manager.h.orig 2023-02-24 22:16:17 UTC
++++ src/notifications/Manager.h
+@@ -55,9 +55,7 @@ public slots:
+ #if defined(NHEKO_DBUS_SYS)
+ public:
+ void closeNotifications(QString roomId);
+-#if defined(Q_OS_LINUX)
+ void closeAllNotifications();
+-#endif
+
+ private:
+ QDBusInterface dbus;